aboutsummaryrefslogtreecommitdiff
path: root/mail/courier
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2008-12-19 12:42:03 +0000
committerStefan Walter <stefan@FreeBSD.org>2008-12-19 12:42:03 +0000
commitd7849bb0a24f53a6c5b9dbfb6bda3cb58bc5b4e2 (patch)
tree19bcc3451e3ec1cc19347eb000255cc2033ebf8f /mail/courier
parentb1fc579d1d31ce6ede5b2b89e4333ef85fec33ea (diff)
downloadports-d7849bb0a24f53a6c5b9dbfb6bda3cb58bc5b4e2.tar.gz
ports-d7849bb0a24f53a6c5b9dbfb6bda3cb58bc5b4e2.zip
Notes
Diffstat (limited to 'mail/courier')
-rw-r--r--mail/courier/Makefile29
-rw-r--r--mail/courier/Makefile.man3
-rw-r--r--mail/courier/Makefile.own4
-rw-r--r--mail/courier/distinfo6
-rw-r--r--mail/courier/files/courier.sh.in18
-rw-r--r--mail/courier/files/patch-courier__cmlm.h11
-rw-r--r--mail/courier/files/patch-courier__perms.sh.in19
-rw-r--r--mail/courier/pkg-plist219
-rw-r--r--mail/courier/scripts/c_rehash160
9 files changed, 90 insertions, 379 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index ade22363a6b2..69f5ff595387 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= courier
-PORTVERSION= 0.54.0
-PORTREVISION= 1
+PORTVERSION= 0.60.0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -20,13 +19,16 @@ LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base \
${LOCALBASE}/share/sysconftool/sysconftool:${PORTSDIR}/devel/sysconftool \
${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support \
- ${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR
+ ${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
+ ca_root_nss>=3.*:${PORTSDIR}/security/ca_root_nss
-CONFLICTS= exim-4.* courier-imap-2.* maildrop-1.* \
+CONFLICTS= courier-imap-2.* couriermlm-0.* \
+ exim-4.* maildrop-1.* \
postfix-1.* postfix-2.* \
- qmail-1.* qmail-*-1.* \
- sendmail-8.* sendmail-*-8.* \
- smail-3.* sqwebmail-3.* zmailer-2.*
+ qmail-*-1.* qmail-1.* \
+ sendmail-*-8.* sendmail-8.* \
+ smail-3.* sqwebmail-3.* \
+ zmailer-2.*
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
@@ -73,8 +75,7 @@ USE_RC_SUBR= courier.sh
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= REHASH=${SCRIPTDIR}/c_rehash \
- CPPFLAGS='${CPPFLAGS}' \
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' \
LDFLAGS='${LDFLAGS}'
MAKE_ENV:= ${CONFIGURE_ENV}
@@ -268,15 +269,15 @@ pre-patch:
post-patch:
@${REINPLACE_CMD} -e 's|^PROG=\./|PROG=exec ./|g' \
${WRKSRC}/courier/module.*/courier.config
- @${REINPLACE_CMD} -e 's|@datadir@|@sysconfdir@|g' \
+ @${REINPLACE_CMD} -e 's|@mydatadir@|@sysconfdir@|g' \
${WRKSRC}/*/mk*cert.* \
${WRKSRC}/*/*/mk*cert.*
- @${REINPLACE_CMD} -e 's|^\(TLS_CERTFILE=\)@datadir@|\1@sysconfdir@|g' \
+ @${REINPLACE_CMD} -e 's|^\(TLS_CERTFILE=\)@mydatadir@|\1@sysconfdir@|g' \
${WRKSRC}/*/*.dist.in \
${WRKSRC}/*/*/*.dist.in
- @${REINPLACE_CMD} -e 's|^\(RANDFILE = \)@datadir@[^[:space:]]*|\1@sysconfdir@/random.tmp|g' \
- ${WRKSRC}/*/*.cnf.in \
- ${WRKSRC}/*/*/*.cnf.in
+ @${REINPLACE_CMD} -e 's|^\(RANDFILE[[:space:]]*=[[:space:]]*\)@mydatadir@|\1@sysconfdir@|g' \
+ ${WRKSRC}/*/*.cnf.openssl.in \
+ ${WRKSRC}/*/*/*.cnf.openssl.in
@${REINPLACE_CMD} -e 's|$$(INSTALL_DATA) \(.$$$$file.\)|${INSTALL_MAN} \1|' \
${WRKSRC}/Makefile.in \
${WRKSRC}/*/Makefile.in \
diff --git a/mail/courier/Makefile.man b/mail/courier/Makefile.man
index f4cd921e08e7..3b9219e30260 100644
--- a/mail/courier/Makefile.man
+++ b/mail/courier/Makefile.man
@@ -18,7 +18,8 @@ MAN1= \
reformail.1 \
reformime.1 \
sendmail.1 \
- testmxlookup.1
+ testmxlookup.1 \
+ webmlmd.1
MAN5= \
dot-courier.5 \
maildir.5
diff --git a/mail/courier/Makefile.own b/mail/courier/Makefile.own
index 632b6777ff28..daa607a972cb 100644
--- a/mail/courier/Makefile.own
+++ b/mail/courier/Makefile.own
@@ -16,6 +16,8 @@ OWNER0= bin/courier-config \
bin/reformime \
bin/sendmail \
bin/testmxlookup \
+ bin/webmlmd \
+ bin/webmlmd.rc \
etc/courier/courierd.dist \
etc/courier/enablefiltering \
etc/courier/esmtp.authpam \
@@ -42,6 +44,7 @@ OWNER0= bin/courier-config \
etc/courier/rfcerrheader.txt \
etc/courier/smtpaccess/default \
etc/courier/webmail.authpam \
+ etc/courier/webmlmrc.dist \
libexec/courier/courierpop3d \
libexec/courier/courierpop3login \
libexec/courier/imaplogin \
@@ -51,6 +54,7 @@ OWNER0= bin/courier-config \
libexec/courier/sqwebmaild \
libexec/courier/webmail/webadmin \
libexec/courier/webmail/webmail \
+ libexec/courier/webmail/webmlm \
libexec/filters/dupfilter \
libexec/filters/perlfilter \
sbin/courier \
diff --git a/mail/courier/distinfo b/mail/courier/distinfo
index 98836f6ff4d8..09feb669a33b 100644
--- a/mail/courier/distinfo
+++ b/mail/courier/distinfo
@@ -1,3 +1,3 @@
-MD5 (courier-0.54.0.tar.bz2) = 9495a444ecaa7920da478584969d8e4e
-SHA256 (courier-0.54.0.tar.bz2) = 63c860edd57f61ae93e1bcb3cf1739c14fc6c28c22e9913938a70459e68718e3
-SIZE (courier-0.54.0.tar.bz2) = 7028765
+MD5 (courier-0.60.0.tar.bz2) = 688d4b44c0d7438c5c47c0a65835846d
+SHA256 (courier-0.60.0.tar.bz2) = c13da0a0b76c4a59aa219d037129b8305293d1091143027f2dfd631b9e470e64
+SIZE (courier-0.60.0.tar.bz2) = 7067430
diff --git a/mail/courier/files/courier.sh.in b/mail/courier/files/courier.sh.in
index 7ad2acdb899a..a2ec2e2f7fa4 100644
--- a/mail/courier/files/courier.sh.in
+++ b/mail/courier/files/courier.sh.in
@@ -247,12 +247,30 @@ courier_start()
esac
fi
echo "."
+
+ LISTS=""
+ if [ -f ${sysconfdir}/webmlmrc ]; then
+ . ${sysconfdir}/webmlmrc
+ if [ -n "$LISTS" ];then
+ if [ -x ${bindir}/webmlmd \
+ -a -x ${bindir}/webmlmd.rc ]; then
+ echo -n " webmlmd"
+ ${bindir}/webmlmd.rc start ${sysconfdir}/webmlmrc
+ fi
+ fi
+ fi
}
courier_stop()
{ # kill courier services in the reverse order of starting them
echo -n "Stopping"
+ if [ -x ${bindir}/webmlmd \
+ -a -x ${bindir}/webmlmd.rc ]; then
+ echo -n " webmlmd"
+ ${bindir}/webmlmd.rc stop ${sysconfdir}/webmlmrc
+ fi
+
if [ -x ${sbindir}/pop3d-ssl ]; then
echo -n " pop3d-ssl"
${sbindir}/pop3d-ssl stop
diff --git a/mail/courier/files/patch-courier__cmlm.h b/mail/courier/files/patch-courier__cmlm.h
new file mode 100644
index 000000000000..f38f744a4dc2
--- /dev/null
+++ b/mail/courier/files/patch-courier__cmlm.h
@@ -0,0 +1,11 @@
+--- courier/cmlm.h.orig 2007-04-29 11:59:40.000000000 -0400
++++ courier/cmlm.h 2007-04-29 11:59:40.000000000 -0400
+@@ -56,7 +56,7 @@
+
+ #include "bindir.h"
+
+-#define SENDMAIL BINDIR "/sendmail"
++#define SENDMAIL "/usr/sbin/sendmail"
+ #define REFORMIME BINDIR "/reformime"
+ #define MAXRCPTS 20
+
diff --git a/mail/courier/files/patch-courier__perms.sh.in b/mail/courier/files/patch-courier__perms.sh.in
index 03feaf7a3202..fe80b2bf349b 100644
--- a/mail/courier/files/patch-courier__perms.sh.in
+++ b/mail/courier/files/patch-courier__perms.sh.in
@@ -1,7 +1,7 @@
---- courier/perms.sh.in.orig Thu Jan 27 21:53:58 2005
-+++ courier/perms.sh.in Thu Jan 27 21:53:58 2005
-@@ -10,9 +10,6 @@
- exec_prefix="@exec_prefix@"
+--- courier/perms.sh.in.orig 2007-07-01 11:36:31.000000000 -0400
++++ courier/perms.sh.in 2007-07-01 11:36:31.000000000 -0400
+@@ -11,9 +11,6 @@
+ datarootdir="@datarootdir@"
PERMS="
-. 755
@@ -10,7 +10,7 @@
@localstatedir@/tmp 770
@localstatedir@/msgs 750
@localstatedir@/msgq 750
-@@ -45,7 +42,6 @@
+@@ -47,7 +44,6 @@
@sysconfdir@/rfcerr2046.txt 444 config
@sysconfdir@/rfcerr2047.txt 444 config
@@ -18,13 +18,14 @@
@libexecdir@/courier 755 x bin bin
@libexecdir@/courier/modules 755 x bin bin
@libexecdir@/courier/submitmkdir 4550
-@@ -59,13 +55,12 @@
+@@ -61,14 +57,13 @@
@libexecdir@/courier/makedatprog 555
@libexecdir@/courier/imaplogin 555 x bin bin
@libexecdir@/courier/pcpd 555 x bin bin
-@libexecdir@/courier/webmail 700 x root bin
+@libexecdir@/courier/webmail 500 x root bin
@libexecdir@/courier/webmail/webmail 555 x root bin
+ @libexecdir@/courier/webmail/webmlm 555 x root bin
@libexecdir@/courier/sqwebmaild 555
-@libexecdir@/courier/sqwebpasswd 2755
-@libexecdir@/courier/webmail/webadmin 4555 x root bin
@@ -35,7 +36,7 @@
@sbindir@/courier 555
@sbindir@/showconfig 555
@sbindir@/showmodules 550
-@@ -78,7 +73,6 @@
+@@ -82,7 +77,6 @@
@datadir@/imapd 555 x bin bin
@datadir@/imapd-ssl 555 x bin bin
@@ -43,7 +44,7 @@
@bindir@/cancelmsg 6555
@bindir@/courier-config 555
@bindir@/mailq 2555
-@@ -105,10 +99,10 @@
+@@ -111,10 +105,10 @@
@sbindir@/makealiases 550
@datadir@/makehosteddomains 555
@sbindir@/makehosteddomains 555
@@ -58,7 +59,7 @@
@sbindir@/webgpg 555
@datadir@ 755 x bin bin
-@@ -202,7 +196,7 @@
+@@ -226,7 +220,7 @@
if test "@HAVE_LDAP@" != 0
then
echo @sysconfdir@/ldapaliasrc.dist 640 @mailuser@ @mailgroup@ config
diff --git a/mail/courier/pkg-plist b/mail/courier/pkg-plist
index c4de58cd41cf..60ace6dbfaf6 100644
--- a/mail/courier/pkg-plist
+++ b/mail/courier/pkg-plist
@@ -36,6 +36,7 @@
@unexec cmp -s %D/etc/courier/pop3d-ssl %D/etc/courier/pop3d-ssl.dist && rm -f %D/etc/courier/pop3d-ssl 2>/dev/null || true
@unexec cmp -s %D/etc/courier/pop3d %D/etc/courier/pop3d.dist && rm -f %D/etc/courier/pop3d 2>/dev/null || true
@unexec cmp -s %D/etc/courier/sqwebmaild %D/etc/courier/sqwebmaild.dist && rm -f %D/etc/courier/sqwebmaild 2>/dev/null || true
+@unexec cmp -s %D/etc/courier/webmlmrc %D/etc/courier/webmlmrc.dist && rm -f %D/etc/courier/webmlmrc 2>/dev/null || true
bin/addcr
bin/cancelmsg
bin/courier-config
@@ -60,6 +61,8 @@ bin/reformime
bin/rmail
bin/sendmail
bin/testmxlookup
+bin/webmlmd
+bin/webmlmd.rc
etc/courier/aliases/system
etc/courier/courierd.dist
etc/courier/crontab
@@ -107,6 +110,7 @@ etc/courier/rfcerrheader.txt
etc/courier/smtpaccess/default
etc/courier/sqwebmaild.dist
etc/courier/webmail.authpam
+etc/courier/webmlmrc.dist
@exec [ -e /etc/aliases ] && ln -sf /etc/aliases %D/etc/courier/aliases/system
@exec [ -f %D/etc/courier/courierd.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/courierd.dist
@exec [ -f %D/etc/courier/esmtpd-msa.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/esmtpd-msa.dist
@@ -122,6 +126,7 @@ etc/courier/webmail.authpam
@exec [ -f %D/etc/courier/pop3d-ssl.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d-ssl.dist
@exec [ -f %D/etc/courier/pop3d.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/pop3d.dist
@exec [ -f %D/etc/courier/sqwebmaild.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/sqwebmaild.dist
+@exec [ -f %D/etc/courier/webmlmrc.dist ] && %%LOCALBASE%%/share/sysconftool/sysconftool %D/etc/courier/webmlmrc.dist
@dirrmtry etc/courier/aliasdir
@dirrmtry etc/courier/aliases
@dirrmtry etc/courier/esmtpacceptmailfor.dir
@@ -158,6 +163,7 @@ libexec/courier/submit
libexec/courier/submitmkdir
libexec/courier/webmail/webadmin
libexec/courier/webmail/webmail
+libexec/courier/webmail/webmlm
libexec/filters/dupfilter
libexec/filters/perlfilter
%%WITHUUCP%%@dirrm libexec/courier/modules/uucp
@@ -211,16 +217,18 @@ share/courier/couriermlm/idxheaderhtml.tmpl
share/courier/couriermlm/idxheadertxt.tmpl
share/courier/couriermlm/idxsubject.tmpl
share/courier/couriermlm/modrejbody.tmpl
-share/courier/couriermlm/modreject.tmpl
share/courier/couriermlm/modrejheader.tmpl
share/courier/couriermlm/modsubject.tmpl
share/courier/couriermlm/modtext.tmpl
share/courier/couriermlm/modtext2.tmpl
+share/courier/couriermlm/style.css.tmpl
share/courier/couriermlm/sub.tmpl
share/courier/couriermlm/sub2.tmpl
share/courier/couriermlm/sub3.tmpl
share/courier/couriermlm/sub4.tmpl
share/courier/couriermlm/sub5.tmpl
+share/courier/couriermlm/suback.tmpl
+share/courier/couriermlm/subjrequest.tmpl
share/courier/couriermlm/subreportfooter.tmpl
share/courier/couriermlm/subreporthdr.tmpl
share/courier/couriermlm/subreporthdr1.tmpl
@@ -233,6 +241,21 @@ share/courier/couriermlm/warn1headers.tmpl
share/courier/couriermlm/warn1text.tmpl
share/courier/couriermlm/warn1text2.tmpl
share/courier/couriermlm/warn2msg.tmpl
+share/courier/couriermlm/webmlm.tmpl
+share/courier/couriermlm/webmlm.tmpl.html
+share/courier/couriermlm/webmlmconfirm.html
+share/courier/couriermlm/webmlmerror.tmpl.html
+share/courier/couriermlm/webmlmidx.html
+share/courier/couriermlm/webmlmlistadmin.tmpl.html
+share/courier/couriermlm/webmlmlistadminmod.tmpl.html
+share/courier/couriermlm/webmlmlistadminpw.tmpl.html
+share/courier/couriermlm/webmlmlistindex.tmpl.html
+share/courier/couriermlm/webmlmnotprocessed.html
+share/courier/couriermlm/webmlmpleasewait.tmpl.html
+share/courier/couriermlm/webmlmprocessed.html
+share/courier/couriermlm/webmlmrequestreceived.tmpl.html
+share/courier/couriermlm/webmlmsubinfo.tmpl.html
+share/courier/couriermlm/webmlmsublist.tmpl.html
@dirrm share/courier/couriermlm
share/courier/courierwebadmin/admin-00machine.html
share/courier/courierwebadmin/admin-00machine.pl
@@ -309,195 +332,6 @@ share/courier/perlfilter-example.pl
share/courier/perlfilter-wrapper.pl
share/courier/pop3d
share/courier/pop3d-ssl
-share/courier/rootcerts/02b73561.0
-share/courier/rootcerts/0481cb65.0
-share/courier/rootcerts/052e396b.0
-share/courier/rootcerts/0c364b2d.0
-share/courier/rootcerts/0dbd0096.0
-share/courier/rootcerts/0e82f83a.0
-share/courier/rootcerts/11a09b38.0
-share/courier/rootcerts/11f154d6.0
-share/courier/rootcerts/124bbd54.0
-share/courier/rootcerts/128b9c8d.0
-share/courier/rootcerts/19899da5.0
-share/courier/rootcerts/219d9499.0
-share/courier/rootcerts/23f4c490.0
-share/courier/rootcerts/256fd83b.0
-share/courier/rootcerts/2edf7016.0
-share/courier/rootcerts/2fb1850a.0
-share/courier/rootcerts/31044350.0
-share/courier/rootcerts/3ad48a91.0
-share/courier/rootcerts/3c58f906.0
-share/courier/rootcerts/3e7271e8.0
-share/courier/rootcerts/412bea73.0
-share/courier/rootcerts/4166ec0c.0
-share/courier/rootcerts/4184de39.0
-share/courier/rootcerts/4643210f.0
-share/courier/rootcerts/47996b5c.0
-share/courier/rootcerts/4d654d1d.0
-share/courier/rootcerts/4fbd6bfa.0
-share/courier/rootcerts/54edfa5d.0
-share/courier/rootcerts/594f1775.0
-share/courier/rootcerts/5a5372fc.0
-share/courier/rootcerts/5cf9d536.0
-share/courier/rootcerts/5f5e5caa.0
-share/courier/rootcerts/61f6c934.0
-share/courier/rootcerts/635ccfd5.0
-share/courier/rootcerts/6c55cf77.0
-share/courier/rootcerts/6e8bf996.0
-share/courier/rootcerts/6fcc125d.0
-share/courier/rootcerts/709afd2b.0
-share/courier/rootcerts/72bf6a04.0
-share/courier/rootcerts/72fa7371.0
-share/courier/rootcerts/74c26bd0.0
-share/courier/rootcerts/755f7420.0
-share/courier/rootcerts/75680d2e.0
-share/courier/rootcerts/7651b327.0
-share/courier/rootcerts/76579174.0
-share/courier/rootcerts/788c9bfc.0
-share/courier/rootcerts/7999be0d.0
-share/courier/rootcerts/7d3cd826.0
-share/courier/rootcerts/7d453d8f.0
-share/courier/rootcerts/8470719d.0
-share/courier/rootcerts/86f32474.0
-share/courier/rootcerts/8f7b96c4.0
-share/courier/rootcerts/8fe643df.0
-share/courier/rootcerts/95750816.0
-share/courier/rootcerts/97b4211c.0
-share/courier/rootcerts/9ec3a561.0
-share/courier/rootcerts/a0bc6fbb.0
-share/courier/rootcerts/a15b3b6b.0
-share/courier/rootcerts/a2df7ad7.0
-share/courier/rootcerts/a3896b44.0
-share/courier/rootcerts/a6776c69.0
-share/courier/rootcerts/a7605362.0
-share/courier/rootcerts/aaa-certificate-services.pem
-share/courier/rootcerts/aaa45464.0
-share/courier/rootcerts/aba-ecom-root-ca.pem
-share/courier/rootcerts/add67345.0
-share/courier/rootcerts/addtrust-class-1-ca-root.pem
-share/courier/rootcerts/addtrust-external-ca-root.pem
-share/courier/rootcerts/addtrust-public-ca-root.pem
-share/courier/rootcerts/addtrust-qualified-ca-root.pem
-share/courier/rootcerts/america-online-root-certification-00.pem
-share/courier/rootcerts/america-online-root-certification-01.pem
-share/courier/rootcerts/aol-time-warner-root-certification-00.pem
-share/courier/rootcerts/aol-time-warner-root-certification-01.pem
-share/courier/rootcerts/b0f3e76e.0
-share/courier/rootcerts/b5f329fa.0
-share/courier/rootcerts/baltimore-cybertrust-root.pem
-share/courier/rootcerts/bcdd5959.0
-share/courier/rootcerts/bda4cc84.0
-share/courier/rootcerts/betrusted-root-ca-baltimore-implementation.pem
-share/courier/rootcerts/betrusted-root-ca-entrust-implementation.pem
-share/courier/rootcerts/betrusted-root-ca-rsa-implementation.pem
-share/courier/rootcerts/betrusted-root-ca.pem
-share/courier/rootcerts/bf87590f.0
-share/courier/rootcerts/c19d42c7.0
-share/courier/rootcerts/c215bc69.0
-share/courier/rootcerts/c33a80d4.0
-share/courier/rootcerts/c527e4ab.0
-share/courier/rootcerts/c9bc75ba.0
-share/courier/rootcerts/ccb919f9.0
-share/courier/rootcerts/cdaebb72.0
-share/courier/rootcerts/certum-ca.pem
-share/courier/rootcerts/chambers-of-commerce-root.pem
-share/courier/rootcerts/class-1-public-primary-ocsp-responder.pem
-share/courier/rootcerts/class-2-public-primary-ocsp-responder.pem
-share/courier/rootcerts/class-3-public-primary-ocsp-responder.pem
-share/courier/rootcerts/d2adc77d.0
-share/courier/rootcerts/d537fba6.0
-share/courier/rootcerts/d78a75c7.0
-share/courier/rootcerts/d8274e24.0
-share/courier/rootcerts/ddc328ff.0
-share/courier/rootcerts/digital-signature-trust-co-dstca-00.pem
-share/courier/rootcerts/digital-signature-trust-co-dstca-01.pem
-share/courier/rootcerts/dst-rootca-x1.pem
-share/courier/rootcerts/dst-rootca-x2.pem
-share/courier/rootcerts/e268a4c5.0
-share/courier/rootcerts/e28f6bbc.0
-share/courier/rootcerts/e7b8d656.0
-share/courier/rootcerts/ed049835.0
-share/courier/rootcerts/ed524cf5.0
-share/courier/rootcerts/ed62f4e3.0
-share/courier/rootcerts/ee7cd6fb.0
-share/courier/rootcerts/entrust-net-certification-authority.pem
-share/courier/rootcerts/entrust-net-client-certification-00.pem
-share/courier/rootcerts/entrust-net-client-certification-01.pem
-share/courier/rootcerts/entrust-net-secure-server-certification-00.pem
-share/courier/rootcerts/entrust-net-secure-server-certification-01.pem
-share/courier/rootcerts/equifax-equifax-secure-certificate.pem
-share/courier/rootcerts/equifax-secure-ebusiness-ca-1.pem
-share/courier/rootcerts/equifax-secure-equifax-secure-ebusiness.pem
-share/courier/rootcerts/equifax-secure-global-ebusiness.pem
-share/courier/rootcerts/f3cf1e8e.0
-share/courier/rootcerts/f4996e82.0
-share/courier/rootcerts/f64d9715.0
-share/courier/rootcerts/f73e89fd.0
-share/courier/rootcerts/f950ccc2.0
-share/courier/rootcerts/ff783690.0
-share/courier/rootcerts/geotrust-global-ca.pem
-share/courier/rootcerts/global-chambersign-root.pem
-share/courier/rootcerts/globalsign-root-ca.pem
-share/courier/rootcerts/gp-root-2.pem
-share/courier/rootcerts/gte-cybertrust-global-root.pem
-share/courier/rootcerts/gte-cybertrust-root.pem
-share/courier/rootcerts/http-www-valicert-com-00.pem
-share/courier/rootcerts/http-www-valicert-com-01.pem
-share/courier/rootcerts/http-www-valicert-com-02.pem
-share/courier/rootcerts/ips-ca-chained-cas-certification.pem
-share/courier/rootcerts/ips-ca-clase1-certification-authority.pem
-share/courier/rootcerts/ips-ca-clase3-certification-authority.pem
-share/courier/rootcerts/ips-ca-clasea1-certification-authority.pem
-share/courier/rootcerts/ips-ca-clasea3-certification-authority.pem
-share/courier/rootcerts/ips-ca-timestamping-certification.pem
-share/courier/rootcerts/ips-servidores.pem
-share/courier/rootcerts/netlock-expressz-class-c-tanusitvanykiado.pem
-share/courier/rootcerts/netlock-kozjegyzoi-class-a-tanusitvanykiado.pem
-share/courier/rootcerts/netlock-uzleti-class-b-tanusitvanykiado.pem
-share/courier/rootcerts/quovadis-root-certification-authority.pem
-share/courier/rootcerts/rsa-data-security-inc-secure-server.pem
-share/courier/rootcerts/rsa-security-inc-rsa-security-1024.pem
-share/courier/rootcerts/rsa-security-inc-rsa-security-2048.pem
-share/courier/rootcerts/secom-trust-net-security-communication.pem
-share/courier/rootcerts/secure-certificate-services.pem
-share/courier/rootcerts/secure-server-ocsp-responder.pem
-share/courier/rootcerts/sonera-class1-ca.pem
-share/courier/rootcerts/sonera-class2-ca.pem
-share/courier/rootcerts/staat-der-nederlanden-root-ca.pem
-share/courier/rootcerts/starfield-technologies-inc-starfield.pem
-share/courier/rootcerts/tc-trustcenter-for-security-in-00.pem
-share/courier/rootcerts/tc-trustcenter-for-security-in-01.pem
-share/courier/rootcerts/tdc-internet-tdc-internet-root.pem
-share/courier/rootcerts/tdc-oces-ca.pem
-share/courier/rootcerts/thawte-personal-basic-ca.pem
-share/courier/rootcerts/thawte-personal-freemail-ca.pem
-share/courier/rootcerts/thawte-personal-premium-ca.pem
-share/courier/rootcerts/thawte-premium-server-ca.pem
-share/courier/rootcerts/thawte-server-ca.pem
-share/courier/rootcerts/thawte-timestamping-ca.pem
-share/courier/rootcerts/the-go-daddy-group-inc-go-daddy.pem
-share/courier/rootcerts/trusted-certificate-services.pem
-share/courier/rootcerts/utn-datacorp-sgc.pem
-share/courier/rootcerts/utn-userfirst-client-authentication.pem
-share/courier/rootcerts/utn-userfirst-hardware.pem
-share/courier/rootcerts/utn-userfirst-network-applications.pem
-share/courier/rootcerts/utn-userfirst-object.pem
-share/courier/rootcerts/verisign-class-1-public-primary.pem
-share/courier/rootcerts/verisign-class-2-public-primary.pem
-share/courier/rootcerts/verisign-class-3-public-primary.pem
-share/courier/rootcerts/verisign-class-4-public-primary.pem
-share/courier/rootcerts/verisign-inc-class-1-public-primary.pem
-share/courier/rootcerts/verisign-inc-class-2-public-primary.pem
-share/courier/rootcerts/verisign-inc-class-3-public-primary.pem
-share/courier/rootcerts/verisign-inc-verisign-trust-network-00.pem
-share/courier/rootcerts/verisign-inc-verisign-trust-network-01.pem
-share/courier/rootcerts/verisign-inc-verisign-trust-network-02.pem
-share/courier/rootcerts/verisign-inc-verisign-trust-network-03.pem
-share/courier/rootcerts/verisign-time-stamping-authority.pem
-share/courier/rootcerts/visa-ecommerce-root.pem
-share/courier/rootcerts/xramp-global-certification-authority.pem
-@dirrm share/courier/rootcerts
share/courier/sharedindexupdate
share/courier/sqwebmail/cleancache.pl
share/courier/sqwebmail/html/en-us/CHARSET
@@ -642,6 +476,7 @@ share/courier/sqwebmail/webgpg
%%PORTDOCS%%%%DOCSDIR%%/html/bg.gif
%%PORTDOCS%%%%DOCSDIR%%/html/cancelmsg.html
%%PORTDOCS%%%%DOCSDIR%%/html/changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/html/chinese_flag.png
%%PORTDOCS%%%%DOCSDIR%%/html/courier.html
%%PORTDOCS%%%%DOCSDIR%%/html/courierd.html
%%PORTDOCS%%%%DOCSDIR%%/html/courierdsn.html
@@ -659,7 +494,6 @@ share/courier/sqwebmail/webgpg
%%PORTDOCS%%%%DOCSDIR%%/html/documentation.html
%%PORTDOCS%%%%DOCSDIR%%/html/dot-courier.html
%%PORTDOCS%%%%DOCSDIR%%/html/dot-forward.html
-%%PORTDOCS%%%%DOCSDIR%%/html/download.php
%%PORTDOCS%%%%DOCSDIR%%/html/draft-varshavchik-exdata-smtpext.txt
%%PORTDOCS%%%%DOCSDIR%%/html/draft-varshavchik-security-smtpext.txt
%%PORTDOCS%%%%DOCSDIR%%/html/draft-varshavchik-verp-smtpext.txt
@@ -672,6 +506,7 @@ share/courier/sqwebmail/webgpg
%%PORTDOCS%%%%DOCSDIR%%/html/icon.gif
%%PORTDOCS%%%%DOCSDIR%%/html/imapd.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/html/index2.html
%%PORTDOCS%%%%DOCSDIR%%/html/install.html
%%PORTDOCS%%%%DOCSDIR%%/html/intro.html
%%PORTDOCS%%%%DOCSDIR%%/html/japanese_flag.png
@@ -721,6 +556,7 @@ share/courier/sqwebmail/webgpg
%%PORTDOCS%%%%DOCSDIR%%/html/style.css
%%PORTDOCS%%%%DOCSDIR%%/html/submit.html
%%PORTDOCS%%%%DOCSDIR%%/html/testmxlookup.html
+%%PORTDOCS%%%%DOCSDIR%%/html/webmlmd.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@exec chown %%MAILOWN%%:%%MAILGRP%% %D/bin/cancelmsg
@@ -753,7 +589,6 @@ share/courier/sqwebmail/webgpg
@exec chmod 0555 %D/share/courier/couriermlm
@exec chmod 0555 %D/share/courier/courierwebadmin
%%WITHFAX%%@exec chmod 0555 %D/share/courier/faxmail
-@exec chmod 0555 %D/share/courier/rootcerts
@exec chmod 0555 %D/share/courier/sqwebmail
@exec chmod 0555 %D/share/courier/sqwebmail/html
@exec chmod 0555 %D/share/courier/sqwebmail/html/en-us
diff --git a/mail/courier/scripts/c_rehash b/mail/courier/scripts/c_rehash
deleted file mode 100644
index 5d3e3d81dde5..000000000000
--- a/mail/courier/scripts/c_rehash
+++ /dev/null
@@ -1,160 +0,0 @@
-#!/usr/bin/env perl
-
-
-# Perl c_rehash script, scan all files in a directory
-# and add symbolic links to their hash values.
-
-my $openssl;
-
-my $dir = "/etc/ssl";
-
-if(defined $ENV{OPENSSL}) {
- $openssl = $ENV{OPENSSL};
-} else {
- $openssl = "openssl";
- $ENV{OPENSSL} = $openssl;
-}
-
-$ENV{PATH} .= ":$dir/bin";
-
-if(! -x $openssl) {
- my $found = 0;
- foreach (split /:/, $ENV{PATH}) {
- if(-x "$_/$openssl") {
- $found = 1;
- last;
- }
- }
- if($found == 0) {
- print STDERR "c_rehash: rehashing skipped ('openssl' program not available)\n";
- exit 0;
- }
-}
-
-if(@ARGV) {
- @dirlist = @ARGV;
-} elsif($ENV{SSL_CERT_DIR}) {
- @dirlist = split /:/, $ENV{SSL_CERT_DIR};
-} else {
- $dirlist[0] = "$dir/certs";
-}
-
-
-foreach (@dirlist) {
- if(-d $_ and -w $_) {
- hash_dir($_);
- }
-}
-
-sub hash_dir {
- my %hashlist;
- print "Doing $_[0]\n";
- chdir $_[0];
- opendir(DIR, ".");
- my @flist = readdir(DIR);
- # Delete any existing symbolic links
- foreach (grep {/^[\da-f]+\.r{0,1}\d+$/} @flist) {
- if(-l $_) {
- unlink $_;
- }
- }
- closedir DIR;
- FILE: foreach $fname (grep {/\.pem$/} @flist) {
- # Check to see if certificates and/or CRLs present.
- my ($cert, $crl) = check_file($fname);
- if(!$cert && !$crl) {
- print STDERR "WARNING: $fname does not contain a certificate or CRL: skipping\n";
- next;
- }
- link_hash_cert($fname) if($cert);
- link_hash_crl($fname) if($crl);
- }
-}
-
-sub check_file {
- my ($is_cert, $is_crl) = (0,0);
- my $fname = $_[0];
- open IN, $fname;
- while(<IN>) {
- if(/^-----BEGIN (.*)-----/) {
- my $hdr = $1;
- if($hdr =~ /^(X509 |TRUSTED |)CERTIFICATE$/) {
- $is_cert = 1;
- last if($is_crl);
- } elsif($hdr eq "X509 CRL") {
- $is_crl = 1;
- last if($is_cert);
- }
- }
- }
- close IN;
- return ($is_cert, $is_crl);
-}
-
-
-# Link a certificate to its subject name hash value, each hash is of
-# the form <hash>.<n> where n is an integer. If the hash value already exists
-# then we need to up the value of n, unless its a duplicate in which
-# case we skip the link. We check for duplicates by comparing the
-# certificate fingerprints
-
-sub link_hash_cert {
- my $fname = $_[0];
- $fname =~ s/'/'\\''/g;
- my ($hash, $fprint) = `"$openssl" x509 -hash -fingerprint -noout -in '$fname'`;
- chomp $hash;
- chomp $fprint;
- $fprint =~ s/^.*=//;
- $fprint =~ tr/://d;
- my $suffix = 0;
- # Search for an unused hash filename
- while(exists $hashlist{"$hash.$suffix"}) {
- # Hash matches: if fingerprint matches its a duplicate cert
- if($hashlist{"$hash.$suffix"} eq $fprint) {
- print STDERR "WARNING: Skipping duplicate certificate $fname\n";
- return;
- }
- $suffix++;
- }
- $hash .= ".$suffix";
- print "$fname => $hash\n";
- $symlink_exists=eval {symlink("",""); 1};
- if ($symlink_exists) {
- symlink $fname, $hash;
- } else {
- system ("cp", $fname, $hash);
- }
- $hashlist{$hash} = $fprint;
-}
-
-# Same as above except for a CRL. CRL links are of the form <hash>.r<n>
-
-sub link_hash_crl {
- my $fname = $_[0];
- $fname =~ s/'/'\\''/g;
- my ($hash, $fprint) = `"$openssl" crl -hash -fingerprint -noout -in '$fname'`;
- chomp $hash;
- chomp $fprint;
- $fprint =~ s/^.*=//;
- $fprint =~ tr/://d;
- my $suffix = 0;
- # Search for an unused hash filename
- while(exists $hashlist{"$hash.r$suffix"}) {
- # Hash matches: if fingerprint matches its a duplicate cert
- if($hashlist{"$hash.r$suffix"} eq $fprint) {
- print STDERR "WARNING: Skipping duplicate CRL $fname\n";
- return;
- }
- $suffix++;
- }
- $hash .= ".r$suffix";
- print "$fname => $hash\n";
- $symlink_exists=eval {symlink("",""); 1};
- if ($symlink_exists) {
- symlink $fname, $hash;
- } else {
- system ("cp", $fname, $hash);
- }
- $hashlist{$hash} = $fprint;
-}
-