aboutsummaryrefslogtreecommitdiff
path: root/mail/crm114
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-01 23:18:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-01 23:18:19 +0000
commitfa697548c6e992c6b84cb15fcab33c7038e405a7 (patch)
treefc1da988ed9c9cba707cf220721bac89300d0c78 /mail/crm114
parentaed1a8bb785780fbecb2c74bdc17b7b1b54133a3 (diff)
downloadports-fa697548c6e992c6b84cb15fcab33c7038e405a7.tar.gz
ports-fa697548c6e992c6b84cb15fcab33c7038e405a7.zip
Notes
Diffstat (limited to 'mail/crm114')
-rw-r--r--mail/crm114/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
index d263764e3bc9..cbf5c652f02b 100644
--- a/mail/crm114/Makefile
+++ b/mail/crm114/Makefile
@@ -1,8 +1,5 @@
-# New ports collection makefile for: crm114
-# Date created: 23 February 2004
-# Whom: Meno Abels <meno.abels@adviser.com>
+# Created by: Meno Abels <meno.abels@adviser.com>
# $FreeBSD$
-#
PORTNAME= crm114
PORTVERSION= 20100106
@@ -46,11 +43,12 @@ CRM_FILES= mailfilter.crm mailfilter.cf mailreaver.crm mailtrainer.crm \
blacklist.mfp.example whitelist.mfp.example crm114-mode.el \
reto_procmailrc.recipe
-OPTIONS= PGO "Enable Profile-Guided Optimization" off
+OPTIONS_DEFINE= PGO
+PGO_DESC= Profile-Guided Optimization
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
MAKE_ARGS+= CFLAGS="${CFLAGS} -fprofile-use" \
LDFLAGS="${LDFLAGS} -fprofile-use"
.else
@@ -63,7 +61,7 @@ post-patch:
's,^((LD|C)FLAGS),#\1,;;s,^(prefix=),#\1,;;s,^(.*-install),#\1,' \
${WRKSRC}/Makefile
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
.if target(pre-build)
.error Makefile error since pre-build target has already been defined
.endif
@@ -82,7 +80,7 @@ post-install:
@for i in priolist.mfp whitelist.mfp; do \
${CP} ${WRKSRC}/$${i}.example ${WRKSRC}/$${i}; \
done
-.ifdef(WITH_NORMALIZEMIME)
+.if ${PORT_OPTIONS:MNORMALIZEMIME}
@${REINPLACE_CMD} -Ee 's|^#(.*/normalizemime/)|\1|' \
${WRKSRC}/mailfilter.cf
.else
@@ -100,7 +98,7 @@ post-install:
done
.endif
-.if defined(WITH_PGO)
+.if ${PORT_OPTIONS:MPGO}
pgo: pgo-build pgo-run pgo-clean
pgo-build:
@@ -113,6 +111,6 @@ pgo-run:
pgo-clean:
@(cd ${BUILD_WRKSRC}; ${MAKE} clean)
-.endif # if defined(WITH_PGO)
+.endif # if ${PORT_OPTIONS:MPGO}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>