aboutsummaryrefslogtreecommitdiff
path: root/mail/crm114
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-19 03:37:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-19 03:37:11 +0000
commitc9c8c6ba2c4363db9fba18ae29ce3b5867ee8b25 (patch)
tree9109ae08e6e75b05a92977f437757d950d52dd11 /mail/crm114
parentd5813fda66ccfe9f23320b1e1e5bd855ac588241 (diff)
downloadports-c9c8c6ba2c4363db9fba18ae29ce3b5867ee8b25.tar.gz
ports-c9c8c6ba2c4363db9fba18ae29ce3b5867ee8b25.zip
- Stage support
PR: 189892 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=354486
Diffstat (limited to 'mail/crm114')
-rw-r--r--mail/crm114/Makefile50
1 files changed, 13 insertions, 37 deletions
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
index 38e0f2ef4c29..364f6be06a38 100644
--- a/mail/crm114/Makefile
+++ b/mail/crm114/Makefile
@@ -17,13 +17,19 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-${CRM114RELEASENAME}.src
MAINTAINER= chalpin@cs.wisc.edu
COMMENT= A Markov based SpamFilter
-LIB_DEPENDS= tre.5:${PORTSDIR}/textproc/libtre
+LICENSE= GPLv2
+
+LIB_DEPENDS= libtre.so:${PORTSDIR}/textproc/libtre
CRM114RELEASENAME=BlameMichelson
USES= gettext iconv
+USE_CSTD=gnu89
+
+OPTIONS_DEFINE= NORMALIZEMIME
+NORMALIZEMIME_DESC= Normalize MIME encoding
-MAKE_ARGS= CC="${CC}" prefix="${PREFIX}" \
+MAKE_ARGS= CC="${CC}" prefix="${STAGEDIR}${PREFIX}" \
LIBS="${LIBS}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}"
@@ -43,31 +49,16 @@ CRM_FILES= mailfilter.crm mailfilter.cf mailreaver.crm mailtrainer.crm \
blacklist.mfp.example whitelist.mfp.example crm114-mode.el \
reto_procmailrc.recipe
-OPTIONS_DEFINE= PGO
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPGO}
-MAKE_ARGS+= CFLAGS="${CFLAGS} -fprofile-use" \
- LDFLAGS="${LDFLAGS} -fprofile-use"
-.else
MAKE_ARGS+= CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
-.endif
post-patch:
@${REINPLACE_CMD} -Ee \
's,^((LD|C)FLAGS),#\1,;;s,^(prefix=),#\1,;;s,^(.*-install),#\1,' \
${WRKSRC}/Makefile
-.if ${PORT_OPTIONS:MPGO}
-.if target(pre-build)
-.error Makefile error since pre-build target has already been defined
-.endif
-pre-build: pgo
-.endif
-
# Peter Jeremy recommended the use of b64decode and md5 20040302
post-install:
@${REINPLACE_CMD} -Ee 's|^(.*/openssl base64 -d/)|#\1|' \
@@ -87,30 +78,15 @@ post-install:
@${REINPLACE_CMD} -Ee 's|^#(.*/b64decode -pr/)|\1|' \
${WRKSRC}/mailfilter.cf
.endif
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
for i in ${CRM_FILES}; do \
- ${INSTALL_DATA} ${WRKSRC}/$${i} ${EXAMPLESDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${STAGEDIR}${EXAMPLESDIR}; \
done
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
@for i in ${WRKSRC}/[^G]*.txt ${WRKSRC}/README; do \
- ${INSTALL_DATA} $${i} ${DOCSDIR}; \
+ ${INSTALL_DATA} $${i} ${STAGEDIR}${DOCSDIR}; \
done
.endif
-.if ${PORT_OPTIONS:MPGO}
-pgo: pgo-build pgo-run pgo-clean
-
-pgo-build:
- @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} CFLAGS="${CFLAGS} -fprofile-generate" LDFLAGS="${LDFLAGS} -fprofile-generate" ${ALL_TARGET})
-
-pgo-run:
-# Check everything to generate profiling information.
-# We will ignore any errors.
- @-(cd ${BUILD_WRKSRC}; ${MAKE} megatest)
-
-pgo-clean:
- @(cd ${BUILD_WRKSRC}; ${MAKE} clean)
-.endif # if ${PORT_OPTIONS:MPGO}
-
.include <bsd.port.mk>