aboutsummaryrefslogtreecommitdiff
path: root/mail/dbmail/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-18 16:04:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-18 16:04:16 +0000
commit05065d99c78a53f6ab97086574a01d75be79decc (patch)
tree2f9f09b2b30cc41ccd58808030a38660205a46fb /mail/dbmail/Makefile
parent679f73e91c22fe170f78e55bd8ed2adf7a40849c (diff)
- Patch nine bugs:
#79 - INTERNALDATE reponses do not conform to RFC #145 - LMTP loses return-path #177 - Compile Fails on FreeBSD (fixes compilation on FreeBSD 4.X) #184 - socklen_t issue #190 - huge load if database crash #198 - DBMail processes killing each other #199 - spare child creates zombie #214 - dbmail-smtp dumps core with double free #216 - malformed header prevents delivery - Fix RC_SUBR usage PR: ports/83437, also ports/80736, ports/82437, ports/83575 Submitted by: Mark Starovoytov <mark@kikg.ifmo.ru>, parts also by: Radim Kolar <hsn@netmag.cz>, thompsa, Marcus Grando <marcus@corp.grupos.com.br> Approved by: maintainer timeout (2 months on oldest PR)
Notes
Notes: svn path=/head/; revision=139510
Diffstat (limited to 'mail/dbmail/Makefile')
-rw-r--r--mail/dbmail/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/mail/dbmail/Makefile b/mail/dbmail/Makefile
index a67e4be6ec2a..d138d51531d7 100644
--- a/mail/dbmail/Makefile
+++ b/mail/dbmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dbmail
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.dbmail.org/download/
PKGNAMESUFFIX= -${DATABASE}
@@ -20,14 +21,10 @@ GNU_CONFIGURE= YES
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_GMAKE= YES
USE_OPENSSL= YES
+USE_RC_SUBR= dbmail-pop3d.sh dbmail-lmtpd.sh dbmail-imapd.sh
CFLAGS += -fPIC
-SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
- -e 's|%%PREFIX%%|${PREFIX}|g' \
- -e 's|%%RC_DIR%%|${RC_DIR}|g' \
- -e 's|%%RC_SUFX%%|${RC_SUFX}|g'
-
.if defined(WITH_POSTGRESQL)
CONFIGURE_ARGS+= --with-pgsql
USE_PGSQL= yes
@@ -68,16 +65,8 @@ post-configure:
@${REINPLACE_CMD} -i.orig 's!/etc/dbmail.conf!${PREFIX}/etc/dbmail.conf!g' \
${WRKSRC}/dbmail.h
-post-build:
-.for f in imap lmtp pop3
- @${SED} ${SED_SCRIPT} ${FILESDIR}/dbmail-${f}d.sh > ${WRKDIR}/dbmail-${f}d.sh
-.endfor
-
post-install:
@${INSTALL_DATA} ${WRKSRC}/dbmail.conf ${PREFIX}/etc/dbmail.conf-dist
-.for f in imap lmtp pop3
- @${INSTALL_SCRIPT} ${WRKDIR}/dbmail-${f}d.sh ${DESTDIR}${PREFIX}/etc/rc.d/dbmail-${f}d.sh
-.endfor
@${MKDIR} ${DATADIR}/sql
@${INSTALL_DATA} ${WRKSRC}/sql/${DATABASE}/* ${DATADIR}/sql
@cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1