aboutsummaryrefslogtreecommitdiff
path: root/mail/dbmail/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-06-24 19:19:06 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-06-24 19:19:06 +0000
commit1763ba3c30f62d80605c1660461265a2d6b582a5 (patch)
tree92e5c59a379d9310528fac2eec0b899482c2160e /mail/dbmail/Makefile
parent3ac4dec4fb05549acf11863b4bd5cd399141440b (diff)
downloadports-1763ba3c30f62d80605c1660461265a2d6b582a5.tar.gz
ports-1763ba3c30f62d80605c1660461265a2d6b582a5.zip
Notes
Diffstat (limited to 'mail/dbmail/Makefile')
-rw-r--r--mail/dbmail/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/mail/dbmail/Makefile b/mail/dbmail/Makefile
index 153efc9a51e4..5c495bc04e91 100644
--- a/mail/dbmail/Makefile
+++ b/mail/dbmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbmail
PORTVERSION= 3.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://www.dbmail.org/download/3.0/
@@ -31,6 +31,8 @@ OPTIONS_DEFINE= LDAP SIEVE THREADS
OPTIONS_DEFAULT= THREADS
SIEVE_DESC= "Build with support for Sieve mail sorting language"
+.include <bsd.port.options.mk>
+
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/dbmail
@@ -66,25 +68,25 @@ PLIST_SUB+= PORTDOCS="@comment "
PLIST_SUB+= PORTDOCS=""
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SIEVE)
+.if ${PORT_OPTIONS:MSIEVE}
CONFIGURE_ARGS+=--with-sieve=${LOCALBASE}
LIB_DEPENDS+= sieve:${PORTSDIR}/mail/libsieve
PLIST_SUB+= SIEVE=""
.else
+CONFIGURE_ARGS+=--without-sieve
PLIST_SUB+= SIEVE="@comment "
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
USE_OPENLDAP= yes
PLIST_SUB+= LDAP=""
.else
+CONFIGURE_ARGS+=--without-ldap
PLIST_SUB+= LDAP="@comment "
.endif
-.if defined(WITH_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-acinclude.m4
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
.endif
@@ -113,4 +115,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>