aboutsummaryrefslogtreecommitdiff
path: root/mail/dcc-dccd/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-03 09:09:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-03 09:09:23 +0000
commit9ab42def12260cc4a395ebc30772c2010ff87b0a (patch)
tree54ce98c3e57050a3b98469a4933ef89d25977651 /mail/dcc-dccd/Makefile
parentcfdec1a0503642667334fed1c32dbcdf64c3c732 (diff)
Notes
Diffstat (limited to 'mail/dcc-dccd/Makefile')
-rw-r--r--mail/dcc-dccd/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/mail/dcc-dccd/Makefile b/mail/dcc-dccd/Makefile
index 131f9e6387f7..d4fed6918d14 100644
--- a/mail/dcc-dccd/Makefile
+++ b/mail/dcc-dccd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dcc-dccd
-PORTVERSION= 1.3.27
+PORTVERSION= 1.3.29
CATEGORIES= mail
MASTER_SITES= http://www.rhyolite.com/anti-spam/dcc/source/ \
http://www.wa.apana.org.au/~dean/sources/ \
@@ -16,9 +16,6 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= dean@odyssey.apana.org.au
COMMENT= Distributed Checksum Clearinghouse procmail, sendmail support
-BROKEN= Unfetchable
-
-USE_REINPLACE= yes
HAS_CONFIGURE= yes
MANCOMPRESSED= yes
MAN8= cdcc.8 dbclean.8 dblist.8 dcc.8 dccd.8 dccifd.8 dccm.8 \
@@ -54,7 +51,7 @@ MILTERBASE= /usr
WITH_SENDMAIL= yes
.else
.if !defined(WITHOUT_SENDMAIL)
-BROKEN= "Base system sendmail not found or too old, rebuild with WITH_SENDMAIL_PORT=yes or WITHOUT_SENDMAIL=yes"
+IGNORE= base system sendmail not found or too old, rebuild with WITH_SENDMAIL_PORT=yes or WITHOUT_SENDMAIL=yes
.endif
.endif
.else
@@ -110,4 +107,10 @@ pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PREFIX} PRE-INSTALL
+post-install:
+.if !exists(${PREFIX}/dcc/map)
+ ${CP} ${PREFIX}/dcc/map ${PREFIX}/dcc/map.dist
+ @${CHOWN} ${DCCUSER} ${PREFIX}/dcc/map.dist
+.endif
+
.include <bsd.port.post.mk>