aboutsummaryrefslogtreecommitdiff
path: root/mail/dkimproxy/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /mail/dkimproxy/Makefile
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Notes
Diffstat (limited to 'mail/dkimproxy/Makefile')
-rw-r--r--mail/dkimproxy/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/mail/dkimproxy/Makefile b/mail/dkimproxy/Makefile
index 9e0df0b8feab..f517e5ba2e14 100644
--- a/mail/dkimproxy/Makefile
+++ b/mail/dkimproxy/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= IPV6
GNU_CONFIGURE= yes
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= scripts/*
NO_ARCH= yes
USE_RC_SUBR= dkimproxy_in dkimproxy_out
@@ -39,8 +40,4 @@ IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy.out
IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy_in.conf.example
IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy_out.conf.example
-post-patch:
- @${GREP} -Ril 'perl' ${WRKDIR} | ${XARGS} ${REINPLACE_CMD} -i '' \
- -e 's|/usr/bin/perl|${PERL}|' -e 's|@PERL@|${PERL}|'
-
.include <bsd.port.mk>