aboutsummaryrefslogtreecommitdiff
path: root/mail/dkimproxy/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-27 16:26:39 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-27 16:26:39 +0000
commit338e2198a3a979bb99404832ecb26c1687476c1a (patch)
treedfd3bf2fee6860f8f5503b34306f288fe77bcd52 /mail/dkimproxy/Makefile
parentc6df86859dce1a7aceaafe2a7b09e19eefe7fb9b (diff)
downloadports-338e2198a3a979bb99404832ecb26c1687476c1a.tar.gz
ports-338e2198a3a979bb99404832ecb26c1687476c1a.zip
Notes
Diffstat (limited to 'mail/dkimproxy/Makefile')
-rw-r--r--mail/dkimproxy/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/dkimproxy/Makefile b/mail/dkimproxy/Makefile
new file mode 100644
index 000000000000..3fb7f61f278e
--- /dev/null
+++ b/mail/dkimproxy/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dkimproxy
+# Date created: 16 July 2006
+# Whom: Yoshisato YANAGISAWA
+#
+# $FreeBSD$
+#
+
+PORTNAME= dkimproxy
+PORTVERSION= 0.13
+CATEGORIES= mail
+MASTER_SITES= http://jason.long.name/dkimproxy/
+
+MAINTAINER= yanagisawa@csg.is.titech.ac.jp
+COMMENT= DKIM filter for Postfix
+
+BUILD_DEPENDS= ${SITE_PERL}/Mail/DKIM.pm:${PORTSDIR}/mail/p5-Mail-DKIM \
+ ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_RC_SUBR= dkimproxy_in dkimproxy_out
+
+DKIMPY_USERNAME?= dkimproxy
+DKIMPY_USERID?= 525
+DKIMPY_GROUPNAME?= ${DKIMPY_USERNAME}
+DKIMPY_GROUPID?= ${DKIMPY_USERID}
+
+SUB_FILES= pkg-install pkg-deinstall
+SUB_LIST= USER=${DKIMPY_USERNAME} \
+ UID=${DKIMPY_USERID} \
+ GROUP=${DKIMPY_GROUPNAME} \
+ GID=${DKIMPY_GROUPID}
+
+.include <bsd.port.pre.mk>
+
+pre-install:
+ ${SH} ${PKGINSTALL} ${PREFIX} PRE-INSTALL
+
+.include <bsd.port.post.mk>