aboutsummaryrefslogtreecommitdiff
path: root/mail/dma
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2019-08-21 19:22:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2019-08-21 19:22:03 +0000
commit52892ad53d85fe4e874040b75d88be562175cc5d (patch)
treea6e9559c64524c8a70d355bbcefb3d41fe80af25 /mail/dma
parent11ab1dd820130675a9cf0c7adc578cce6191e3cf (diff)
downloadports-52892ad53d85fe4e874040b75d88be562175cc5d.tar.gz
ports-52892ad53d85fe4e874040b75d88be562175cc5d.zip
mail/dma: Update to 0.12
Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=509526
Diffstat (limited to 'mail/dma')
-rw-r--r--mail/dma/Makefile4
-rw-r--r--mail/dma/distinfo5
-rw-r--r--mail/dma/files/fix-security-hole.patch34
3 files changed, 4 insertions, 39 deletions
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 98eaf7b3d4e3..c57756183c0c 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= dma
-PORTVERSION= 0.11
+PORTVERSION= 0.12
DISTVERSIONPREFIX= v
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
@@ -31,7 +30,6 @@ MAKE_ENV= __MAKE_CONF=/dev/null SRCCONF=/dev/null NO_WERROR=defined \
USE_RC_SUBR= dma_flushq
SUB_FILES= pkg-message
-EXTRA_PATCHES= ${FILESDIR}/fix-security-hole.patch:-p1
# Allow subports to extend.
CONFFILES+= dma.conf auth.conf
diff --git a/mail/dma/distinfo b/mail/dma/distinfo
index 64ec5df33fa9..a8ebafdfb698 100644
--- a/mail/dma/distinfo
+++ b/mail/dma/distinfo
@@ -1,2 +1,3 @@
-SHA256 (corecode-dma-v0.11_GH0.tar.gz) = 288bd57f17aba696b6423b1fa0cd0f7d9b7228d32811f1cd7b821d5f020051b8
-SIZE (corecode-dma-v0.11_GH0.tar.gz) = 34529
+TIMESTAMP = 1566415052
+SHA256 (corecode-dma-v0.12_GH0.tar.gz) = 054a40203d43bc1182dcadf2375ccf01944329dce472444acb42d56cf01de367
+SIZE (corecode-dma-v0.12_GH0.tar.gz) = 35603
diff --git a/mail/dma/files/fix-security-hole.patch b/mail/dma/files/fix-security-hole.patch
deleted file mode 100644
index 9efd7bd76985..000000000000
--- a/mail/dma/files/fix-security-hole.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From f249aa412dd4a09881cb450390d1003815bd0013 Mon Sep 17 00:00:00 2001
-From: Zach Crownover <zachary.crownover@gmail.com>
-Date: Fri, 5 Aug 2016 15:24:27 -0700
-Subject: [PATCH] dma - Fix security hole (#46)
-
-Affecting DragonFly 4.6 and earlier, Matt Dillon fixed this in base after
-finding out from BSDNow Episode 152. Comments following were from his commit
-which explains better than I. Just taking his change and putting it here as well.
-
-* dma makes an age-old mistake of not properly checking whether a file
- owned by a user is a symlink or not, a bug which the original mail.local
- also had.
-
-* Add O_NOFOLLOW to disallow symlinks.
-
-Thanks-to: BSDNow Episode 152, made me dive dma to check when they talked
- about the mail.local bug.
----
- dma-mbox-create.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/dma-mbox-create.c b/dma-mbox-create.c
-index 532a7af..45a4792 100644
---- a/dma-mbox-create.c
-+++ b/dma-mbox-create.c
-@@ -142,7 +142,7 @@ main(int argc, char **argv)
- logfail(EX_CANTCREAT, "cannot build mbox path for `%s/%s'", _PATH_MAILDIR, user);
- }
-
-- f = open(fn, O_RDONLY|O_CREAT, 0600);
-+ f = open(fn, O_RDONLY|O_CREAT|O_NOFOLLOW, 0600);
- if (f < 0)
- logfail(EX_NOINPUT, "cannt open mbox `%s'", fn);
-