aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot-devel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-29 21:57:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-29 21:57:54 +0000
commit7ea5aa1e24b42bed4ddda29a305b58422eea8170 (patch)
treedc798a6bd801a78b3ff26f3d3755535f1ecdbf4f /mail/dovecot-devel/Makefile
parent30c18d2a4cae15ba3da39b7e5be7bfe722ce066f (diff)
downloadports-7ea5aa1e24b42bed4ddda29a305b58422eea8170.tar.gz
ports-7ea5aa1e24b42bed4ddda29a305b58422eea8170.zip
Notes
Diffstat (limited to 'mail/dovecot-devel/Makefile')
-rw-r--r--mail/dovecot-devel/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/mail/dovecot-devel/Makefile b/mail/dovecot-devel/Makefile
index f6f18e1663ce..27289f294ca9 100644
--- a/mail/dovecot-devel/Makefile
+++ b/mail/dovecot-devel/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= dovecot
-PORTVERSION= 0.99.10.4
-PORTREVISION= 2
+PORTVERSION= 0.99.10.5
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/
@@ -17,6 +16,8 @@ COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
USE_REINPLACE= yes
+USE_RC_SUBR= yes
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-shadow --enable-ipv6 \
@@ -33,10 +34,14 @@ DOCS= auth.txt configuration.txt design.txt \
nfs.txt dovecot-ldap.conf dovecot-pgsql.conf \
dovecot-openssl.cnf securecoding.txt
+OPTIONS= SASL2 "SASL2 support" off \
+ VPOPMAIL "VPopMail support" off \
+ LDAP "OpenLDAP support" off \
+ PGSQL "PostgreSQL support" off
+
.include <bsd.port.pre.mk>
## SASL2 support
-OPTIONS+= SASL2 "SASL2 support" off
#
# SASL provides authentication support to
# session-based protocols. This is can be
@@ -48,7 +53,6 @@ CONFIGURE_ARGS+= --with-cyrus-sasl2
.endif
## VPopMail Support
-OPTIONS+= VPOPMAIL "VPopMail support" off
#
# vpopmail provides easy authentication and
# multi-domain features. It was originally
@@ -61,7 +65,6 @@ CONFIGURE_ARGS+= --with-vpopmail
.endif
## OpenLDAP Support
-OPTIONS+= LDAP "OpenLDAP support" off
#
# LDAP is the light-weight directory access
# protocol and can be used by Dovecot for its
@@ -73,7 +76,6 @@ CONFIGURE_ARGS+= --with-ldap
.endif
## PostgreSQL Support
-OPTIONS+= PGSQL "PostgreSQL support" off
#
# PostgreSQL is a powerful SQL database that
# can be used to store user tables.
@@ -83,12 +85,6 @@ LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql7
CONFIGURE_ARGS+= --with-pgsql
.endif
-.if ${OSVERSION} >= 500038
-RC_SUBR?= /etc/rc.subr
-.else
-USE_RC_SUBR= yes
-.endif
-
pre-build:
@${REINPLACE_CMD} -e 's,%%SSLDIR%%,/var/dovecot/ssl,' \
${WRKSRC}/doc/mkcert.sh \