aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-12-10 15:30:08 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-12-10 15:30:08 +0000
commitd994375584630eb0a7ec78a6535a6e24cfb28265 (patch)
treed5b9af1ec342acb1e41865e391029ca259010b97 /mail/dovecot/Makefile
parentea8549354e9442e5772a8d0b8d8abffd4d3ad619 (diff)
Notes
Diffstat (limited to 'mail/dovecot/Makefile')
-rw-r--r--mail/dovecot/Makefile21
1 files changed, 3 insertions, 18 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 887c7dcf2f7e..cbb3fbb16789 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dovecot
-PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTVERSION= 1.2.8
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${DOVECOTVERSION}/ \
http://www.rename-it.nl/dovecot/${DOVECOTVERSION}/
@@ -52,12 +51,11 @@ PORTDOCS= *.txt wiki ${DOCS}
DOVECOT_UID?= 143
DOVECOT_GID?= 143
-PROTOCOLS= imap
+PROTOCOLS= imap pop3
OPTIONS= KQUEUE "kqueue(2) support" on \
SSL "SSL support" on \
IPV6 "IPv6 support" on \
- POP3 "POP3 support" on \
LDA "LDA support" on \
MANAGESIEVE "ManageSieve support" on \
GSSAPI "GSSAPI support" off \
@@ -91,7 +89,7 @@ CONFIGURE_ARGS+= --with-ioloop=kqueue
## SSL support
#
.if defined(WITH_SSL) && !defined(WITHOUT_SSL)
-PROTOCOLS+= imaps
+PROTOCOLS+= imaps pop3s
.else
CONFIGURE_ARGS+= --without-ssl
.endif
@@ -102,19 +100,6 @@ CONFIGURE_ARGS+= --without-ssl
CONFIGURE_ARGS+= --disable-ipv6
.endif
-## POP3 support
-#
-.if defined(WITHOUT_POP3)
-CONFIGURE_ARGS+= --without-pop3d
-PLIST_SUB+= POP3="@comment "
-.else
-PROTOCOLS+= pop3
-.if defined(WITH_SSL) && !defined(WITHOUT_SSL)
-PROTOCOLS+= pop3s
-.endif
-PLIST_SUB+= POP3=""
-.endif
-
## LDA support
#
.if defined(WITHOUT_LDA)