aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:55:11 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:55:11 +0000
commitfc631bd198463ccfb8fa6d003bb0f253491bdefd (patch)
treeb03c3f552fc588d4ebd0ace3a4fee6867c59c05f /mail/dovecot
parent65817b752ef49f9fa4f57d225163dc1fc37bcc66 (diff)
downloadports-fc631bd198463ccfb8fa6d003bb0f253491bdefd.tar.gz
ports-fc631bd198463ccfb8fa6d003bb0f253491bdefd.zip
Notes
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile58
-rw-r--r--mail/dovecot/distinfo5
-rw-r--r--mail/dovecot/files/patch-dovecot-example.conf35
-rw-r--r--mail/dovecot/files/patch-src-lib-index-mail-index-sync-ext.c16
-rw-r--r--mail/dovecot/pkg-message2
-rw-r--r--mail/dovecot/pkg-plist34
6 files changed, 57 insertions, 93 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 5b09fc0cb769..6b3cf1301943 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= dovecot
-DISTVERSION= 1.0.alpha4
-PORTREVISION= 2
+DISTVERSION= 1.0.alpha5
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
@@ -16,6 +15,7 @@ MAINTAINER= robin@isometry.net
COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -26,13 +26,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PKGMESSAGE= ${WRKDIR}/pkg-message
-DOCS= USE-WIKI-INSTEAD \
+PORTDOCS= USE-WIKI-INSTEAD \
auth-protocol.txt auth.txt configuration.txt design.txt \
- index.txt mail-storages.txt mkcert.sh multiaccess.txt \
- nfs.txt securecoding.txt variables.txt \
- dovecot-ldap.conf dovecot-sql.conf dovecot-openssl.cnf
+ index.txt mail-storages.txt multiaccess.txt nfs.txt \
+ securecoding.txt variables.txt
OPTIONS= SASL2 "SASL2 support" off \
+ GSSAPI "GSSAPI support" off \
VPOPMAIL "VPopMail support" off \
LDAP "OpenLDAP support" off \
PGSQL "PostgreSQL support" off \
@@ -41,7 +41,7 @@ OPTIONS= SASL2 "SASL2 support" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500038 || !defined(WITH_RCORDER)
+.if ( ${OSVERSION} < 500038 ) || !defined(WITH_RCORDER)
USE_RC_SUBR= dovecot.sh
.else
USE_RCORDER= dovecot.sh
@@ -49,15 +49,19 @@ USE_RCORDER= dovecot.sh
## SASL2 support
#
-# SASL provides authentication support to
-# session-based protocols. This is can be
-# used by dovecot for authentication sources.
-#
.if defined(WITH_SASL2)
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --with-cyrus-sasl2
.endif
+## GSSAPI support
+#
+.if defined(WITH_GSSAPI)
+CONFIGURE_ARGS+= --with-gssapi
+.else
+CONFIGURE_ARGS+= --without-gssapi
+.endif
+
## VPopMail Support
#
.if defined(WITH_VPOPMAIL)
@@ -89,35 +93,19 @@ USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
.endif
+pre-configure:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's/^\(SUBDIRS = src\) doc/\1/' \
+ ${WRKSRC}/Makefile.in
+.endif
+
post-build:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
- ${WRKSRC}/dovecot-example.conf >${WRKDIR}/dovecot.conf.sample
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
+ ${WRKSRC}/dovecot-example.conf
pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-do-install:
- @${MKDIR} ${PREFIX}/libexec/dovecot
- ${INSTALL_PROGRAM} \
- ${WRKSRC}/src/auth/checkpassword-reply \
- ${WRKSRC}/src/auth/dovecot-auth \
- ${WRKSRC}/src/deliver/deliver \
- ${WRKSRC}/src/imap/imap \
- ${WRKSRC}/src/imap-login/imap-login \
- ${WRKSRC}/src/pop3/pop3 \
- ${WRKSRC}/src/pop3-login/pop3-login \
- ${WRKSRC}/src/util/rawlog \
- ${PREFIX}/libexec/dovecot/
- ${INSTALL_PROGRAM} \
- ${WRKSRC}/src/master/dovecot \
- ${WRKSRC}/src/util/dovecotpw \
- ${PREFIX}/sbin/
- ${INSTALL_DATA} ${WRKDIR}/dovecot.conf.sample ${PREFIX}/etc/
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
-
post-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
diff --git a/mail/dovecot/distinfo b/mail/dovecot/distinfo
index 9734480a7fcb..660d14c8d28a 100644
--- a/mail/dovecot/distinfo
+++ b/mail/dovecot/distinfo
@@ -1,2 +1,3 @@
-MD5 (dovecot-1.0.alpha4.tar.gz) = 65f8e2cd097e80b536a75c31a974b5de
-SIZE (dovecot-1.0.alpha4.tar.gz) = 1203714
+MD5 (dovecot-1.0.alpha5.tar.gz) = a3277835f04d73485ff5ce3cc3daeea7
+SHA256 (dovecot-1.0.alpha5.tar.gz) = 12330727df9ee513482b60830b0496fec338e3e866fcb18bd73a596827aaabd8
+SIZE (dovecot-1.0.alpha5.tar.gz) = 1266342
diff --git a/mail/dovecot/files/patch-dovecot-example.conf b/mail/dovecot/files/patch-dovecot-example.conf
index d0b5d1a16b22..455793ddcda7 100644
--- a/mail/dovecot/files/patch-dovecot-example.conf
+++ b/mail/dovecot/files/patch-dovecot-example.conf
@@ -1,5 +1,5 @@
---- dovecot-example.conf.orig Thu Oct 20 15:33:33 2005
-+++ dovecot-example.conf Thu Oct 20 15:38:40 2005
+--- dovecot-example.conf.orig Sun Dec 18 15:10:59 2005
++++ dovecot-example.conf Sun Dec 18 15:15:02 2005
@@ -7,7 +7,7 @@
# Default values are shown after each value, it's not required to uncomment
# any of the lines. Exception to this are paths, they're just examples
@@ -18,16 +18,7 @@
# IP or host address where to listen in for connections. It's not currently
# possible to specify multiple addresses. "*" listens in all IPv4 interfaces.
-@@ -95,7 +95,7 @@
- # only it has access, it's used to control access for authentication process.
- # Note that this user is NOT used to access mails.
- # http://wiki.dovecot.org/UserIds
--#login_user = dovecot
-+login_user = dovecot
-
- # Set max. process size in megabytes. If you don't use
- # login_process_per_connection you might need to grow this.
-@@ -148,7 +148,7 @@
+@@ -153,7 +153,7 @@
# Show more verbose process titles (in ps). Currently shows user name and
# IP address. Useful for seeing who are actually using the IMAP processes
# (eg. shared mailboxes or if same uid is used for multiple accounts).
@@ -36,7 +27,7 @@
# Show protocol level SSL errors.
#verbose_ssl = no
-@@ -164,12 +164,12 @@
+@@ -169,12 +169,12 @@
# non-valid GID as primary group ID aren't allowed to log in. If user
# belongs to supplementary groups with non-valid GIDs, those groups are
# not set.
@@ -51,7 +42,7 @@
# ':' separated list of directories under which chrooting is allowed for mail
# processes (ie. /var/mail will allow chrooting to /var/mail/foo/bar too).
-@@ -205,7 +205,7 @@
+@@ -210,7 +210,7 @@
# default_mail_env = mbox:~/mail/:INBOX=/var/mail/%u
# default_mail_env = mbox:/var/mail/%d/%n/:INDEX=/var/indexes/%d/%n
#
@@ -60,7 +51,7 @@
# If you need to set multiple mailbox locations or want to change default
# namespace settings, you can do it by defining namespace sections:
-@@ -391,12 +391,12 @@
+@@ -400,12 +400,12 @@
protocol imap {
# Login executable location.
@@ -76,7 +67,7 @@
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
-@@ -405,7 +405,7 @@
+@@ -414,7 +414,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@@ -85,7 +76,7 @@
# Send IMAP capabilities in greeting message. This makes it unnecessary for
# clients to request it with CAPABILITY command, so it saves one round-trip.
-@@ -435,7 +435,7 @@
+@@ -444,7 +444,7 @@
# With mbox storage a mailbox can contain either mails or submailboxes,
# but not both. Thunderbird separates these two by forcing server to
# accept '/' suffix in mailbox names in subscriptions list.
@@ -94,7 +85,7 @@
}
##
-@@ -444,10 +444,10 @@
+@@ -453,10 +453,10 @@
protocol pop3 {
# Login executable location.
@@ -107,7 +98,7 @@
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
-@@ -484,7 +484,7 @@
+@@ -493,7 +493,7 @@
# installations. %08Xu%08Xv will be the new default, so use it for new
# installations.
#
@@ -116,7 +107,7 @@
# POP3 logout format string:
# %t - number of TOP commands
-@@ -498,7 +498,7 @@
+@@ -507,7 +507,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@@ -125,7 +116,7 @@
# Workarounds for various client bugs:
# outlook-no-nuls:
-@@ -507,7 +507,7 @@
+@@ -516,7 +516,7 @@
# oe-ns-eoh:
# Outlook Express and Netscape Mail breaks if end of headers-line is
# missing. This option simply sends it if it's missing.
@@ -134,7 +125,7 @@
}
##
-@@ -515,7 +515,7 @@
+@@ -524,7 +524,7 @@
##
# Executable location
diff --git a/mail/dovecot/files/patch-src-lib-index-mail-index-sync-ext.c b/mail/dovecot/files/patch-src-lib-index-mail-index-sync-ext.c
deleted file mode 100644
index af432b7b06bc..000000000000
--- a/mail/dovecot/files/patch-src-lib-index-mail-index-sync-ext.c
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: src/lib-index/mail-index-sync-ext.c
-===================================================================
-RCS file: /home/cvs/dovecot/src/lib-index/mail-index-sync-ext.c,v
-retrieving revision 1.11
-retrieving revision 1.12
-diff -u -r1.11 -r1.12
---- src/lib-index/mail-index-sync-ext.c 24 Sep 2005 10:12:03 -0000 1.11
-+++ src/lib-index/mail-index-sync-ext.c 28 Oct 2005 14:10:13 -0000 1.12
-@@ -332,6 +332,7 @@
- unsigned i, count = array_count(&map->extensions);
- ssize_t diff = (ssize_t)new_size - (ssize_t)old_size;
-
-+ ext = array_idx_modifyable(&map->extensions, 0);
- for (i = ext_id + 1; i < count; i++)
- ext[i].hdr_offset += diff;
- }
diff --git a/mail/dovecot/pkg-message b/mail/dovecot/pkg-message
index c0011013d5ee..7169bd0bfa6f 100644
--- a/mail/dovecot/pkg-message
+++ b/mail/dovecot/pkg-message
@@ -7,7 +7,7 @@
the systems passwd file and use the default /var/mail/$USER mbox
files.
- cd %%PREFIX%%/etc; cp dovecot.conf.sample dovecot.conf
+ cd %%PREFIX%%/etc; cp dovecot-example.conf dovecot.conf
echo dovecot_enable="YES" >> /etc/rc.conf
diff --git a/mail/dovecot/pkg-plist b/mail/dovecot/pkg-plist
index a7af67d7b768..00de86d73707 100644
--- a/mail/dovecot/pkg-plist
+++ b/mail/dovecot/pkg-plist
@@ -1,5 +1,21 @@
@comment $FreeBSD$
-etc/dovecot.conf.sample
+etc/dovecot-example.conf
+lib/dovecot/imap/libimap_quota_plugin.a
+lib/dovecot/imap/libimap_quota_plugin.la
+lib/dovecot/imap/libimap_quota_plugin.so
+lib/dovecot/imap/libquota_plugin.so
+lib/dovecot/imap/libtrash_plugin.so
+@dirrm lib/dovecot/imap
+lib/dovecot/lda/libquota_plugin.so
+lib/dovecot/lda/libtrash_plugin.so
+@dirrm lib/dovecot/lda
+lib/dovecot/libquota_plugin.a
+lib/dovecot/libquota_plugin.la
+lib/dovecot/libquota_plugin.so
+lib/dovecot/libtrash_plugin.a
+lib/dovecot/libtrash_plugin.la
+lib/dovecot/libtrash_plugin.so
+@dirrm lib/dovecot
libexec/dovecot/checkpassword-reply
libexec/dovecot/deliver
libexec/dovecot/dovecot-auth
@@ -11,19 +27,3 @@ libexec/dovecot/rawlog
@dirrm libexec/dovecot
sbin/dovecot
sbin/dovecotpw
-%%PORTDOCS%%%%DOCSDIR%%/USE-WIKI-INSTEAD
-%%PORTDOCS%%%%DOCSDIR%%/auth-protocol.txt
-%%PORTDOCS%%%%DOCSDIR%%/auth.txt
-%%PORTDOCS%%%%DOCSDIR%%/configuration.txt
-%%PORTDOCS%%%%DOCSDIR%%/design.txt
-%%PORTDOCS%%%%DOCSDIR%%/index.txt
-%%PORTDOCS%%%%DOCSDIR%%/mail-storages.txt
-%%PORTDOCS%%%%DOCSDIR%%/mkcert.sh
-%%PORTDOCS%%%%DOCSDIR%%/multiaccess.txt
-%%PORTDOCS%%%%DOCSDIR%%/nfs.txt
-%%PORTDOCS%%%%DOCSDIR%%/securecoding.txt
-%%PORTDOCS%%%%DOCSDIR%%/variables.txt
-%%PORTDOCS%%%%DOCSDIR%%/dovecot-ldap.conf
-%%PORTDOCS%%%%DOCSDIR%%/dovecot-openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/dovecot-sql.conf
-%%PORTDOCS%%@dirrm %%DOCSDIR%%