aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-01-29 20:59:18 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2018-01-29 20:59:18 +0000
commit14986c7295905f23f149df2bb68d50ea07d19fe7 (patch)
tree81724dc081726050ee90bc21958ebc0adf16fbd0 /mail/dovecot
parentbb9cc6503907f2802085e54fcad0bc5b751be72b (diff)
downloadports-14986c7295905f23f149df2bb68d50ea07d19fe7.tar.gz
ports-14986c7295905f23f149df2bb68d50ea07d19fe7.zip
Notes
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/files/patch-src_lib-auth_auth-client-request.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 912c52ae9efd..e2b44792bce1 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -13,7 +13,7 @@
PORTNAME= dovecot
PORTVERSION= 2.2.33.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.2/
diff --git a/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
new file mode 100644
index 000000000000..7cc94b62f148
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib-auth_auth-client-request.c
@@ -0,0 +1,10 @@
+--- src/lib-auth/auth-client-request.c.orig 2017-10-05 17:10:44 UTC
++++ src/lib-auth/auth-client-request.c
+@@ -180,6 +180,7 @@ void auth_client_request_abort(struct auth_client_requ
+
+ auth_client_send_cancel(request->conn->client, request->id);
+ call_callback(request, AUTH_REQUEST_STATUS_ABORT, NULL, NULL);
++ pool_unref(&request->pool);
+ }
+
+ unsigned int auth_client_request_get_id(struct auth_client_request *request)