aboutsummaryrefslogtreecommitdiff
path: root/mail/dsbl-testers
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-01-31 23:25:50 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-01-31 23:25:50 +0000
commit967c2ae805c47bb294a9250afd7c13d5ac8c6967 (patch)
tree8a3fbe7bbcb091d348893f30114e83701f306a4b /mail/dsbl-testers
parent7dafd7e358734d2393e09502839664d9f12affd1 (diff)
downloadports-967c2ae805c47bb294a9250afd7c13d5ac8c6967.tar.gz
ports-967c2ae805c47bb294a9250afd7c13d5ac8c6967.zip
Notes
Diffstat (limited to 'mail/dsbl-testers')
-rw-r--r--mail/dsbl-testers/Makefile49
-rw-r--r--mail/dsbl-testers/distinfo3
-rw-r--r--mail/dsbl-testers/files/patch-firemake_makefiletop11
-rw-r--r--mail/dsbl-testers/pkg-descr5
-rw-r--r--mail/dsbl-testers/pkg-plist3
5 files changed, 36 insertions, 35 deletions
diff --git a/mail/dsbl-testers/Makefile b/mail/dsbl-testers/Makefile
index 04c17fe28da2..20428af84d17 100644
--- a/mail/dsbl-testers/Makefile
+++ b/mail/dsbl-testers/Makefile
@@ -5,14 +5,12 @@
# $FreeBSD$
#
-PORTNAME= dsbl
-PORTVERSION= 0.9.4
+PORTNAME= dsbl-testers
+PORTVERSION= 0.9.5
CATEGORIES= mail
-MASTER_SITES= http://ares.penguinhosting.net/~ian/projects/ \
+MASTER_SITES= http://firestuff.org/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
-PKGNAMESUFFIX= -testers
-DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= dean@odyssey.apana.org.au
COMMENT= Testing software configured to work with DSBL/DSBL-compliant services
@@ -20,41 +18,32 @@ COMMENT= Testing software configured to work with DSBL/DSBL-compliant services
BUILD_DEPENDS= ${LOCALBASE}/include/firestring.h:${PORTSDIR}/misc/firestring \
${LOCALBASE}/include/firedns.h:${PORTSDIR}/dns/firedns
-USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LIBS="${LIBS} ${PTHREAD_LIBS}"
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}
+ LIBS="${LIBS} ${PTHREAD_LIBS}" PREFIX="${PREFIX}"
INSTALL_SHLIBS= yes
-MAN1= formmailtest.1 relaytest.1 socks5test.1 \
- httptest.1 socks4test.1 spamtrap.1
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= auth-relaytest.1 formmailtest.1 getcookie.1 httptest.1 \
+ relaytest.1 socks4test.1 socks5test.1 spamtrap.1
MAN5= dsbl.conf.5
+post-patch:
+ @-${RM} ${WRKSRC}/firemake/*.orig
+
# install ourselves to insure proper ownership/permissions
# as dictated by port's rules
-BINARY_FILES= formmailtest httptest relaytest socks4test socks5test \
- spamtrap
+BINARY_FILES= auth-relaytest formmailtest httptest relaytest \
+ getcookie socks4test socks5test spamtrap
CONF_FILES= conf/dsbl.conf
-post-configure:
-# let the configure script findings be used
- @${REINPLACE_CMD} -E \
- -e 's|\?=|=|' \
- ${BUILD_WRKSRC}/${MAKEFILE}
-
do-install:
-.for file in ${BINARY_FILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
-.endfor
-.for file in ${CONF_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/etc
-.endfor
-.for file in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/man/${file} ${MANPREFIX}/man/man1
-.endfor
-.for file in ${MAN5}
- @${INSTALL_MAN} ${WRKSRC}/man/${file} ${MANPREFIX}/man/man5
-.endfor
+ cd ${WRKSRC} && \
+ ${INSTALL_PROGRAM} ${BINARY_FILES} ${PREFIX}/bin && \
+ ${INSTALL_DATA} ${CONF_FILES} ${PREFIX}/etc
+ cd ${WRKSRC}/man && \
+ ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1 && \
+ ${INSTALL_MAN} ${MAN5} ${MAN5PREFIX}/man/man5
.include <bsd.port.mk>
diff --git a/mail/dsbl-testers/distinfo b/mail/dsbl-testers/distinfo
index e9eb50b3f06c..17b77c8c1f8a 100644
--- a/mail/dsbl-testers/distinfo
+++ b/mail/dsbl-testers/distinfo
@@ -1 +1,2 @@
-MD5 (dsbl-testers-0.9.4.tar.gz) = f4872966d3b448839dbd28e180fedb89
+MD5 (dsbl-testers-0.9.5.tar.gz) = 55285009d90914048df2f62f4c9525d8
+SIZE (dsbl-testers-0.9.5.tar.gz) = 129952
diff --git a/mail/dsbl-testers/files/patch-firemake_makefiletop b/mail/dsbl-testers/files/patch-firemake_makefiletop
new file mode 100644
index 000000000000..77d5aa87173b
--- /dev/null
+++ b/mail/dsbl-testers/files/patch-firemake_makefiletop
@@ -0,0 +1,11 @@
+--- firemake/makefiletop.orig Sun Feb 1 02:04:08 2004
++++ firemake/makefiletop Sun Feb 1 02:04:51 2004
+@@ -3,7 +3,7 @@
+ #require make
+ #phase makefile
+ dispn "Writing Makefile top entries..."
+-if test "$MAKE_CONDSET" = "y"; then
++if test "$MAKE_CONDSET" = "never"; then
+ $ECHO "PREFIX ?= $FM_PREFIX"
+
+ if test "$FM_MANDIRSTRICT" = "y"; then
diff --git a/mail/dsbl-testers/pkg-descr b/mail/dsbl-testers/pkg-descr
index 97377639672b..a786a81a9116 100644
--- a/mail/dsbl-testers/pkg-descr
+++ b/mail/dsbl-testers/pkg-descr
@@ -1,13 +1,10 @@
-From the README file:
-
This package contains testing software configured to work with the
DSBL (http://dsbl.org/) or DSBL-compliant services. It enables you
to send tests to servers based on spam that you receive. If those
tests succeed, the results will reach the DSBL host in question,
and the relay will be listed.
-WWW: http://ares.penguinhosting.net/~ian/
+WWW: http://ares.penguinhosting.net/~ian/
- Dean
-
dean@odyssey.apana.org.au
diff --git a/mail/dsbl-testers/pkg-plist b/mail/dsbl-testers/pkg-plist
index 951f956f649c..6b55d119ad24 100644
--- a/mail/dsbl-testers/pkg-plist
+++ b/mail/dsbl-testers/pkg-plist
@@ -1,4 +1,7 @@
+@comment $FreeBSD$
+bin/auth-relaytest
bin/formmailtest
+bin/getcookie
bin/httptest
bin/relaytest
bin/socks4test