aboutsummaryrefslogtreecommitdiff
path: root/mail/dspam-devel/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-12-04 17:46:30 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-12-04 17:46:30 +0000
commit952ce06a573c9a034fdd9bfe75db8498f57975e4 (patch)
tree5d5a123a33c96e9840bcbfc76fbc32fa6d85270e /mail/dspam-devel/Makefile
parent3fe1be2c2c26c8760ccba865b65e224ae56abec5 (diff)
Update to SNAP_DATE 20041201.1330, which supports daemonized dspam
PR: 74599 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Notes
Notes: svn path=/head/; revision=123110
Diffstat (limited to 'mail/dspam-devel/Makefile')
-rw-r--r--mail/dspam-devel/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 032b8d8971d5..48e06154b27e 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -16,7 +16,7 @@ COMMENT= Bayesian spam filter - development version
WRKSRC= ${WRKDIR}/dspam-cvs-devel${SNAP_DATE}
-SNAP_DATE= .20041125.0945
+SNAP_DATE= .20041201.1330
PORTVER_MAJ= 3.3.0.a
## debug / log / admin options
@@ -27,6 +27,7 @@ OPTIONS+= VERBOSE_DEBUG "Enable debug in LOGDIR/dspam.debug" off
#OPTIONS+= SAT "Log spam source addresses to syslog" on
#OPTIONS+= PARSE_TO_HEADERS "Get user from To header on fp spam" off
OPTIONS+= PREF_EXT "Preferences in database not in files" off
+OPTIONS+= DAEMON "Daemonize dspam; speak LMTP; EXPERIMENTAL" off
## algorithm options
OPTIONS+= GRAHAM_BAYES "Enable Graham (traditional) bayesian" on
OPTIONS+= BURTON_BAYES "Enable Burton (alternative) bayesian" on
@@ -162,10 +163,14 @@ CONFIGURE_ARGS+= --enable-verbose-debug
#CONFIGURE_ARGS+= --enable-parse-to-headers
#.endif
-.if defined(PREF_EXT)
+.if defined(WITH_PREF_EXT)
CONFIGURE_ARGS+= --enable-preferences-extension
.endif
+.ifdef(WITH_DAEMON)
+CONFIGURE_ARGS+= --enable-daemon
+.endif
+
.if !defined(WITH_GRAHAM_BAYES)
CONFIGURE_ARGS+= --disable-traditional-bayesian
.endif
@@ -315,7 +320,7 @@ CONFIGURE_ARGS+= --with-storage-driver=ora_drv \
DBDRV_COUNT:= ${DBDRV_COUNT:S/o//}
.endif
-.if defined(WITH_BDB)
+.if defined(WITH_BDB4)
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --with-storage-driver=libdb4_drv \
--with-db4-includes=${LOCALBASE}/include/db41