aboutsummaryrefslogtreecommitdiff
path: root/mail/dspam-devel
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-12 16:08:20 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-12 16:08:20 +0000
commit30d300ebcb7e96fb94762ffcd456afddda80264d (patch)
tree75cb8dca44413670836392fec45fb2ae576b715d /mail/dspam-devel
parentf5c48bb9a599be5d8808d9ce8086474700a656b7 (diff)
downloadports-30d300ebcb7e96fb94762ffcd456afddda80264d.tar.gz
ports-30d300ebcb7e96fb94762ffcd456afddda80264d.zip
Notes
Diffstat (limited to 'mail/dspam-devel')
-rw-r--r--mail/dspam-devel/Makefile22
-rw-r--r--mail/dspam-devel/files/UPDATING11
2 files changed, 27 insertions, 6 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 38818bf8bcc8..2d0d6c743fb9 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -12,7 +12,7 @@
# Else the port will be broken. Thanks.
PORTNAME= dspam-devel
-PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}
+PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}_1
CATEGORIES= mail
MASTER_SITES= # set later
@@ -21,9 +21,8 @@ COMMENT= Bayesian spam filter - development version
PORTVER_MAJ= 3.6.8
SNAP_DATE= .20061010.1118
-_UPD_LINE_NO= 23
-MIN_OPTIONS_VER= ${PORTNAME}-3.6.6
+MIN_OPTIONS_VER= ${PORTNAME}-3.6.8.20061010.1118_1
.ifdef(SNAP_DATE)
MASTER_SITES= ${MASTER_SITE_LOCAL} \
@@ -83,6 +82,7 @@ OPTIONS+= CYRUS23_LDA "Use Cyrus's 2.3 deliver as LDA" off
OPTIONS+= EXIM_LDA "Use Exim as local delivery agent" off
OPTIONS+= MAILDROP_LDA "Use Maildrop as local delivery agent" off
OPTIONS+= PROCMAIL_LDA "Use Procmail as local delivery agent" off
+OPTIONS+= SAFECAT_LDA "Use Safecat as local delivery agent" off
OPTIONS+= SENDMAIL_LDA "Use Sendmail as local delivery agent" off
OPTIONS+= SENDMAIL "Play nice with sendmail server" off
@@ -125,6 +125,7 @@ DSPAM_MODE?= 4510
DSPAM_OWNER?= root
DSPAM_GROUP?= mail
+DSPAM_ETC?= ${LOCALBASE}/etc
DSPAM_HOME?= ${_VAR_DIR}/db/dspam
DSPAM_HOME_OWNER?= ${DSPAM_OWNER}
DSPAM_HOME_GROUP?= ${DSPAM_GROUP}
@@ -136,6 +137,7 @@ DSPAM_HOME_MODE?= 0770
BROKEN= for now dspam doesn't build on HEAD with PGSQL DB driver; it should be OK with any other driver
.endif
+CONFIGURE_ARGS+= --sysconfdir=${DSPAM_ETC}
CONFIGURE_ARGS+= --with-logdir=${LOG_DIR}
PLIST_SUB+= LOG_DIR=${LOG_DIR}
@@ -336,7 +338,7 @@ CONFIGURE_ARGS+= --enable-domain-scale
.endif
# add one 'o' here for each new LDA
-LDA_TOTAL_COUNT= oooooooo # 8
+LDA_TOTAL_COUNT= ooooooooo # 9
LDA_COUNT= ${LDA_TOTAL_COUNT}
.if defined(WITH_CYRUS21_LDA)
@@ -380,6 +382,12 @@ CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/bin/procmail'
LDA_COUNT:= ${LDA_COUNT:S/o//}
.endif
+.ifdef(WITH_SAFECAT_LDA)
+RUN_DEPENDS+= safecat:${PORTSDIR}/sysutils/safecat
+CONFIGURE_ARGS+= --with-delivery-agent='${LOCALBASE}/safecat tmp new'
+LDA_COUNT:= ${LDA_COUNT:S/o//}
+.endif
+
.ifdef(WITH_SENDMAIL_LDA) && exists(/usr/sbin/sendmail)
CONFIGURE_ARGS+= --with-delivery-agent=/usr/sbin/sendmail
LDA_COUNT:= ${LDA_COUNT:S/o//}
@@ -452,7 +460,8 @@ pre-everything::
.ifndef(MAINT)
@${ECHO_CMD} ""
@${ECHO_CMD} "Last ${FILESDIR}/UPDATING entry:"
- @${GREP} -B 1 -A ${_UPD_LINE_NO} ${PKGNAME} ${FILESDIR}/UPDATING
+ @${ECHO_CMD} "###########################################################################"
+ @${SED} -n < ${FILESDIR}/UPDATING "/^# ${PKGNAME}/,/^#####/p"
@${ECHO_CMD} ""
@sleep 5
.endif
@@ -466,6 +475,7 @@ pre-extract: check-options-version
@${ECHO_CMD} "DSPAM_OWNER=${DSPAM_OWNER} (default: root)"
@${ECHO_CMD} "DSPAM_GROUP=${DSPAM_GROUP} (default: mail)"
@${ECHO_CMD} "DSPAM_MODE=${DSPAM_MODE}"
+ @${ECHO_CMD} "DSPAM_ETC=${DSPAM_ETC} (default: ${LOCALBASE}/etc"
@${ECHO_CMD} "DSPAM_HOME=${DSPAM_HOME} (default: ${_VAR_DIR}/db/dspam)"
@${ECHO_CMD} "DSPAM_HOME_OWNER=${DSPAM_HOME_OWNER}"
@${ECHO_CMD} "DSPAM_HOME_GROUP=${DSPAM_HOME_GROUP}"
@@ -500,7 +510,7 @@ pre-configure:
@${ECHO_CMD}
.if !( ${LDA_TOTAL_COUNT:S/o//}==${LDA_COUNT} || ${LDA_TOTAL_COUNT}==${LDA_COUNT} )
@${ECHO_CMD} "You can only use one local delivery agent at once."
- @${ECHO_CMD} "See ${LOCALBASE}/etc/dspam.conf for how to chage it at run time."
+ @${ECHO_CMD} "See ${DSPAM_ETC}/dspam.conf for how to change it at run time."
@${FALSE}
.endif
.if ${_DBDRV}==""
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index e32e3ccb404f..7a46df02aaaa 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -11,6 +11,17 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-devel-3.6.8.20061010.1118_1
+#
+
+Port changes:
+- added safecat as LDA [1]
+- give user the possibility to configure where dspam.conf is [1]
+
+[1] patch from Emil Isberg <emil@pyttemjuk.se> [1]
+
+
+###########################################################################
# dspam-devel-3.6.8.20061010.1118
#