aboutsummaryrefslogtreecommitdiff
path: root/mail/dspam-devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-01 14:57:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-01 14:57:48 +0000
commit48bbb6cb4410848aae7ad27e06c1529323fab481 (patch)
tree52b558e2e2e4234e9317f96ff2b2ab5cd41f50d3 /mail/dspam-devel
parent080e15aaffb03d33fef065cbf41207d2062ef719 (diff)
downloadports-48bbb6cb4410848aae7ad27e06c1529323fab481.tar.gz
ports-48bbb6cb4410848aae7ad27e06c1529323fab481.zip
Notes
Diffstat (limited to 'mail/dspam-devel')
-rw-r--r--mail/dspam-devel/Makefile16
-rw-r--r--mail/dspam-devel/files/UPDATING9
-rw-r--r--mail/dspam-devel/files/dspam-devel.in (renamed from mail/dspam-devel/files/dspam-devel.sh.in)29
-rw-r--r--mail/dspam-devel/pkg-message4
4 files changed, 36 insertions, 22 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index 24781c8e9bb7..0f8d571663b1 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -2,7 +2,7 @@
# Date created: 24 Jun 2004
# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
#
-# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.44 2006/04/22 12:43:37 itetcu Exp $
+# $Tecnik: ports/mail/dspam-devel/Makefile,v 1.49 2006/04/30 10:44:28 itetcu Exp $
# $FreeBSD$
#
@@ -13,6 +13,7 @@
PORTNAME= dspam-devel
PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= # set later
@@ -21,9 +22,9 @@ COMMENT= Bayesian spam filter - development version
PORTVER_MAJ= 3.6.5
#SNAP_DATE= .20060421.2101
-_UPD_LINE_NO= 44
+_UPD_LINE_NO= 8
-MIN_OPTIONS_VER= ${PORTNAME}-3.6.4..20060421.2101
+MIN_OPTIONS_VER= ${PORTNAME}-3.6.5
.ifdef(SNAP_DATE)
MASTER_SITES= http://sce-tindy.tecnik93.com/FreeBSD/ports/${PORTNAME}/sources/ \
@@ -177,8 +178,7 @@ CONFIGURE_ARGS+= --enable-preferences-extension
.ifndef(WITHOUT_DAEMON)
CONFIGURE_ARGS+= --enable-daemon
-RC_SUFX= .sh
-USE_RC_SUBR= ${PORTNAME}${RC_SUFX}
+USE_RC_SUBR= ${PORTNAME}
_SED_SCRIPT+= -e 's,%%DAEMON%%,,g'
SUB_LIST+= DSPAM_HOME=${DSPAM_HOME}
.else
@@ -420,7 +420,7 @@ CONFIGURE_ARGS+= --with-dspam-mode=${DSPAM_MODE}
RUN_DEPENDS+= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
. else
USE_APACHE= 1.3+
-.endif
+. endif
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
RUN_DEPENDS+= ${SITE_PERL}/mach/GD.pm:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS+= ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
@@ -531,7 +531,7 @@ pre-configure:
.endif
.ifndef(WITHOUT_DAEMON) && !( defined(USE_MYSQL) || \
!defined(WITHOUT_POSTGRESQL) || !defined(WITHOUT_HASH) )
- @${ECHO_CMD} "You need MySQL, PostgreSQL ot Hash for Daemon mode, because multithreading support is needed"
+ @${ECHO_CMD} "You need MySQL, PostgreSQL or Hash for Daemon mode, because multithreading support is needed"
@${FALSE}
.endif
.if ( defined(WITH_MYSQL40) && defined(WITH_MYSQL41) && !defined(WITHOUT_MYSQL50) && defined(WITH_MYSQL51))
@@ -652,7 +652,7 @@ check-options-version:
.ifdef(_OPTIONS_READ)
@(if ${PKG_VERSION} -t ${_OPTIONS_READ} ${MIN_OPTIONS_VER} | ${GREP} -q '<'; \
then ${ECHO_CMD} "You have unsupported (old) OPTIONS, please do a 'make config; make'\n" \
- exit 1; \
+ exit 1; \
fi)
.endif
diff --git a/mail/dspam-devel/files/UPDATING b/mail/dspam-devel/files/UPDATING
index b242e9f8112c..f7b1d0c8e3cf 100644
--- a/mail/dspam-devel/files/UPDATING
+++ b/mail/dspam-devel/files/UPDATING
@@ -11,6 +11,15 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-devel-3.6.5_1
+#
+
+Add dspam_debug rc.d options (default off): starts dspam with debug
+logging (you need at least WITH_DEBUG).
+Also fixed a few typos (like MIN_OPTIONS_VER value) in Makefile.
+
+
+###########################################################################
# dspam-devel-3.6.5
#
diff --git a/mail/dspam-devel/files/dspam-devel.sh.in b/mail/dspam-devel/files/dspam-devel.in
index 8fc2828bb386..eb2237dab128 100644
--- a/mail/dspam-devel/files/dspam-devel.sh.in
+++ b/mail/dspam-devel/files/dspam-devel.in
@@ -1,6 +1,6 @@
#!/bin/sh
# $FreeBSD$
-# formerly $ FreeBSD: ports/mail/dspam-devel/files/dspam.rc,v 1.2 2005/02/25 03:09:26 leeym Exp $
+#
# PROVIDE: dspam
# REQUIRE: DAEMON %%MYSQL%% %%PGSQL%% %%CLAMD%%
@@ -9,33 +9,38 @@
#
# Add the following lines to /etc/rc.conf[.local] to enable dspam:
-#
# dspam_enable="YES"
#
+# dspam_debug="YES" will start dspam with debug logging (you need ar least WITH_DEBUG)
+# you can also set the pid file via dspam_pidfile
+#
. %%RC_SUBR%%
-name=dspam
-rcvar=`set_rcvar`
+name="dspam"
+rcvar=${name}_enable
command=%%PREFIX%%/bin/${name}
-command_args="--daemon > /dev/null 2>&1 &"
+if checkyesno dspam_debug
+then
+ command_args="--daemon --debug > /dev/null 2>&1 &"
+else
+ command_args="--daemon > /dev/null 2>&1 &"
+fi
required_dirs=%%DSPAM_HOME%%
required_files=%%PREFIX%%/etc/${name}.conf
extra_commands=reload
-
reload()
{
kill -HUP `cat $pidfile`
}
-# set defaults
-
-dspam_enable=${dspam_enable:-"NO"}
-#dspam_flags=${dspam_flags:-"--daemon &"}
-
load_rc_config $name
-pidfile=${dspam_pidfile:-/var/run/dspam.pid}
+
+#defaults
+: ${dspam_enable="NO"}
+: ${dspam_debug="NO"}
+: ${dspam_pidfile:-/var/run/dspam.pid}
run_rc_command "$1"
diff --git a/mail/dspam-devel/pkg-message b/mail/dspam-devel/pkg-message
index e16575e809fd..a1f6028c9783 100644
--- a/mail/dspam-devel/pkg-message
+++ b/mail/dspam-devel/pkg-message
@@ -8,8 +8,8 @@
uname -a, dspam --version, %%_VAR_DIR%%/db/ports/%%PORTNAME%%/options, MTA setup.
Asking about updates or telling me there is one: not only I am active on the
-mailing lists but I also track dspam CSV so I already know; either there is a
-problem with the new version or I didn't have enough time to patch the port
+mailing lists and IRC but I also track dspam CVS so I already know; either there
+is a problem with the new version or I didn't have enough time to patch the port
and _test_ the new version; please report your succes/failure if you run the
new version or the cvs version.