aboutsummaryrefslogtreecommitdiff
path: root/mail/dspam
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-01-19 18:25:27 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2010-01-19 18:25:27 +0000
commit3913cf32113ccda03e1452de912899d7d1414c86 (patch)
treeafaa126518ef2a0934963036405e26efe37f019e /mail/dspam
parent82a86af19bc2aad1b4ef41d9e9136f148ca0756c (diff)
downloadports-3913cf32113ccda03e1452de912899d7d1414c86.tar.gz
ports-3913cf32113ccda03e1452de912899d7d1414c86.zip
Notes
Diffstat (limited to 'mail/dspam')
-rw-r--r--mail/dspam/Makefile142
-rw-r--r--mail/dspam/distinfo6
-rw-r--r--mail/dspam/files/UPDATING13
-rw-r--r--mail/dspam/files/patch-scripts__train.pl (renamed from mail/dspam/files/patch-scripts_train.pl)4
-rw-r--r--mail/dspam/files/patch-src__dspam.conf.in62
-rw-r--r--mail/dspam/pkg-message47
-rw-r--r--mail/dspam/pkg-plist211
7 files changed, 272 insertions, 213 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index 074bf5424196..cf8c83b6dded 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -11,29 +11,16 @@
# Thanks.
PORTNAME= dspam
-PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}
-PORTREVISION= 5
+PORTVERSION= 3.9.0
CATEGORIES= mail
-MASTER_SITES= # set later
+MASTER_SITES= SF \
+ http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
+MASTER_SITE_SUBDIR=${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Bayesian spam filter - stable maintenance version
-PORTVER_MAJ= 3.6.8
-#SNAP_DATE= .20060421.2101
-
-MIN_OPTIONS_VER= ${PORTNAME}-3.6.8_1
-
-.ifdef(SNAP_DATE)
-MASTER_SITES= http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
-WRKSRC= ${WRKDIR}/dspam-${SNAP_DATE}
-.else
-MASTER_SITES= http://dspam.irontec.com/sources/ \
- http://dspam.nuclearelephant.com/sources/ \
- http://dspam.systemadministrator.org/sources/ \
- http://dspam.sourceforge.net/sources/ \
- http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
-.endif
+MIN_OPTIONS_VER= ${PORTNAME}-3.9.0
## debug / log / admin options
OPTIONS= SYSLOG "Logs via syslog" on
@@ -56,12 +43,11 @@ OPTIONS+= MYSQL_COMPRESS "Compress dspam <--> MySQL" off
OPTIONS+= MYSQL_LOCAL "RUN_DEPEND on selected MySQL server ver." off
OPTIONS+= POSTGRESQL "Use PostgreSQL as back-end" on
OPTIONS+= POSTGRESQL_LOCAL "RUN_DEPEND on PostgreSQL server" off
-OPTIONS+= ORACLE "Use Oracle as back-end (BROKEN)" off
OPTIONS+= SQLITE2 "Use SQLite v2.x as back-end" off
OPTIONS+= SQLITE3 "Use SQLite v3.x as back-end" on
OPTIONS+= HASH "Use hash driver" on
#
-OPTIONS+= LDAP "Enable recipient verification via LDAP" off
+OPTIONS+= EXTERNAL_LOOKUP "Enable rcpt verification via extlookup" off
# layout
OPTIONS+= USER_HOMEDIR "Store user data in ~/.dspam" off
@@ -85,7 +71,7 @@ OPTIONS+= SENDMAIL "Play nice with sendmail server" off
OPTIONS+= POSTFIX_MBC "Dspam as mailbox_command in Postfix" off
OPTIONS+= QMAIL "Play nice with Qmail mail server" off
-OPTIONS+= CGI "Install CGI (pulls in Apache or see below)" off
+OPTIONS+= WebUI "Install WebUI (pulls in Apache / see below)" off
OPTIONS+= LIGHTTPD "RUN_DEPEND on LightHTTPD, not Apache" off
USE_PERL5= yes
@@ -200,8 +186,7 @@ SUB_LIST+= CLAMD=
# we need to know if we are building statically or dynamicaly for the plist
_DBDRV_COUNT= # blank, but defined so we can check against it
-#_DBDRV_ALL= pgsql_drv,ora_drv,sqlite3_drv,sqlite_drv,hash_drv,mysql_drv
-# above won't work because ORACLE support is broken so
+#_DBDRV_ALL= pgsql_drv,sqlite3_drv,sqlite_drv,hash_drv,mysql_drv
_DBDRV= pgsql_drv,sqlite3_drv,sqlite_drv,hash_drv,mysql_drv,
.ifndef(WITHOUT_POSTGRESQL)
@@ -222,16 +207,6 @@ PLIST_SUB+= PGSQL="@comment "
_DBDRV:= ${_DBDRV:S/pgsql_drv,//}
.endif
-.if defined(WITH_ORACLE)
-#BUILD_DEPENDS= ${LOCALBASE}/oracle7/rdbms/lib/libnlsrtl3.a:\
-# ${PORTSDIR}/databases/oracle7-client
-#CONFIGURE_ARGS+= --with-oracle-home= ${LOCALBASE}/oracle7
-#PKGNAMESUFFIX= -oracle
-#_DBDRV_COUNT:= ${_DBDRV_COUNT}o
-#.else
-#_DBDRV:= ${_DBDRV:S/ora_drv,//}
-.endif
-
.ifndef(WITHOUT_SQLITE3)
USE_SQLITE= 3
_DBDRV_COUNT:= ${_DBDRV_COUNT}o
@@ -307,8 +282,8 @@ PLIST_SUB+= DYNAMIC=""
PLIST_SUB+= DYNAMIC="@comment "
.endif
-.ifdef(WITH_LDAP)
-CONFIGURE_ARGS+= --enable-ldap
+.ifdef(WITH_EXTERNAL_LOOKUP)
+CONFIGURE_ARGS+= --enable-external-lookup
USE_OPENLDAP= YES
#CPPFLAGS+= -I${LOCALBASE}/include
#LDFLAGS+= -lldap -llber
@@ -414,7 +389,7 @@ DSPAM_MODE= 4511
CONFIGURE_ARGS+= --with-dspam-mode=${DSPAM_MODE}
.endif
-.ifdef(WITH_CGI)
+.ifdef(WITH_WebUI)
. if defined(WITH_LIGHTTPD)
RUN_DEPENDS+= ${LOCALBASE}/sbin/lighttpd:${PORTSDIR}/www/lighttpd
. else
@@ -428,15 +403,13 @@ RUN_DEPENDS+= ${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil
CONFIGURE_ARGS+=--enable-logging
CONFIGURE_ARGS+=--enable-user-logging
USE_PERL5= yes
-PLIST_SUB+= CGI=""
-CGI_PATH?= ${PREFIX}/www/vhosts/dspam
-_SED_SCRIPT+= -e 's/%%CGI%%//g'
-_SED_SCRIPT+= -e 's,%%CGI_PATH%%,${CGI_PATH},g'
-#SED_FILES= ${LS} ${WRKSRC}/cgi/*.pl
-#SED_FILES+= ${LS} $PWRKSRC}/cgi/*.cgi
+PLIST_SUB+= WebUI=""
+_SED_SCRIPT+= -e 's/%%WebUI%%//g'
+_SED_SCRIPT+= -e 's,%%WWWDIR%%,${WWWDIR},g'
+PLIST_SUB+= WWWDIR=${WWWDIR_REL}
.else
-PLIST_SUB+= CGI="@comment "
-_SED_SCRIPT+= -e '/%%CGI%%/D'
+PLIST_SUB+= WebUI="@comment "
+_SED_SCRIPT+= -e '/%%WebUI%%/D'
.endif
MAN1= dspam.1 dspam_clean.1 dspam_dump.1 dspam_merge.1 dspam_stats.1 \
@@ -452,9 +425,9 @@ MLINKS+= libdspam.3 dspam_destroy.3
MLINKS+= libdspam.3 dspam_detach.3
_DOCS= CHANGELOG LICENSE README README.FreeBSD RELEASE.NOTES UPGRADING
-_DOCSL= courier.txt exim.txt markov.txt mysql_drv.txt ora_drv.txt \
- pgsql_drv.txt pop3filter.txt postfix.txt qmail.txt relay.txt \
- sendmail.txt sqlite_drv.txt
+_DOCSL= courier.txt exim.txt markov.txt mysql_drv.txt pgsql_drv.txt \
+ pop3filter.txt postfix.txt qmail.txt relay.txt sendmail.txt \
+ sqlite_drv.txt
pre-everything::
.ifndef(MAINT)
@@ -475,7 +448,7 @@ pre-extract: check-options-version
@${ECHO_CMD} "DSPAM_OWNER=${DSPAM_OWNER} (default: root)"
@${ECHO_CMD} "DSPAM_GROUP=${DSPAM_GROUP} (default: mail)"
@${ECHO_CMD} "DSPAM_MODE=${DSPAM_MODE}"
- @${ECHO_CMD} "DSPAM_ETC=${DSPAM_ETC} (default: ${LOCALBASE}/etc"
+ @${ECHO_CMD} "DSPAM_ETC=${DSPAM_ETC} (default: ${PREFIX}/etc"
@${ECHO_CMD} "DSPAM_HOME=${DSPAM_HOME} (default: ${_VAR_DIR}/db/dspam)"
@${ECHO_CMD} "DSPAM_HOME_OWNER=${DSPAM_HOME_OWNER}"
@${ECHO_CMD} "DSPAM_HOME_GROUP=${DSPAM_HOME_GROUP}"
@@ -484,10 +457,10 @@ pre-extract: check-options-version
. ifdef(WITHOUT_SYSLOG)
@${ECHO_CMD} "LOGFILE=${LOGFILE} (default: ${_VAR_DIR}/log/dspam/dspam.log)"
. endif
-. ifdef(WITH_CGI)
- @${ECHO_CMD} "Define CGI_PATH before make-ing if you need the CGI files"
+. ifdef(WITH_WebUI)
+ @${ECHO_CMD} "Define WWWDIR before making if you need the WebUI files"
@${ECHO_CMD} "installed in other place that this installation's default"
- @${ECHO_CMD} "${PREFIX}/www/vhosts/dspam"
+ @${ECHO_CMD} "${WWWDIR}"
. endif
@${ECHO_CMD} ""
@sleep 5
@@ -500,8 +473,6 @@ post-patch:
${WRKSRC}/src/tools.mysql_drv/purge-4.1.sql
@${REINPLACE_CMD} -e 's|WHERE CURRENT_DATE - created_on > 14;|WHERE CURRENT_DATE - created_on > ${SIGNATURE_LIFE};|' \
${WRKSRC}/src/tools.pgsql_drv/purge.sql
- @${REINPLACE_CMD} -e 's|where SYSDATE-created_on > 14|where SYSDATE-created_on > ${SIGNATURE_LIFE};|' \
- ${WRKSRC}/src/tools.ora_drv/purge.sql
@${REINPLACE_CMD} -e "s|where date('now')-date(created_on) > 14;|where date('now')-date(created_on) > ${SIGNATURE_LIFE};|" \
${WRKSRC}/src/tools.sqlite_drv/purge-2.sql
@${REINPLACE_CMD} -e "s|where julianday('now')-julianday(created_on) > 14;|where julianday('now')-julianday(created_on) > ${SIGNATURE_LIFE};|" \
@@ -521,8 +492,8 @@ pre-configure:
@${FALSE}
.endif
.if defined(WITH_VIRT_USERS) && !(defined(USE_MYSQL) || \
- !defined(WITHOUT_POSTGRESQL) || defined(WITH_ORACLE) || !defined(WITHOUT_HASH) )
- @${ECHO_CMD} "You need MySQL, POSTGRESQL, HASH or ORACLE for virtual users."
+ !defined(WITHOUT_POSTGRESQL) || !defined(WITHOUT_HASH) )
+ @${ECHO_CMD} "You need MySQL, POSTGRESQL or HASH for virtual users."
@${FALSE}
.endif
.if defined(WITH_PREF_EXT) && !( defined(USE_MYSQL) || \
@@ -539,29 +510,23 @@ pre-configure:
@${ECHO_CMD} "You can compile with only one MySQL version driver."
@${FALSE}
.endif
-.if defined(WITH_LDAP) && !( defined(USE_MYSQL) || \
+.if defined(WITH_EXTERNAL_LOOKUP) && !( defined(USE_MYSQL) || \
!defined(WITHOUT_POSTGRESQL) || defined(USE_SQLITE) )
- @${ECHO_CMD} "You need MySQL, Postgres or SQLITE for LDAP."
+ @${ECHO_CMD} "You need MySQL, Postgres or SQLITE for EXTERNAL_LOOKUP."
@${FALSE}
.endif
-.if defined(WITH_USER_HOMEDIR) && defined(WITH_CGI)
- @${ECHO_CMD} "USER_HOMEDIR and CGI are incopatible"
+.if defined(WITH_USER_HOMEDIR) && defined(WITH_WebUI)
+ @${ECHO_CMD} "USER_HOMEDIR and WebUI are incopatible"
@${FALSE}
.endif
.if defined(WITH_DOMAIN_SCALE) && defined(WITH_LARGE_SCALE)
@${ECHO_CMD} "DOMAIN_SCALE and LARGE_SCALE are incopatible"
@${FALSE}
.endif
-.if defined(WITH_LIGHTHTTPD) && !defined(WITH_CGI)
- @${ECHO_CMD} "There's no reason to depend on LightHTTPD if you're not using CGI"
+.if defined(WITH_LIGHTHTTPD) && !defined(WITH_WebUI)
+ @${ECHO_CMD} "There's no reason to depend on LightHTTPD if you're not using WebUI"
@${FALSE}
.endif
-.ifdef(SNAP_DATE)
- @${ECHO_CMD}
- @${ECHO_CMD} "You can safely ignore the following auto* errors"
- @${ECHO_CMD}
- @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
-.endif
post-install:
${CP} ${WRKSRC}/src/dspam.conf ${WRKSRC}/src/dspam.conf.sample
@@ -576,6 +541,7 @@ post-install:
${TEST} `ls -1 ${PREFIX}/lib/pkgconfig | wc -l` -eq 0 && \
${RM} -R ${PREFIX}/lib/pkgconfig || true
+.ifndef NOPORTEXAMPLES
.ifdef(USE_MYSQL)
@${MKDIR} ${EXAMPLESDIR}/mysql
cd ${WRKSRC}/src/tools.mysql_drv && \
@@ -596,29 +562,35 @@ post-install:
cd ${WRKSRC}/src/tools.sqlite_drv && \
${INSTALL_DATA} *.sql ${EXAMPLESDIR}/sqlite
.endif
-.ifdef(WITH_ORACLE)
- @${MKDIR} ${EXAMPLESDIR}/oracle
- cd ${WRKSRC}/src/tools.ora_drv && \
- ${INSTALL_DATA} *.sql ${EXAMPLESDIR}/oracle
-.endif
+.endif # NOPORTEXAMPLES
-.ifdef(WITH_CGI)
-. for I in admin.cgi admingraph.cgi configure.pl dspam.cgi graph.cgi
- @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/webui/cgi-bin/${I}
+.ifdef(WITH_WebUI)
+. for I in admin.cgi admingraph.cgi configure.pl dspam.cgi graph.cgi templates/strings.pl
+ ${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/webui/cgi-bin/${I}
. endfor
- cd ${WRKSRC}/webui/cgi-bin && ${MV} configure.pl configure.pl.sample
- cd ${WRKSRC}/webui/cgi-bin && ${MKDIR} ${CGI_PATH} && \
- ${INSTALL_SCRIPT} configure.pl.sample ${CGI_PATH}/ && \
- ${INSTALL_SCRIPT} *.cgi ${CGI_PATH} && \
- ${INSTALL_DATA} rgb.txt ${CGI_PATH}/
+ ${MV} ${WRKSRC}/webui/cgi-bin/configure.pl ${WRKSRC}/webui/cgi-bin/configure.pl.sample
+ cd ${WRKSRC}/webui/cgi-bin && ${MKDIR} ${WWWDIR} && \
+ ${INSTALL_SCRIPT} configure.pl.sample ${WWWDIR}/ && \
+ ${INSTALL_SCRIPT} *.cgi ${WWWDIR} && \
+ ${INSTALL_DATA} rgb.txt ${WWWDIR}/
cd ${WRKSRC}/webui/htdocs && \
- ${INSTALL_DATA} base.css dspam-logo-small.gif ${CGI_PATH}/
+ ${INSTALL_DATA} base.css dspam-logo-small.gif ${WWWDIR}/
cd ${WRKSRC}/webui/cgi-bin && \
- ${INSTALL_DATA} default.prefs ${CGI_PATH}/default.prefs.sample
+ ${INSTALL_DATA} default.prefs ${WWWDIR}/default.prefs.sample
cd ${WRKSRC}/webui/cgi-bin && \
- ${INSTALL_DATA} admins ${CGI_PATH}/admins.sample
- ${MKDIR} ${CGI_PATH}/templates && cd ${WRKSRC}/webui/cgi-bin/templates && \
- ${INSTALL_DATA} *.html ${CGI_PATH}/templates/
+ ${INSTALL_DATA} admins ${WWWDIR}/admins.sample
+ ${MKDIR} ${WWWDIR}/templates && cd ${WRKSRC}/webui/cgi-bin/templates && \
+ ${INSTALL_DATA} *.html ${WWWDIR}/templates/ && \
+ ${INSTALL_SCRIPT} strings.pl ${WWWDIR}/templates/ &&
+ for _dir in de es-es fr he pt-br ro; do \
+ ${INSTALL_DATA} -d ${WWWDIR}/templates/$${_dir} && \
+ cd ${WRKSRC}/webui/cgi-bin/templates/$${_dir} && \
+ ${INSTALL_DATA} *.html ${WWWDIR}/templates/$${_dir}; \
+ done && \
+ for _dir in de es-es pt-br; do \
+ cd ${WRKSRC}/webui/cgi-bin/templates/$${_dir} && \
+ ${INSTALL_SCRIPT} strings.pl ${WWWDIR}/templates/$${_dir}/; \
+ done
.endif
@${SED} ${_SED_SCRIPT} ${.CURDIR}/pkg-message > ${WRKSRC}/README.FreeBSD
diff --git a/mail/dspam/distinfo b/mail/dspam/distinfo
index 857ae0671cec..545310f8e849 100644
--- a/mail/dspam/distinfo
+++ b/mail/dspam/distinfo
@@ -1,3 +1,3 @@
-MD5 (dspam-3.6.8.tar.gz) = c4b1a7079690ee16d8b0f36b2a2a90a4
-SHA256 (dspam-3.6.8.tar.gz) = 88c7b41fb81e90ba8a260885a1d14bce39f2ef4a06cc2c6b8bfa0b99ba1aec34
-SIZE (dspam-3.6.8.tar.gz) = 743275
+MD5 (dspam-3.9.0.tar.gz) = 10d092b57d628d8c91655fee5dc0d0cd
+SHA256 (dspam-3.9.0.tar.gz) = fb2b0d0e49d44e077e665041041035c3a882d858c03265dd0955664c0fa934ae
+SIZE (dspam-3.9.0.tar.gz) = 973232
diff --git a/mail/dspam/files/UPDATING b/mail/dspam/files/UPDATING
index de903f8f59cf..c5c167d07949 100644
--- a/mail/dspam/files/UPDATING
+++ b/mail/dspam/files/UPDATING
@@ -17,6 +17,19 @@ in the port directory:
make extract; more `find . -type f -maxdepth 2 -name UPGRADING`
###########################################################################
+# dspam-3.9.0
+#
+
+Port changes:
+- LDAP option --> EXTERNAL_LOOKUP (following upstream changes)
+- CGI option --> WebUI (following upstream changes)
+- CGI_PATH var --> WWWDIR (defaulting to PREFIX/www/dspam)
+
+Lots of changes, see UPGRADING file in the tarball. At very least you need
+to adjust your dspam.conf and your database.
+
+
+###########################################################################
# dspam-3.6.8_1
#
diff --git a/mail/dspam/files/patch-scripts_train.pl b/mail/dspam/files/patch-scripts__train.pl
index 3550e64474f5..bb582e46b90a 100644
--- a/mail/dspam/files/patch-scripts_train.pl
+++ b/mail/dspam/files/patch-scripts__train.pl
@@ -1,5 +1,5 @@
---- scripts/train.pl.dist Tue Nov 8 14:34:38 2005
-+++ scripts/train.pl Tue Nov 8 14:36:06 2005
+--- ./scripts/train.pl.orig 2010-01-11 23:21:58.000000000 +0200
++++ ./scripts/train.pl 2010-01-17 18:52:16.000000000 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!%%PERL%%
diff --git a/mail/dspam/files/patch-src__dspam.conf.in b/mail/dspam/files/patch-src__dspam.conf.in
index 63e907c50ea2..39d75699ee8b 100644
--- a/mail/dspam/files/patch-src__dspam.conf.in
+++ b/mail/dspam/files/patch-src__dspam.conf.in
@@ -1,56 +1,44 @@
---- ./src/dspam.conf.in.orig Tue Oct 10 01:22:52 2006
-+++ ./src/dspam.conf.in Tue Oct 10 01:39:10 2006
-@@ -52,7 +52,7 @@
- # the user DSPAM is processing mail for. This configuration parameter is only
+--- ./src/dspam.conf.in.orig 2010-01-11 23:21:58.000000000 +0200
++++ ./src/dspam.conf.in 2010-01-17 18:49:37.000000000 +0200
+@@ -56,6 +56,7 @@
# necessary if you plan on allowing untrusted processing.
#
--#UntrustedDeliveryAgent "/usr/bin/procmail -d %u"
-+#UntrustedDeliveryAgent "@delivery_agent@"
+ #UntrustedDeliveryAgent "/usr/bin/procmail -d %u"
++#QuarantineAgent "@delivery_agent@"
#
# SMTP or LMTP Delivery: Alternatively, you may wish to use SMTP or LMTP
-@@ -85,7 +85,7 @@
- # a quarantine agent which will be called with all messages DSPAM thinks is
- # spam. Use %u to specify the user DSPAM is processing mail for.
- #
--#QuarantineAgent "/usr/bin/procmail -d spam"
-+#QuarantineAgent "@delivery_agent@"
-
- #
- # DSPAM can optionally process "plused users" (addresses in the user+detail
-@@ -273,7 +273,7 @@
+@@ -330,7 +331,7 @@
# Storage driver settings: Specific to a particular storage driver. Uncomment
# the configuration specific to your installation, if applicable.
#
--#MySQLServer /var/lib/mysql/mysql.sock
-+#MySQLServer /tmp/mysql.sock
- #MySQLPort
- #MySQLUser dspam
- #MySQLPass changeme
-@@ -619,7 +619,10 @@
- # If the message is larger than the maximum size, it will be delivered
- # without processing. Value is in bytes.
- #
-+# WARNING: this applies to clamav scan also
-+#
- #MaxMessageSize 4194304
-+MaxMessageSize 307200
-
- #
- # Virus Checking: If you are running clamd, DSPAM can perform stream-based
-@@ -644,6 +647,7 @@
- #
+-#MySQLServer /var/lib/mysql/mysql.sock
++#MySQLServer /tmp/mysql.sock
+ #MySQLPort
+ #MySQLUser dspam
+ #MySQLPass changeme
+@@ -341,7 +342,7 @@
+ # If you are using replication for clustering, you can also specify a separate
+ # server to perform all writes to.
+ #
+-#MySQLWriteServer /var/lib/mysql/mysql.sock
++#MySQLWriteServer /tmp/mysql.sock
+ #MySQLWritePort
+ #MySQLWriteUser dspam
+ #MySQLWritePass changeme
+@@ -778,6 +779,7 @@
+ #ServerHost 127.0.0.1
#ServerPort 24
#ServerQueueSize 32
+# keep this is sync with /usr/local/etc/rc.d/dspam[.sh] rc.d script
- #ServerPID /var/run/dspam.pid
+ #ServerPID /var/run/dspam.pid
#
-@@ -680,14 +684,15 @@
+@@ -814,14 +816,15 @@
# you are running the client and server on the same machine, as it eliminates
# much of the bandwidth overhead.
#
--#ServerDomainSocketPath "/tmp/dspam.sock"
+-#ServerDomainSocketPath "/tmp/dspam.sock"
+# keep this is sync with /usr/local/etc/rc.d/dspam[.sh] rc.d script
+#ServerDomainSocketPath "/var/run/dspam.sock"
diff --git a/mail/dspam/pkg-message b/mail/dspam/pkg-message
index fbcfa1c5ab5d..6c5e1446bd92 100644
--- a/mail/dspam/pkg-message
+++ b/mail/dspam/pkg-message
@@ -7,32 +7,29 @@
Please be sure to include in your email/pr relevant information such as:
uname -a, dspam --version, %%_VAR_DIR%%/db/ports/%%PORTNAME%%/options, MTA setup.
-Asking about updates or telling me there is one: not only I am active on the
-mailing lists and IRC but I also track dspam CVS so I already know; either there
-is a problem with the new version or I didn't have enough time to patch the port
-and _test_ the new version; please report your success/failure if you run the
-new version or the cvs version.
+Asking about updates or telling me there is one: there's no need, I am one of
+the developers.
-%%CGI%% The CGI files had been installed in
-%%CGI%% %%CGI_PATH%%
-%%CGI%% Copy
-%%CGI%% %%CGI_PATH%%/default.prefs.sample
-%%CGI%% to
-%%CGI%% %%CGI_PATH%%/default.prefs
-%%CGI%% and edit it to your needs.
-%%CGI%% Copy
-%%CGI%% %%CGI_PATH%%/configure.pl.sample
-%%CGI%% to
-%%CGI%% %%CGI_PATH%%/configure.pl
-%%CGI%% and edit it to your needs.
-%%CGI%% If you symlink this file in %%DSPAM_HOME%%/
-%%CGI%% an administrator can edit these options in the DSPAM Admin Suite.
-%%CGI%% Define administrators by copying
-%%CGI%% %%CGI_PATH%%/admins.sample
-%%CGI%% to
-%%CGI%% %%CGI_PATH%%/admins
-%%CGI%% and edit the file to your needs.
-%%CGI%% If you have problems (after upgrading) check permissions.
+%%WebUI%% The CGI files had been installed in
+%%WebUI%% %%WWWDIR%%
+%%WebUI%% Copy
+%%WebUI%% %%WWWDIR%%/default.prefs.sample
+%%WebUI%% to
+%%WebUI%% %%WWWDIR%%/default.prefs
+%%WebUI%% and edit it to your needs.
+%%WebUI%% Copy
+%%WebUI%% %%WWWDIR%%/configure.pl.sample
+%%WebUI%% to
+%%WebUI%% %%WWWDIR%%/configure.pl
+%%WebUI%% and edit it to your needs.
+%%WebUI%% If you symlink this file in %%DSPAM_HOME%%/
+%%WebUI%% an administrator can edit these options in the DSPAM Admin Suite.
+%%WebUI%% Define administrators by copying
+%%WebUI%% %%WWWDIR%%/admins.sample
+%%WebUI%% to
+%%WebUI%% %%WWWDIR%%/admins
+%%WebUI%% and edit the file to your needs.
+%%WebUI%% If you have problems (after upgrading) check permissions.
%%DAEMON%%
%%DAEMON%% To enable the dspam deamon put dspam_enable="YES" in your
%%DAEMON%% /etc/rc.conf
diff --git a/mail/dspam/pkg-plist b/mail/dspam/pkg-plist
index 8783ba9e9686..e11af75d980c 100644
--- a/mail/dspam/pkg-plist
+++ b/mail/dspam/pkg-plist
@@ -22,33 +22,36 @@ include/dspam/config_shared.h
include/dspam/decode.h
include/dspam/diction.h
include/dspam/error.h
+include/dspam/external_lookup.h
include/dspam/heap.h
-include/dspam/ldap_client.h
include/dspam/libdspam.h
include/dspam/libdspam_objects.h
include/dspam/nodetree.h
+include/dspam/pref.h
+include/dspam/read_config.h
include/dspam/storage_driver.h
include/dspam/tokenizer.h
lib/libdspam.a
lib/libdspam.la
lib/libdspam.so
lib/libdspam.so.7
-%%DYNAMIC%%%%HASH%%lib/libhash_drv.a
-%%DYNAMIC%%%%HASH%%lib/libhash_drv.la
-%%DYNAMIC%%%%HASH%%lib/libhash_drv.so
-%%DYNAMIC%%%%HASH%%lib/libhash_drv.so.7
-%%DYNAMIC%%%%MYSQL%%lib/libmysql_drv.a
-%%DYNAMIC%%%%MYSQL%%lib/libmysql_drv.la
-%%DYNAMIC%%%%MYSQL%%lib/libmysql_drv.so
-%%DYNAMIC%%%%MYSQL%%lib/libmysql_drv.so.7
-%%DYNAMIC%%%%PGSQL%%lib/libpgsql_drv.a
-%%DYNAMIC%%%%PGSQL%%lib/libpgsql_drv.la
-%%DYNAMIC%%%%PGSQL%%lib/libpgsql_drv.so
-%%DYNAMIC%%%%PGSQL%%lib/libpgsql_drv.so.7
-%%DYNAMIC%%%%SQLITE%%lib/libsqlite3_drv.a
-%%DYNAMIC%%%%SQLITE%%lib/libsqlite3_drv.la
-%%DYNAMIC%%%%SQLITE%%lib/libsqlite3_drv.so
-%%DYNAMIC%%%%SQLITE%%lib/libsqlite3_drv.so.7
+%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.a
+%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.la
+%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.so
+%%DYNAMIC%%%%HASH%%lib/dspam/libhash_drv.so.7
+%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.a
+%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.la
+%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.so
+%%DYNAMIC%%%%MYSQL%%lib/dspam/libmysql_drv.so.7
+%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.a
+%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.la
+%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.so
+%%DYNAMIC%%%%PGSQL%%lib/dspam/libpgsql_drv.so.7
+%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.a
+%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.la
+%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.so
+%%DYNAMIC%%%%SQLITE%%lib/dspam/libsqlite3_drv.so.7
+@dirrm lib/dspam
libdata/pkgconfig/dspam.pc
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
@@ -59,7 +62,6 @@ libdata/pkgconfig/dspam.pc
%%PORTDOCS%%%%DOCSDIR%%/exim.txt
%%PORTDOCS%%%%DOCSDIR%%/markov.txt
%%PORTDOCS%%%%DOCSDIR%%/mysql_drv.txt
-%%PORTDOCS%%%%DOCSDIR%%/ora_drv.txt
%%PORTDOCS%%%%DOCSDIR%%/pgsql_drv.txt
%%PORTDOCS%%%%DOCSDIR%%/pop3filter.txt
%%PORTDOCS%%%%DOCSDIR%%/postfix.txt
@@ -70,49 +72,136 @@ libdata/pkgconfig/dspam.pc
%%PORTDOCS%%%%DOCSDIR%%/UPDATING
%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-4.1.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-space.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/mysql_objects-speed.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/purge-4.1.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/purge.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/virtual_user_aliases.sql
-%%MYSQL%%%%EXAMPLESDIR%%/mysql/virtual_users.sql
-%%MYSQL%%@dirrm %%EXAMPLESDIR%%/mysql
-%%PGSQL%%%%EXAMPLESDIR%%/pgsql/pgsql_objects.sql
-%%PGSQL%%%%EXAMPLESDIR%%/pgsql/purge.sql
-%%PGSQL%%%%EXAMPLESDIR%%/pgsql/virtual_users.sql
-%%PGSQL%%@dirrm %%EXAMPLESDIR%%/pgsql
-%%SQLITE%%%%EXAMPLESDIR%%/sqlite/purge-2.sql
-%%SQLITE%%%%EXAMPLESDIR%%/sqlite/purge-3.sql
-%%SQLITE%%@dirrm %%EXAMPLESDIR%%/sqlite
-@dirrmtry %%EXAMPLESDIR%%
-%%CGI%%www/vhosts/dspam/admins.sample
-%%CGI%%www/vhosts/dspam/admin.cgi
-%%CGI%%www/vhosts/dspam/admingraph.cgi
-%%CGI%%www/vhosts/dspam/base.css
-%%CGI%%www/vhosts/dspam/configure.pl.sample
-%%CGI%%www/vhosts/dspam/default.prefs.sample
-%%CGI%%www/vhosts/dspam/dspam.cgi
-%%CGI%%www/vhosts/dspam/graph.cgi
-%%CGI%%www/vhosts/dspam/dspam-logo-small.gif
-%%CGI%%www/vhosts/dspam/rgb.txt
-%%CGI%%www/vhosts/dspam/templates/nav_admin_error.html
-%%CGI%%www/vhosts/dspam/templates/nav_admin_preferences.html
-%%CGI%%www/vhosts/dspam/templates/nav_admin_status.html
-%%CGI%%www/vhosts/dspam/templates/nav_admin_user.html
-%%CGI%%www/vhosts/dspam/templates/nav_alerts.html
-%%CGI%%www/vhosts/dspam/templates/nav_analysis.html
-%%CGI%%www/vhosts/dspam/templates/nav_error.html
-%%CGI%%www/vhosts/dspam/templates/nav_fragment.html
-%%CGI%%www/vhosts/dspam/templates/nav_history.html
-%%CGI%%www/vhosts/dspam/templates/nav_performance.html
-%%CGI%%www/vhosts/dspam/templates/nav_preferences.html
-%%CGI%%www/vhosts/dspam/templates/nav_quarantine.html
-%%CGI%%www/vhosts/dspam/templates/nav_viewmessage.html
-%%CGI%%@dirrm www/vhosts/dspam/templates
-%%CGI%%@dirrm www/vhosts/dspam
-%%CGI%%@dirrm www/vhosts
-%%CGI%%@dirrmtry www
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/mysql_objects-4.1.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/mysql_objects-space.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/mysql_objects-speed.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/purge-4.1.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/purge.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/virtual_user_aliases.sql
+%%MYSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mysql/virtual_users.sql
+%%MYSQL%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/mysql
+%%PGSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/pgsql_objects.sql
+%%PGSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/purge.sql
+%%PGSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/purge-pe.sql
+%%PGSQL%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pgsql/virtual_users.sql
+%%PGSQL%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/pgsql
+%%SQLITE%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sqlite/purge-2.sql
+%%SQLITE%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sqlite/purge-3.sql
+%%SQLITE%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sqlite
+@dirrmtry %%PORTEXAMPLES%%%%EXAMPLESDIR%%
+%%WebUI%%%%WWWDIR%%/admins.sample
+%%WebUI%%%%WWWDIR%%/admin.cgi
+%%WebUI%%%%WWWDIR%%/admingraph.cgi
+%%WebUI%%%%WWWDIR%%/base.css
+%%WebUI%%%%WWWDIR%%/configure.pl.sample
+%%WebUI%%%%WWWDIR%%/default.prefs.sample
+%%WebUI%%%%WWWDIR%%/dspam.cgi
+%%WebUI%%%%WWWDIR%%/graph.cgi
+%%WebUI%%%%WWWDIR%%/dspam-logo-small.gif
+%%WebUI%%%%WWWDIR%%/rgb.txt
+%%WebUI%%%%WWWDIR%%/templates/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/strings.pl
+%%WebUI%%%%WWWDIR%%/templates/de/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/de/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/de/strings.pl
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/es-es/strings.pl
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/fr/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/he/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/nav_viewmessage.html
+%%WebUI%%%%WWWDIR%%/templates/pt-br/strings.pl
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_admin_error.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_admin_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_admin_status.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_admin_user.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_alerts.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_analysis.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_error.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_fragment.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_history.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_performance.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_preferences.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_quarantine.html
+%%WebUI%%%%WWWDIR%%/templates/ro/nav_viewmessage.html
+%%WebUI%%@dirrm %%WWWDIR%%/templates/de
+%%WebUI%%@dirrm %%WWWDIR%%/templates/es-es
+%%WebUI%%@dirrm %%WWWDIR%%/templates/fr
+%%WebUI%%@dirrm %%WWWDIR%%/templates/he
+%%WebUI%%@dirrm %%WWWDIR%%/templates/pt-br
+%%WebUI%%@dirrm %%WWWDIR%%/templates/ro
+%%WebUI%%@dirrm %%WWWDIR%%/templates
+%%WebUI%%@dirrm %%WWWDIR%%
@dirrm include/dspam
@cwd %%DSPAM_HOME%%
firstrun.txt.sample