aboutsummaryrefslogtreecommitdiff
path: root/mail/ecartis
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 20:06:21 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 20:06:21 +0000
commit599fe3313c538b0b280563e51ea6734de042ee5e (patch)
tree67b9e686d9e78bd1a9756401c22712a53c9077d2 /mail/ecartis
parent58b19967499d586b4c610ba956f7a5364040f4c2 (diff)
downloadports-599fe3313c538b0b280563e51ea6734de042ee5e.tar.gz
ports-599fe3313c538b0b280563e51ea6734de042ee5e.zip
Notes
Diffstat (limited to 'mail/ecartis')
-rw-r--r--mail/ecartis/Makefile37
-rw-r--r--mail/ecartis/files/patch-Makefile (renamed from mail/ecartis/files/patch-aa)31
-rw-r--r--mail/ecartis/files/pkg-message.in7
-rw-r--r--mail/ecartis/pkg-descr6
-rw-r--r--mail/ecartis/pkg-install63
-rw-r--r--mail/ecartis/pkg-plist8
6 files changed, 36 insertions, 116 deletions
diff --git a/mail/ecartis/Makefile b/mail/ecartis/Makefile
index 4dfcad924280..1e66be12914b 100644
--- a/mail/ecartis/Makefile
+++ b/mail/ecartis/Makefile
@@ -3,43 +3,34 @@
PORTNAME= ecartis
PORTVERSION= 1.0.0.s20060813
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail
-MASTER_SITES= http://conducive.net/tarballs/ \
+MASTER_SITES= ftp://ftp.ecartis.net/pub/ecartis/ \
http://rodrigo.osorio.free.fr/freebsd/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.s/-snap/}
MAINTAINER= jtrigg@spamcop.net
-COMMENT= The Ecartis Listserver \ Mailing List Manager
+COMMENT= The Ecartis Listserver / Mailing List Manager
USES= gmake
-NO_PACKAGE= Requires ecartis uid
-IS_INTERACTIVE= "Stops to ask to create ecartis user/group"
+USERS= ecartis
+GROUPS= ecartis
+
WRKSRC= ${WRKDIR}/ecartis-1.0.0/src
+IDEST= ${STAGEDIR}${PREFIX}/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST_SUB+= EC_USER=${USERS} EC_GROUP=${GROUPS}
-NO_STAGE= yes
pre-patch:
@${CP} ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
pre-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
- @${MKDIR} ${PREFIX}/${PORTNAME}
- @${CP} -R ${WRKDIR}/${PORTNAME}-1.0.0/* ${PREFIX}/ecartis
- @${RM} -R ${PREFIX}/${PORTNAME}/src/
- @${RM} -R ${PREFIX}/${PORTNAME}/debian/
- @${RM} ${PREFIX}/${PORTNAME}/ecartis.dsp ${PREFIX}/${PORTNAME}/ecartis.dsw
- @${CHOWN} -R ecartis:ecartis ${PREFIX}/${PORTNAME}/*
-
-post-install:
- @${ECHO_MSG} "---------------------------------------------------"
- @${ECHO_MSG} "- Thank You for installing the Ecartis Listserver -"
- @${ECHO_MSG} "- package. Please read the documentation located -"
- @${ECHO_MSG} "- in ${PREFIX}/ecartis/, or online at: -"
- @${ECHO_MSG} "- -"
- @${ECHO_MSG} "- http://www.ecartis.org/ -"
- @${ECHO_MSG} "- -"
- @${ECHO_MSG} "- -The Ecartis Developers -"
- @${ECHO_MSG} "---------------------------------------------------"
+ ${MKDIR} ${IDEST}
+ cd ${WRKDIR}/${PORTNAME}-1.0.0 && ${FIND} * -print | \
+ ${CPIO} -pdu --quiet ${IDEST}
+ ${RM} -rf ${IDEST}/src/ ${IDEST}/debian ${IDEST}/ecartis.ds[pw]
.include <bsd.port.mk>
diff --git a/mail/ecartis/files/patch-aa b/mail/ecartis/files/patch-Makefile
index e986673cdd6d..2b69c1456a48 100644
--- a/mail/ecartis/files/patch-aa
+++ b/mail/ecartis/files/patch-Makefile
@@ -1,17 +1,17 @@
---- Makefile.dist Sat Apr 27 02:26:56 2002
-+++ Makefile Sat Apr 27 09:35:52 2002
+--- Makefile.dist 2006-08-13 03:50:15.000000000 -0500
++++ Makefile 2014-05-19 20:04:56.636909101 -0500
@@ -6,8 +6,8 @@
# they should be set. All of them are conditional on options set in this
# file, so it should be relatively easy to determine which branch is correct
-BINDIR = ..
-MODDIR = ../modules
-+BINDIR = ${PREFIX}/ecartis
-+MODDIR = ${PREFIX}/ecartis/modules
++BINDIR = ${DESTDIR}${PREFIX}/ecartis
++MODDIR = ${BINDIR}/modules
# First things first we need to set up some various options since OS's aren't
# as nice about things are they could be.
-@@ -38,7 +38,7 @@
+@@ -33,7 +33,7 @@
# Uncomment this if you are on a BSD system AND you want dynamic modules
# SunOS (4 and 5 both) also needs this setting.
#
@@ -20,16 +20,7 @@
# Uncomment this if you are compiling on OpenBSD with modules (BSDMOD = 1)
#OBSDMOD = 1
-@@ -60,7 +60,7 @@
- # Uncomment this if you have the GNU strftime() function. This version
- # of the function understands %z to return the numerical offset. It's better
- # to use that if it's available for RFC822 date headers
--GNU_STRFTIME=-DGNU_STRFTIME
-+#GNU_STRFTIME=-DGNU_STRFTIME
-
- # Uncomment this if you are on a machine that doesn't have strerror()
- #
-@@ -125,7 +125,6 @@
+@@ -120,7 +120,6 @@
ifdef BSDIMOD
CC=shlicc
else
@@ -37,7 +28,7 @@
endif
# Warning-level flags. Under SunOS (4 and 5), this NEEDS TO BE BLANK.
-@@ -134,9 +133,7 @@
+@@ -129,9 +128,7 @@
#
# It appears that IRIX is also rather stupid, and may require this
# to be removed.
@@ -48,11 +39,3 @@
# Now set up the initial command line. SUNOS_5 makes this a bit wierd.
ifndef SUNOS_5
-@@ -327,6 +324,7 @@
- install: targets
- cp build/ecartis ${BINDIR}
- chmod ug+s ${BINDIR}/ecartis
-+ chown -R ecartis:ecartis ${BINDIR}
- ifdef DYNMOD
- @for dir in ${MODULES}; do \
- cp build/$${dir}.lpm ${MODDIR}/$${dir}.lpm; \
diff --git a/mail/ecartis/files/pkg-message.in b/mail/ecartis/files/pkg-message.in
new file mode 100644
index 000000000000..ef5ea57e9f38
--- /dev/null
+++ b/mail/ecartis/files/pkg-message.in
@@ -0,0 +1,7 @@
+Thank You for installing the Ecartis Listserver package. Please
+read the documentation located in %%PREFIX%%/ecartis/
+or online at:
+
+http://www.ecartis.net/
+
+-- The Ecartis Developers
diff --git a/mail/ecartis/pkg-descr b/mail/ecartis/pkg-descr
index 3c01d97bd2f2..914aff148126 100644
--- a/mail/ecartis/pkg-descr
+++ b/mail/ecartis/pkg-descr
@@ -1,4 +1,4 @@
-Ecartis is a open-source (GNU Licence) software package that adminsters
+Ecartis is a open-source (GNU Licence) software package that adminsters
mailing lists (similar to Majordomo and Listserv). Some of Ecartis's
features include:
@@ -9,5 +9,5 @@ features include:
- Ability to be run in a multi-Virtual Host configuration.
Take a look at the Ecartis website to get a full feature list:
-
-WWW: http://www.ecartis.org/
+
+WWW: http://www.ecartis.net
diff --git a/mail/ecartis/pkg-install b/mail/ecartis/pkg-install
deleted file mode 100644
index 944afd6123c4..000000000000
--- a/mail/ecartis/pkg-install
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/bin/sh
-
-user=ecartis
-group=ecartis
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-if [ x"$2" = xPRE-INSTALL ]; then
- if pw groupshow "${group}" 2>/dev/null; then
- echo "You already have a group \"${group}\", so I will use it."
- else
- echo "You need a group \"${group}\"."
- if yesno "Would you like me to create it" y; then
- pw groupadd ${group} -h - || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if pw user show "${user}" 2>/dev/null; then
- echo "You already have a user \"${user}\", so I will use it."
- else
- echo "You need a user \"${user}\"."
- if yesno "Would you like me to create it" y; then
- pw useradd ${user} -g ${group} -h - -d /nonexistent \
- -s /nonexistent -c "Ecartis Listserver" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
-fi
diff --git a/mail/ecartis/pkg-plist b/mail/ecartis/pkg-plist
index 1844c642e6ef..f5769d7daf4c 100644
--- a/mail/ecartis/pkg-plist
+++ b/mail/ecartis/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%EC_USER%%
+@group %%EC_GROUP%%
ecartis/ecartis
ecartis/banned
ecartis/documentation/Makefile
@@ -65,10 +67,10 @@ ecartis/ecartis.cfg.dist
ecartis/ecartis.aliases.dist
@dirrm ecartis/lists/test/text
@dirrm ecartis/lists/test
-@dirrm ecartis/lists
+@dirrmtry ecartis/lists
@dirrm ecartis/templates
@dirrm ecartis/scripts
-@dirrm ecartis/queue
+@dirrmtry ecartis/queue
@dirrm ecartis/modules
@dirrm ecartis/documentation
-@dirrm ecartis
+@dirrmtry ecartis