aboutsummaryrefslogtreecommitdiff
path: root/mail/elm+ME
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-11-01 23:07:24 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-11-01 23:07:24 +0000
commitbc8ce6dec58dfea9326e30f5e75e65d42c7718af (patch)
tree22e98ee9ed27386a9f39bbd47651b29bb2d54a01 /mail/elm+ME
parentddd4f07f6e19544b883adf0c985086215835a0fa (diff)
downloadports-bc8ce6dec58dfea9326e30f5e75e65d42c7718af.tar.gz
ports-bc8ce6dec58dfea9326e30f5e75e65d42c7718af.zip
Notes
Diffstat (limited to 'mail/elm+ME')
-rw-r--r--mail/elm+ME/Makefile50
-rw-r--r--mail/elm+ME/distinfo6
-rw-r--r--mail/elm+ME/files/patch-shared_libs-iconv-config113
-rw-r--r--mail/elm+ME/files/patch-shared_libs-iconv-elmiconv.h11
-rw-r--r--mail/elm+ME/pkg-plist7
-rw-r--r--mail/elm+ME/scripts/pre-configure13
6 files changed, 173 insertions, 27 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index 66a1c1014245..1ad33ca930e1 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -6,13 +6,9 @@
#
PORTNAME= elm+ME
-PORTVERSION= 2.4.94.0c
+PORTVERSION= 2.4.95${PATCHLEVEL}
CATEGORIES= mail
-.if ${PORTVERSION:M*[a-z]} == ""
-DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R}ME+${PORTVERSION:E}
-.else
-DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R:R}ME+${PORTVERSION:R:E}
-.endif
+DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R}ME+${PORTVERSION:E:S|${PATCHLEVEL}||}
# here are the main repositories.
MASTER_SITES= ftp://ftp.ozone.fmi.fi/KEH/ \
@@ -25,18 +21,17 @@ MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/ \
ftp://ftp.eos.hokudai.ac.jp/pub/network/mail/elm-2.4ME+/ \
ftp://ftp.win.ne.jp/pub/network/mail/elm-2.4ME+/
# the following repositories maybe conform to the main repository.
-MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
- ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
- ftp://ftp.uni-trier.de/pub/unix/network/mail/elm-me+/
+# MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
+# ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
+# ftp://ftp.uni-trier.de/pub/unix/network/mail/elm-me+/
PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ${DISTNAME:S/+/+PL/}a.patch.gz \
- ${DISTNAME:S/+/+PL/}b.patch.gz \
- ${DISTNAME:S/+/+PL/}c.patch.gz
+PATCHFILES= ${DISTNAME:S/+/+PL/}a.patch.gz
+PATCHLEVEL= a
PATCH_DIST_STRIP= -p1
MAINTAINER= clefevre@citeweb.net
-LIB_DEPENDS= iconv.2:${PORTSDIR}/converters/iconv
+LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
# not needed since config.sh is generated by scripts/pre-configure.
# BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
@@ -66,8 +61,9 @@ PLIST_SUB= SO_REV="${SO_REV}" DOC_SUBDIR="${DOC_SUBDIR}" \
LIB_SUBDIR="${LIB_SUBDIR}" SHLIB_SUBDIR="${SHLIB_SUBDIR}"
MAN1= answer.1 checkalias.1 elm.1 elmalias.1 elmcharset.1 \
- elmterminal.1 elmunidata.1 fastmail.1 frm.1 listalias.1 \
- messages.1 newalias.1 newmail.1 printmail.1 readmsg.1
+ elmrc-write.1 elmterminal.1 elmunidata.1 fastmail.1 frm.1 \
+ listalias.1 messages.1 newalias.1 newmail.1 printmail.1 \
+ readmsg.1
MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
# Local variables
@@ -115,7 +111,7 @@ patch-nls-files:
#
post-install: install-startup-files install-nls-files \
- install-doc-files install-mime-types \
+ install-doc-files install-mime-types install-global-rc-file \
remove-catman-files remove-catman-links
install-startup-files:
@@ -136,10 +132,24 @@ install-doc-files:
install-mime-types:
@${INSTALL_DATA} ${FILESDIR}/${MIME_TYPES} \
${PREFIX}/${LIB_SUBDIR}/${MIME_TYPES}-dist
- @if [ ! -f ${PREFIX}/${LIB_SUBDIR}/${MIME_TYPES} ]; then \
- ${INSTALL_DATA} ${FILESDIR}/${MIME_TYPES} \
- ${PREFIX}/${LIB_SUBDIR}; \
- fi
+.if !exists(${PREFIX}/${LIB_SUBDIR}/${MIME_TYPES})
+ @${INSTALL_DATA} ${FILESDIR}/${MIME_TYPES} \
+ ${PREFIX}/${LIB_SUBDIR}
+.endif
+
+# at installation time, elm already has merged changes to the global
+# rc file. so, the only way to generate a -dist rc file is to
+# backup the original rc file, then to generate the -dist rc file
+# and to restore the backuped rc file. this allow us, at deinstallation
+# time, to not delete an existing customized rc file.
+install-global-rc-file:
+ @${MV} ${PREFIX}/${LIB_SUBDIR}/elm.rc \
+ ${PREFIX}/${LIB_SUBDIR}/elm.rc.orig
+ @${PREFIX}/${LIB_SUBDIR}/elmrc-write -G -I
+ @${MV} ${PREFIX}/${LIB_SUBDIR}/elm.rc \
+ ${PREFIX}/${LIB_SUBDIR}/elm.rc-dist
+ @${MV} ${PREFIX}/${LIB_SUBDIR}/elm.rc.orig \
+ ${PREFIX}/${LIB_SUBDIR}/elm.rc
remove-catman-files:
.for sect in ${MSECS}
diff --git a/mail/elm+ME/distinfo b/mail/elm+ME/distinfo
index 6ba5d07b403b..5332d9a86857 100644
--- a/mail/elm+ME/distinfo
+++ b/mail/elm+ME/distinfo
@@ -1,4 +1,2 @@
-MD5 (elm-2.4ME+94.tar.gz) = 51e17fea6a2bd8fa49633d07f4047b12
-MD5 (elm-2.4ME+PL94a.patch.gz) = 2f9dafa7e0bfaa8b56566bc876f556ec
-MD5 (elm-2.4ME+PL94b.patch.gz) = 6db19ead83eafc7f6449fbbb9e20ee4c
-MD5 (elm-2.4ME+PL94c.patch.gz) = ca1a71e15b3fcbfc1c782407b8232751
+MD5 (elm-2.4ME+95.tar.gz) = ecb07943ff5e74a71ee39bb2ceb63187
+MD5 (elm-2.4ME+PL95a.patch.gz) = bd686b1cecc3412560d5080b68a9c306
diff --git a/mail/elm+ME/files/patch-shared_libs-iconv-config b/mail/elm+ME/files/patch-shared_libs-iconv-config
new file mode 100644
index 000000000000..b27517759a97
--- /dev/null
+++ b/mail/elm+ME/files/patch-shared_libs-iconv-config
@@ -0,0 +1,113 @@
+--- shared_libs/iconv/config.orig Sun Oct 7 17:13:24 2001
++++ shared_libs/iconv/config Thu Nov 1 00:23:10 2001
+@@ -22,23 +22,23 @@
+ iconv_dir=system
+ ;;
+ systemlib)
+- if $test -r /usr/include/iconv.h
++ if $test -r /usr/include/giconv.h
+ then
+- echo "Found <iconv.h> from system headers"
++ echo "Found <giconv.h> from system headers"
+ iconv_dir=systemlib
+ fi
+ ;;
+ *)
+- if $test -r $a/include/iconv.h -a \
+- "`$ls $a/$libdirname/libiconv.* 2>/dev/null`" != ""
++ if $test -r $a/include/giconv.h -a \
++ "`$ls $a/$libdirname/libgiconv.* 2>/dev/null`" != ""
+ then
+ iconv_dir="$a"
+- echo "Found GNU libiconv from $iconv_dir"
+- elif $test -r $a/include/iconv.h -a \
+- "`$ls $a/lib/libiconv.* 2>/dev/null`" != ""
++ echo "Found GNU libgiconv from $iconv_dir"
++ elif $test -r $a/include/giconv.h -a \
++ "`$ls $a/lib/libgiconv.* 2>/dev/null`" != ""
+ then
+ iconv_dir="$a"
+- echo "Found GNU libiconv from $iconv_dir"
++ echo "Found GNU libgiconv from $iconv_dir"
+ fi
+ ;;
+ esac
+@@ -48,23 +48,23 @@
+
+ cat <<EOM
+
+-Elm ME+ can use GNU libiconv for character set conversions.
++Elm ME+ can use GNU libgiconv for character set conversions.
+ Support is implemented as shared library libelmme-iconv.so.
+
+ Give directory under which there are library and include files of OpenSSL.
+
+ Give "none" to disabled generation of shared library.
+-Give "system" to indicate that GNU libiconv include and library files
++Give "system" to indicate that GNU libgiconv include and library files
+ are search path of compiler.
+
+-Give "systemlib" to indicate that <iconv.h> and iconv routines are
++Give "systemlib" to indicate that <giconv.h> and iconv routines are
+ on system native library instead. That works on IRIX 6.5. It works also
+ Linux with (some) glibc 2.x.
+
+ EOM
+ dflt="$iconv_dir"
+
+- rp="GNU libiconv directory prefix? [$dflt]"
++ rp="GNU libgiconv directory prefix? [$dflt]"
+ echo $n "$rp $c"
+ . myread
+
+@@ -79,8 +79,8 @@
+ iconv_lib_dir=''
+ iconv_dir=system
+ iconv_ok="$define"
+- iconv_link=iconv
+- echo "GNU libiconv is assumed to found from system locations"
++ iconv_link=giconv
++ echo "GNU libgiconv is assumed to found from system locations"
+ ;;
+ systemlib)
+ iconv_include_dir=''
+@@ -93,23 +93,23 @@
+ *)
+ iconv_dir="$ans"
+ iconv_include_dir="$iconv_dir/include"
+- X="`$ls $iconv_dir/$libdirname/libiconv.* 2>/dev/null`"
++ X="`$ls $iconv_dir/$libdirname/libgiconv.* 2>/dev/null`"
+ if $test "$X" != ""
+ then
+ iconv_lib_dir="$iconv_dir/$libdirname"
+ else
+ iconv_lib_dir="$iconv_dir/lib"
+ fi
+- iconv_link=iconv
++ iconv_link=giconv
+ iconv_ok="$define"
+- echo "GNU libiconv is assumed to found from $iconv_dir directory"
++ echo "GNU libgiconv is assumed to found from $iconv_dir directory"
+ ;;
+ esac
+
+ if $test "$iconv_ok" = "$define"; then
+ $cat >try.c <<'EOF'
+ #include "stdio.h"
+-#include <iconv.h>
++#include <giconv.h>
+
+ int main(argc,argv)
+ int argc;
+@@ -164,9 +164,9 @@
+ '')
+ cat <<EOF
+
+-GNU libiconv location $iconv_dir seems not work. Select one of following
++GNU libgiconv location $iconv_dir seems not work. Select one of following
+ d) Disable iconv support
+- c) Change GNU libiconv directory prefix
++ c) Change GNU libgiconv directory prefix
+
+ EOF
+ dflt=d
diff --git a/mail/elm+ME/files/patch-shared_libs-iconv-elmiconv.h b/mail/elm+ME/files/patch-shared_libs-iconv-elmiconv.h
new file mode 100644
index 000000000000..fc8aaa92df7b
--- /dev/null
+++ b/mail/elm+ME/files/patch-shared_libs-iconv-elmiconv.h
@@ -0,0 +1,11 @@
+--- shared_libs/iconv/elmiconv.h.orig Wed Oct 31 09:23:34 2001
++++ shared_libs/iconv/elmiconv.h Thu Nov 1 00:24:13 2001
+@@ -8,7 +8,7 @@
+
+ #include "elmshared.h"
+
+-#include <iconv.h>
++#include <giconv.h>
+
+ #include "../../hdrs/cs_imp.h"
+
diff --git a/mail/elm+ME/pkg-plist b/mail/elm+ME/pkg-plist
index 05c88e8e8b6b..0c7ae088bfc1 100644
--- a/mail/elm+ME/pkg-plist
+++ b/mail/elm+ME/pkg-plist
@@ -27,6 +27,7 @@ etc/rc.d/00elm.sh
@exec [ ! -f %B/elm.mimetypes ] && cp %B/%f %B/elm.mimetypes
%%LIB_SUBDIR%%/elmcharset
%%LIB_SUBDIR%%/elmrc-info
+%%LIB_SUBDIR%%/elmrc-write
%%LIB_SUBDIR%%/elmterminal
%%LIB_SUBDIR%%/elmunidata
%%LIB_SUBDIR%%/prlong
@@ -43,7 +44,11 @@ etc/rc.d/00elm.sh
%%PORTDOCS%%%%DOC_SUBDIR%%/Ref.fmtd.gz
%%PORTDOCS%%%%DOC_SUBDIR%%/Users.fmtd.gz
share/nls/C/elm2.4me+.cat
+@exec if [ -f %D/%%LIB_SUBDIR%%/elm.rc ]; then mv %D/%%LIB_SUBDIR%%/elm.rc %D/%%LIB_SUBDIR%%/elm.rc.orig; fi
+@exec %D/%%LIB_SUBDIR%%/elmrc-write -G -I; mv %D/%%LIB_SUBDIR%%/elm.rc %D/%%LIB_SUBDIR%%/elm.rc-dist
+@exec if [ -f %D/%%LIB_SUBDIR%%/elm.rc.orig ]; then mv %D/%%LIB_SUBDIR%%/elm.rc.orig %D/%%LIB_SUBDIR%%/elm.rc; else cp -p %D/%%LIB_SUBDIR%%/elm.rc-dist %D/%%LIB_SUBDIR%%/elm.rc; fi
+@unexec if cmp -s %D/%%LIB_SUBDIR%%/elm.rc %D/%%LIB_SUBDIR%%/elm.rc-dist; then rm -f %D/%%LIB_SUBDIR%%/elm.rc; fi; rm -f %D/%%LIB_SUBDIR%%/elm.rc-dist
@dirrm %%LIB_SUBDIR%%/elm.map.bin
-@dirrm %%LIB_SUBDIR%%
+@unexec rmdir %D/%%LIB_SUBDIR%% 2> /dev/null || :
@dirrm %%SHLIB_SUBDIR%%
%%PORTDOCS%%@dirrm %%DOC_SUBDIR%%
diff --git a/mail/elm+ME/scripts/pre-configure b/mail/elm+ME/scripts/pre-configure
index 4659273d3793..01937f0f6e01 100644
--- a/mail/elm+ME/scripts/pre-configure
+++ b/mail/elm+ME/scripts/pre-configure
@@ -10,6 +10,11 @@ d_shared_rev=${SO_REV:-$(awk '/SHAREDTAG:/{print $2}' ${WRKSRC}/hdrs/patchlevel.
[ -d ${WRKSRC}/shlib ] || mkdir ${WRKSRC}/shlib
+case ${CFLAGS} in
+*-g*) DEBUG="-DDEBUG" ;;
+*) DEBUG= ;;
+esac
+
cat > ${WRKSRC}/config.sh << EOF
#!/bin/sh
# config.sh
@@ -22,6 +27,7 @@ bin='${PREFIX}/bin'
contains='grep'
cppstdin='/usr/bin/cpp'
cppminus=''
+diff='/usr/bin/diff'
d_getopt='define'
d_memcpy='define'
d_symlink='define'
@@ -64,8 +70,11 @@ mv
rm
sed
sleep
+sort
+diff
touch
tr
+uniq
cut
'
expr='/bin/expr'
@@ -294,7 +303,7 @@ manroffopts=''
suffix=''
packer=''
optimize='${CFLAGS}'
-ccflags='-D_LIBICONV_VERSION=200'
+ccflags='${DEBUG}'
cppflags=''
ldflags='-s'
cc='cc'
@@ -339,7 +348,7 @@ iconv_ok='define'
iconv_dir='${LOCALBASE}'
iconv_include_dir='${LOCALBASE}/include'
iconv_lib_dir='${LOCALBASE}/lib'
-iconv_link='iconv'
+iconv_link='giconv'
EOF
mv ${WRKSRC}/shared_libs/tls/README.ME+ \