aboutsummaryrefslogtreecommitdiff
path: root/mail/elm+ME
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1995-09-28 16:41:56 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1995-09-28 16:41:56 +0000
commita519662b846586d1ced2c00060689cac13bdfef9 (patch)
tree3685d1b37a1935813db034eaba5fcc8ae64f3861 /mail/elm+ME
parentec8beab634c807050238f60c176121a447fe3e80 (diff)
downloadports-a519662b846586d1ced2c00060689cac13bdfef9.tar.gz
ports-a519662b846586d1ced2c00060689cac13bdfef9.zip
Notes
Diffstat (limited to 'mail/elm+ME')
-rw-r--r--mail/elm+ME/Makefile26
-rw-r--r--mail/elm+ME/distinfo3
-rw-r--r--mail/elm+ME/files/patch-ab49
-rw-r--r--mail/elm+ME/files/patch-ac19
-rw-r--r--mail/elm+ME/pkg-comment2
-rw-r--r--mail/elm+ME/pkg-descr2
-rw-r--r--mail/elm+ME/scripts/pre-configure16
7 files changed, 99 insertions, 18 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index 661e03485dd2..2b60c9053911 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -1,19 +1,25 @@
# New ports collection makefile for: elm
-# Version required: 2.4
-# Date created: 14 October 1994
-# Whom: piero
+# Version required: 2.4 ME8a
+# Date created: 26 June 1995
+# Whom: ache
#
-# $Id: Makefile,v 1.4 1995/04/11 20:28:05 asami Exp $
+# $Id: Makefile,v 1.3 1995/09/22 20:10:54 ache Exp $
#
-DISTNAME= elm2.4
-PKGNAME= elm-2.4
+DISTNAME= elm-2.4pl24me8
+PKGNAME= elm-2.4m8a
+PATCHFILES= elm-2.4pl24me8a.diffs.Z
+PATCH_DIST_STRIP= -p1
CATEGORIES+= mail
-MASTER_SITES= ftp://dsinc.myxa.com/pub/elm/
-EXTRACT_SUFX= .tar.Z
+MASTER_SITES= ftp://cs.hmc.edu/pub/me/
+PATCH_SITES= ${MASTER_SITES}
+
+MAINTAINER= ache@FreeBSD.ORG
-NO_WRKSUBDIR= yes
IS_INTERACTIVE= yes
-NO_PACKAGE= yes
+NO_PACKAGE= yes # I don't know, why
+
+post-install:
+ cd ${WRKSRC}/nls; ${MAKE} install
.include <bsd.port.mk>
diff --git a/mail/elm+ME/distinfo b/mail/elm+ME/distinfo
index 906888ac0740..3797cdac8081 100644
--- a/mail/elm+ME/distinfo
+++ b/mail/elm+ME/distinfo
@@ -1 +1,2 @@
-MD5 (elm2.4.tar.Z) = 0e9d1985fc64bfb39a91eb406b124f64
+MD5 (elm-2.4pl24me8.tar.gz) = 5419a3de3b9d8e69ea52c47c617a6a9c
+MD5 (elm-2.4pl24me8a.diffs.Z) = 6be90830bd929cab64e14c5aa7ca97cf
diff --git a/mail/elm+ME/files/patch-ab b/mail/elm+ME/files/patch-ab
new file mode 100644
index 000000000000..42fd950579dd
--- /dev/null
+++ b/mail/elm+ME/files/patch-ab
@@ -0,0 +1,49 @@
+*** nls/Makefile.old Thu Mar 10 20:21:47 1994
+--- nls/Makefile Fri Jul 28 06:55:04 1995
+***************
+*** 1,6 ****
+ LANGFILE=LANGS
+ CATNAME=elm2.4.cat
+! GENCAT= nls/gencat
+
+ HDIR= ../hdrs
+ SDIR= C/C/C
+--- 1,6 ----
+ LANGFILE=LANGS
+ CATNAME=elm2.4.cat
+! GENCAT= gencat
+
+ HDIR= ../hdrs
+ SDIR= C/C/C
+***************
+*** 39,45 ****
+ ./Install $(LANGFILE) $(GENCAT) $(CATNAME)
+
+ $(HFILES): $(MFILES)
+! gencat/gencat $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@
+
+ clean: FRC
+ /bin/rm -f $(MSGCAT)
+--- 39,45 ----
+ ./Install $(LANGFILE) $(GENCAT) $(CATNAME)
+
+ $(HFILES): $(MFILES)
+! $(GENCAT) $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@
+
+ clean: FRC
+ /bin/rm -f $(MSGCAT)
+*** nls/LANGS.old Sun Jun 28 04:32:25 1992
+--- nls/LANGS Fri Jul 28 06:48:31 1995
+***************
+*** 1,5 ****
+ # LANGS file
+
+! C/C/C /usr/local/nls/msg/C
+! english/us/ascii /usr/local/nls/msg/english
+! french/canada/8859 /usr/local/nls/msg/french
+--- 1,5 ----
+ # LANGS file
+
+! C/C/C /usr/local/share/nls/C
+! english/us/ascii /usr/local/share/nls/en_US.ISO_8859-1
+! french/canada/8859 /usr/local/share/nls/fr_FR.ISO_8859-1
diff --git a/mail/elm+ME/files/patch-ac b/mail/elm+ME/files/patch-ac
new file mode 100644
index 000000000000..cc4eb21b843a
--- /dev/null
+++ b/mail/elm+ME/files/patch-ac
@@ -0,0 +1,19 @@
+*** src/menu2.c.bak Mon Aug 28 06:10:02 1995
+--- src/menu2.c Sun Sep 24 21:18:52 1995
+***************
+*** 93,99 ****
+ default:
+ for (i = 0; i < max ; i++) {
+ if (ch == items[i].key) {
+! do_item (items[i]);
+ update = TRUE;
+ break;
+ }
+--- 93,99 ----
+ default:
+ for (i = 0; i < max ; i++) {
+ if (ch == items[i].key) {
+! do_item (&items[i]);
+ update = TRUE;
+ break;
+ }
diff --git a/mail/elm+ME/pkg-comment b/mail/elm+ME/pkg-comment
index 33d7b0a95cde..94b2bfd2f6ad 100644
--- a/mail/elm+ME/pkg-comment
+++ b/mail/elm+ME/pkg-comment
@@ -1 +1 @@
-ELM Mail User Agent v2.4
+ELM Mail User Agent, v2.4pl24 ME8a
diff --git a/mail/elm+ME/pkg-descr b/mail/elm+ME/pkg-descr
index 489b59b72c53..e7b0352e9125 100644
--- a/mail/elm+ME/pkg-descr
+++ b/mail/elm+ME/pkg-descr
@@ -1,2 +1,2 @@
Elm is an interactive screen-oriented mailer program that
- supersedes mail and mailx.
+ supersedes mail and mailx. This version comes with PGP support.
diff --git a/mail/elm+ME/scripts/pre-configure b/mail/elm+ME/scripts/pre-configure
index b336c7e584e7..b17d53a26de3 100644
--- a/mail/elm+ME/scripts/pre-configure
+++ b/mail/elm+ME/scripts/pre-configure
@@ -1,7 +1,7 @@
#!/bin/sh -
#
# pre-configure script for Elm port to FreeBSD 2.0
-# $Id: pre-configure,v 1.1 1994/11/25 19:13:56 gpalmer Exp $
+# $Id: pre-configure,v 1.4 1995/09/23 21:06:06 ache Exp $
PortsDir=$PORTSDIR
CurDir=$CURDIR
@@ -58,7 +58,7 @@ c=''
orderlib='false'
ranlib='/usr/bin/ranlib'
package='elm2'
-pager='builtin+'
+pager='builtin++'
prefshell='/bin/csh'
startsh='#!/bin/sh'
d_eunice='undef'
@@ -113,6 +113,7 @@ more
nroff
pack
pg
+pgp
pmake
pr
rmail
@@ -173,7 +174,7 @@ pack='pack'
compress='/usr/bin/compress'
execmail=''
libswanted='intl nls'
-c_date='Sat May 13 00:58:50 MSD 1995'
+c_date='Tue Jul 4 04:52:32 MSD 1995'
d_ascii='undef'
d_broke_ctype='undef'
d_calendar='define'
@@ -213,6 +214,7 @@ d_mallocvoid='define'
d_mboxedit='undef'
d_mime='undef'
defencoding='7bit'
+d_8bitmime='undef'
defcharset='US-ASCII'
defdispcharset='US-ASCII'
d_mmdf='undef'
@@ -273,7 +275,7 @@ i_utime='define'
i_sysutime='undef'
lib='/usr/local/lib'
libc='/usr/lib/libc.so.2.1'
-linepr='/usr/bin/lpr'
+linepr='/usr/bin/lp'
maildir='/var/mail'
mailer='/usr/sbin/sendmail'
mailgrp='bin'
@@ -294,7 +296,7 @@ small=''
medium=''
large=''
huge=''
-optimize='-O2'
+optimize='-O2 -fno-strength-reduce'
ccflags=''
cppflags=''
ldflags=''
@@ -319,6 +321,10 @@ xencf=''
xenlf=''
d_xenix='undef'
d_bsd='define'
+d_pgp='define'
+pgp='/usr/local/bin/pgp'
+pgp_path='/usr/local/bin/pgp'
+d_remailer='define'
CONFIG=true
EOF