aboutsummaryrefslogtreecommitdiff
path: root/mail/elm+ME
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-29 20:37:58 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-29 20:37:58 +0000
commit4c09704145fc7cefbe566e83536648a2f67ebedb (patch)
tree3a907755e5d846c76a573fc2177a532044f06e53 /mail/elm+ME
parentab84ac8ecfcfc4d99ccc037cb5ca31450a9566d4 (diff)
downloadports-4c09704145fc7cefbe566e83536648a2f67ebedb.tar.gz
ports-4c09704145fc7cefbe566e83536648a2f67ebedb.zip
Notes
Diffstat (limited to 'mail/elm+ME')
-rw-r--r--mail/elm+ME/Makefile12
-rw-r--r--mail/elm+ME/distinfo4
-rw-r--r--mail/elm+ME/files/00elm.sh6
-rw-r--r--mail/elm+ME/files/patch-aa20
-rw-r--r--mail/elm+ME/files/patch-ac18
-rw-r--r--mail/elm+ME/files/patch-mailmsg2.c102
-rw-r--r--mail/elm+ME/scripts/pre-configure11
7 files changed, 72 insertions, 101 deletions
diff --git a/mail/elm+ME/Makefile b/mail/elm+ME/Makefile
index 7b0bc1402b86..10d29fae0929 100644
--- a/mail/elm+ME/Makefile
+++ b/mail/elm+ME/Makefile
@@ -20,6 +20,7 @@ MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/ \
ftp://ftp.ntua.gr/pub/net/mail/elm-me/ \
ftp://ftp.eos.hokudai.ac.jp/pub/network/mail/elm-2.4ME+/ \
ftp://ftp.win.ne.jp/pub/network/mail/elm-2.4ME+/
+
# the following repositories maybe conform to the main repository.
# MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
# ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
@@ -46,13 +47,16 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/-//:S/ME+/.ME+./}
HAS_CONFIGURE= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
+USE_OPENSSL= yes
CONFIGURE_SCRIPT= Configure
SCRIPTS_ENV= CONFIG_PATH="${CONFIG_PATH}" CFLAGS="${CFLAGS}" \
PREFIX="${PREFIX}" LOCALBASE="${LOCALBASE}" \
MAN1PREFIX="${MAN1PREFIX}" CONF_DIR="${CONF_DIR}" \
LIB_DIR="${LIB_DIR}" SHLIB_DIR="${SHLIB_DIR}" \
- STAGE_DIR="${STAGE_DIR}" ELM_SHLIBS="${ELM_SHLIBS}"
+ STAGE_DIR="${STAGE_DIR}" ELM_SHLIBS="${ELM_SHLIBS}" \
+ OPENSSLLIB="${OPENSSLLIB}" OPENSSLINC="${OPENSSLINC}" \
+ OPENSSLBASE="${OPENSSLBASE}"
CONFIGURE_ARGS= -b -S -P ${PREFIX} -c ../${CONFIG_PATH:T}
MAKE_ENV= MJ="FORMATTER=groff FORMATTER_OPTS=-Tlatin1"
@@ -82,7 +86,9 @@ MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
.if !defined(ELM_USER_SHLIBS)
OPTIONS= ELM_ICONV "libiconv support" on \
ELM_SMTP "SMTP submission protocol (RFC2746) support" on \
- ELM_TLS "POP STLS and IMAP STARTTLS support" on
+ ELM_TLS "POP STLS and IMAP STARTTLS support" on \
+ OPENSSL_BASE "use the base system OpenSSL (required by TLS)" on \
+ OPENSSL_PORT "use OpenSSL from ports (requires by TLS)" off
.endif
.include <bsd.port.pre.mk>
@@ -91,7 +97,7 @@ OPTIONS= ELM_ICONV "libiconv support" on \
#
ELM_VERSION= 2.4
-ELM_REVISION= 116
+ELM_REVISION= 119
ELM_PATCHLEVEL= _ # a...z = patch-level, _ means no patch-level.
ELM_PATCHDONE= false
diff --git a/mail/elm+ME/distinfo b/mail/elm+ME/distinfo
index db0871b049cb..9e5c696a53b8 100644
--- a/mail/elm+ME/distinfo
+++ b/mail/elm+ME/distinfo
@@ -1,2 +1,2 @@
-MD5 (elm-2.4ME+116.tar.gz) = cb2ef246253a679268102e3e0d0b1954
-SIZE (elm-2.4ME+116.tar.gz) = 1458277
+MD5 (elm-2.4ME+119.tar.gz) = b9491fcc6533a42d1e835c5cc0049a45
+SIZE (elm-2.4ME+119.tar.gz) = 1491512
diff --git a/mail/elm+ME/files/00elm.sh b/mail/elm+ME/files/00elm.sh
index ab80dc89b7ea..e94cfad0196d 100644
--- a/mail/elm+ME/files/00elm.sh
+++ b/mail/elm+ME/files/00elm.sh
@@ -8,8 +8,8 @@
# REQUIRE: ldconfig
# KEYWORD: FreeBSD
-elm_enable="YES"
-elm_shlib_dir="%%SHLIB_DIR%%"
+elm_enable=${elm_enable:-"YES"}
+elm_shlib_dir=${elm_shlib_dir:-"%%SHLIB_DIR%%"}
. %%RC_SUBR%%
@@ -25,6 +25,8 @@ stop_cmd=":"
elm_start ()
{
+ local _ins
+
_ins=
ldconfig=${ldconfig_command}
checkyesno ldconfig_insecure && _ins="-i"
diff --git a/mail/elm+ME/files/patch-aa b/mail/elm+ME/files/patch-aa
deleted file mode 100644
index 39b21952caf7..000000000000
--- a/mail/elm+ME/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- nls/Makefile.orig Wed Mar 20 08:04:46 2002
-+++ nls/Makefile Tue Apr 16 04:58:53 2002
-@@ -3,7 +3,7 @@
- #
- LANGFILE=LANGS
- CATNAME=elm2.4me+.cat
--GENCAT= nls/gencat
-+GENCAT= gencat
-
- HDIR= ../hdrs
- SDIR= C/C/C
-@@ -44,7 +44,7 @@
- ./Install $(LANGFILE) $(GENCAT) $(CATNAME)
-
- $(HFILES): $(MFILES) gencat/gencat
-- gencat/gencat $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@
-+ $(GENCAT) $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@
-
- clean: FRC
- /bin/rm -f $(MSGCAT)
diff --git a/mail/elm+ME/files/patch-ac b/mail/elm+ME/files/patch-ac
index c86bf8799e53..56571607eedf 100644
--- a/mail/elm+ME/files/patch-ac
+++ b/mail/elm+ME/files/patch-ac
@@ -27,24 +27,6 @@
shift
case "$config" in
"")
-@@ -122,7 +122,7 @@
- case "$error" in
- true)
- cat >&2 << EOM
--Usage: Configure [-dS]
-+Usage: Configure [-dbhSMN] [-P'prefix'] [-s'suffix'] [-c'config'] [-DDEBUG]
- -d : use defaults for all answers.
- -b : batchmode -- do not prompt user (implies -d)
- -h : print this help message and exit (with an error status).
-@@ -2296,7 +2296,7 @@
- echo "Found shlib directory"
- fi
-
-- $echo "Trying create chared library"
-+ $echo "Trying create shared library"
-
- LibLoc=`cd ..; pwd`/shlib
-
@@ -2589,7 +2589,10 @@
: see if crypt exists
diff --git a/mail/elm+ME/files/patch-mailmsg2.c b/mail/elm+ME/files/patch-mailmsg2.c
index 6000f3b28d3b..a96d0cd9f24f 100644
--- a/mail/elm+ME/files/patch-mailmsg2.c
+++ b/mail/elm+ME/files/patch-mailmsg2.c
@@ -1,61 +1,61 @@
---- src/mailmsg2.c.orig Wed Mar 20 08:04:47 2002
-+++ src/mailmsg2.c Fri May 10 10:21:54 2002
-@@ -259,6 +259,7 @@
-
- } else if (copy_msg && ! retransmit) { /* if retransmit we have it! */
- struct string * From_buffer = NULL;
-+ struct string * Date_buffer = NULL;
- struct addr_item *p;
+--- src/mailmsg2.c.orig Wed Aug 4 19:07:35 2004
++++ src/mailmsg2.c Wed Aug 25 01:44:23 2004
+@@ -486,6 +486,7 @@
+ } else if (
+ (forwarding || mime_attach || copy_msg)) {
+ struct string * From_buffer = NULL;
++ struct string * Date_buffer = NULL;
+ struct addr_item *p;
- if (current_header->from) {
-@@ -277,7 +278,23 @@
+ if (hdr->from) {
+@@ -504,7 +505,22 @@
+ }
}
}
- }
-
+
-+ if (current_header->time_sent) {
-+ char date_buf[SLEN];
++ if (hdr->time_sent) {
++ char date_buf[SLEN];
+
-+ Date_buffer = new_string(display_charset);
-+ add_ascii_to_string(Date_buffer,
-+ s2us(elm_date_str(date_buf,
-+ current_header->time_sent +
-+ current_header->tz_offset,
-+ sizeof date_buf)));
-+ if (current_header->time_zone[0]) {
-+ add_ascii_to_string(Date_buffer, s2us(" "));
++ Date_buffer = new_string(display_charset);
+ add_ascii_to_string(Date_buffer,
-+ s2us(current_header->time_zone));
++ s2us(elm_date_str(date_buf,
++ hdr->time_sent +
++ hdr->tz_offset,
++ sizeof date_buf)));
++ if (hdr->time_zone[0]) {
++ add_ascii_to_string(Date_buffer, s2us(" "));
++ add_ascii_to_string(Date_buffer, s2us(hdr->time_zone));
++ }
+ }
-+ }
+
- if (!cur_editcharset)
- cur_editcharset = display_charset;
+ if (!cur_editcharset)
+ cur_editcharset = display_charset;
-@@ -296,12 +313,14 @@
- current_header->env_from);
-
- } else if (attribution[0] && current_header) {
-+ char * date = us2s(stream_from_string(Date_buffer,1,NULL));
- if (From_buffer) {
- char * str = us2s(stream_from_string(From_buffer,1,NULL));
-- fprintf(reply, attribution, str);
-+ fprintf(reply, attribution, str, date);
- free(str);
- } else
-- fprintf(reply, attribution, current_header->env_from);
-+ fprintf(reply, attribution, current_header->env_from, date);
-+ free(date);
- fputc('\n', reply);
- }
- if (edit_message && current_folder) {
-@@ -389,6 +408,8 @@
- }
- if (From_buffer)
- free_string(&From_buffer);
-+ if (Date_buffer)
-+ free_string(&Date_buffer);
- }
-
- if (!cur_editcharset)
+@@ -523,12 +539,15 @@
+ hdr->env_from);
+
+ } else if (attribution[0] && hdr) {
++ char * date = us2s(stream_from_string(Date_buffer,1,NULL));
++
+ if (From_buffer) {
+ char * str = us2s(stream_from_string(From_buffer,1,NULL));
+- fprintf(reply, attribution, str);
++ fprintf(reply, attribution, str, date);
+ free(str);
+ } else
+- fprintf(reply, attribution, hdr->env_from);
++ fprintf(reply, attribution, hdr->env_from, date);
++ free(date);
+ fputc('\n', reply);
+ }
+ if (edit_message && mailbox_file) {
+@@ -621,6 +640,8 @@
+
+ if (From_buffer)
+ free_string(&From_buffer);
++ if (Date_buffer)
++ free_string(&Date_buffer);
+
+ } else {
+ /* make referenced message as edited message */
diff --git a/mail/elm+ME/scripts/pre-configure b/mail/elm+ME/scripts/pre-configure
index 39c1bd361717..6dc752b90e5b 100644
--- a/mail/elm+ME/scripts/pre-configure
+++ b/mail/elm+ME/scripts/pre-configure
@@ -101,7 +101,7 @@ date
diff
emacs
execmail
-finger
+gencat
gpg
ispell
line
@@ -177,9 +177,10 @@ col=''
pack='pack'
compress='/usr/bin/compress'
execmail=''
+gencat='/usr/bin/gencat'
libswanted='sun nls c_s'
noaddlib='yes'
-c_date='Wed Dec 24 03:02:21 CET 2003'
+c_date='Tue Aug 24 15:05:52 CEST 2004'
d_ascii='undef'
d_broke_ctype='undef'
d_calendar='define'
@@ -359,9 +360,9 @@ iconv_link='iconv'
EOF
tee -a ${CONFIG_PATH} >> ${WRKSRC}/shared_libs/tls/config.res << EOF
-tls_dir='system'
-tls_include_dir=''
-tls_lib_dir=''
+tls_dir='${OPENSSLBASE}'
+tls_include_dir='${OPENSSLINC}'
+tls_lib_dir='${OPENSSLLIB}'
EOF
exit 0