aboutsummaryrefslogtreecommitdiff
path: root/mail/elmo/Makefile
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-07 13:57:21 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-07 13:57:21 +0000
commit804f68e42a644b267bca4ee581bf13588eed388e (patch)
tree80f4a355cb48e8670feb7eee5e2e5ce592afdc36 /mail/elmo/Makefile
parentaac2bb9591be71b07e70133747bb76675da114be (diff)
Notes
Diffstat (limited to 'mail/elmo/Makefile')
-rw-r--r--mail/elmo/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 5e99a4f6db55..376e90be9a32 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -17,7 +17,6 @@ COMMENT= Receive, filter, read, compose and send mail at the text console
CONFLICTS= elmo-devel-*
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
USE_ICONV= yes
USE_OPENSSL= yes
USE_PERL5_RUN= yes
@@ -26,6 +25,15 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= elmo.1 elmoconf.pl.1
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+.endif
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libgpgme03.so) || defined(WITH_GPGME)