aboutsummaryrefslogtreecommitdiff
path: root/mail/elmo
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-11 06:27:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-11 06:27:40 +0000
commit20d09fd708ab3de4d8075552b082cd8c7680b97b (patch)
tree98ca28f26330decf7e6fef1ecf9f6640784938a0 /mail/elmo
parentd4e5e008e37b1b2d2cde0396d4b98bde160cd6cb (diff)
downloadports-20d09fd708ab3de4d8075552b082cd8c7680b97b.tar.gz
ports-20d09fd708ab3de4d8075552b082cd8c7680b97b.zip
Notes
Diffstat (limited to 'mail/elmo')
-rw-r--r--mail/elmo/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 69e80b6bfb87..28607aa81182 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -12,10 +12,13 @@ COMMENT= Receive, filter, read, compose, and send mail at the text console
CONFLICTS= elmo-devel-[0-9]*
+OPTIONS_DEFINE= NLS
+
GNU_CONFIGURE= yes
-USES= iconv
+USES= iconv shebangfix
USE_OPENSSL= yes
USE_PERL5_RUN= yes
+SHEBANG_FILES= src/elmoconf.pl
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -26,16 +29,10 @@ MAKE_JOBS_SAFE= yes
MAN1= elmo.1 elmoconf.pl.1
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
-PLIST_SUB+= NLS=""
-USES+= gettext
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_CONFIGURE_ON= --with-libintl-prefix="${LOCALBASE}"
+NLS_CONFIGURE_OFF= --disable-nls
+NLS_USES= gettext
+OPTIONS_SUB= yes
.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
@@ -47,12 +44,10 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/bin/env perl|${PERL} -w|" \
- ${WRKSRC}/src/elmoconf.pl
@${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' -e 's|== "|= "|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' ${WRKSRC}/src/pgp.c
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>