aboutsummaryrefslogtreecommitdiff
path: root/mail/elmo
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-08-07 07:40:19 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-08-07 07:40:19 +0000
commitbf50eb44f29b44273c952f6e8f8b733c908f077b (patch)
tree6e2b57d665a1200073895941efd5136fdbd9a1c9 /mail/elmo
parentddc82c082f7dd71500620543d5d964549a4cf494 (diff)
downloadports-bf50eb44f29b44273c952f6e8f8b733c908f077b.tar.gz
ports-bf50eb44f29b44273c952f6e8f8b733c908f077b.zip
Notes
Diffstat (limited to 'mail/elmo')
-rw-r--r--mail/elmo/Makefile73
-rw-r--r--mail/elmo/distinfo4
-rw-r--r--mail/elmo/files/patch-src_rstring.c16
-rw-r--r--mail/elmo/pkg-message2
-rw-r--r--mail/elmo/pkg-plist7
5 files changed, 44 insertions, 58 deletions
diff --git a/mail/elmo/Makefile b/mail/elmo/Makefile
index 1c67460e313c..abf4a8d9d00f 100644
--- a/mail/elmo/Makefile
+++ b/mail/elmo/Makefile
@@ -6,55 +6,38 @@
#
PORTNAME= elmo
-PORTVERSION= 0.8.3
-PORTREVISION= 3
+PORTVERSION= 1.2.0
CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:sf/} \
- ${MASTER_SITE_SAVANNAH:S/$/:sav/}
-MASTER_SITE_SUBDIR= ${PORTNAME}/:sf \
- ${PORTNAME}/unstable.pkg/${PORTVERSION}/:sav
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf,sav
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= trevor@FreeBSD.org
+MAINTAINER= adamw@FreeBSD.org
COMMENT= Receive, filter, read, compose and send mail at the text console
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
-INFO= elmo
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-MAN1= elmo.1 elmoconf.pl.1
-PLIST= ${WRKDIR}/pkg-plist
USE_GETTEXT= yes
USE_ICONV= yes
-USE_PERL5= yes
-
-pre-extract:
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD} sleeping ten seconds--press control-C to cancel build
- @${ECHO_CMD} 
- @sleep 10
-
-pre-install:
- ${RM} -f ${PLIST}
-.for ii in elmo elmoconf.pl
- ${ECHO_CMD} bin/${ii} >> ${PLIST}
-.endfor
-.for ii in de pl
- ${ECHO_CMD} share/locale/${ii}/LC_MESSAGES/elmo.mo >> ${PLIST}
-.endfor
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/elmo ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/src/elmoconf.pl ${PREFIX}/bin/
-.for ii in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/doc/${ii} ${MANPREFIX}/man/man1
-.endfor
-.for ii in de pl
- ${INSTALL_DATA} ${WRKSRC}/po/${ii}.gmo \
- ${PREFIX}/share/locale/${ii}/LC_MESSAGES/elmo.mo
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/doc/elmo.info ${PREFIX}/info/
- - install-info --info-dir=${PREFIX}/info ${PREFIX}/info/elmo.info
-
-.include <bsd.port.mk>
+USE_OPENSSL= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= elmo.1 elmoconf.pl.1
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libgpgme.so) || defined(WITH_GPGME)
+LIB_DEPENDS+= gpgme:${PORTSDIR}/security/gpgme
+.else
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Define WITH_GPGME=yes to build with gpgme support."
+ @${ECHO_CMD}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/bin/env perl|${PERL}|" \
+ ${WRKSRC}/src/elmoconf.pl
+
+.include <bsd.port.post.mk>
diff --git a/mail/elmo/distinfo b/mail/elmo/distinfo
index 596579f3141f..22d5cc848793 100644
--- a/mail/elmo/distinfo
+++ b/mail/elmo/distinfo
@@ -1,2 +1,2 @@
-MD5 (elmo-0.8.3.tar.gz) = a7837950dbb4ffcc5ec7fea15150c525
-SIZE (elmo-0.8.3.tar.gz) = 469689
+MD5 (elmo-1.2.0.tar.gz) = 6d2ed7ab5f1cb5ea938819f57d24a419
+SIZE (elmo-1.2.0.tar.gz) = 506336
diff --git a/mail/elmo/files/patch-src_rstring.c b/mail/elmo/files/patch-src_rstring.c
index 3d8e793afaab..9f224c115ae2 100644
--- a/mail/elmo/files/patch-src_rstring.c
+++ b/mail/elmo/files/patch-src_rstring.c
@@ -1,20 +1,18 @@
-$FreeBSD$
-
---- src/rstring.c.orig Sat Sep 6 01:58:14 2003
-+++ src/rstring.c Sun Sep 28 02:57:41 2003
-@@ -29,7 +29,6 @@
- #include <stdio.h>
- #include <stdlib.h>
+--- src/rstring.c.orig Sat Aug 7 03:01:05 2004
++++ src/rstring.c Sat Aug 7 03:02:12 2004
+@@ -30,7 +30,6 @@
#include <string.h>
+ #include <stdarg.h>
+ #include <sys/types.h>
-#include <regex.h>
#include <errno.h>
#include <ctype.h>
-@@ -37,6 +36,7 @@
+@@ -38,6 +37,7 @@
#include "rarray.h"
#include "rstring.h"
#include "error.h"
+#include <regex.h>
#include "memchunk.h"
+ #include "str.h"
- /****************************************************************************
diff --git a/mail/elmo/pkg-message b/mail/elmo/pkg-message
deleted file mode 100644
index 4251ec07b065..000000000000
--- a/mail/elmo/pkg-message
+++ /dev/null
@@ -1,2 +0,0 @@
-* WARNING:
-* the source code of elmo has not been reviewed by the FreeBSD port maintainer.
diff --git a/mail/elmo/pkg-plist b/mail/elmo/pkg-plist
new file mode 100644
index 000000000000..f291a5d4444a
--- /dev/null
+++ b/mail/elmo/pkg-plist
@@ -0,0 +1,7 @@
+bin/elmo
+bin/elmoconf.pl
+%%DATADIR%%/template
+%%DATADIR%%/tutorial
+share/locale/de/LC_MESSAGES/elmo.mo
+share/locale/pl/LC_MESSAGES/elmo.mo
+@dirrm %%DATADIR%%