aboutsummaryrefslogtreecommitdiff
path: root/mail/enma
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-04 06:55:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-04 06:55:04 +0000
commit2f515b22d0a88b770c4c22188d51896a5e412884 (patch)
treea34d689b3868645ccc7e567656a85fe479eb829b /mail/enma
parentf75221e4d18a2704ec4f4116cf839f7656b45a26 (diff)
downloadports-2f515b22d0a88b770c4c22188d51896a5e412884.tar.gz
ports-2f515b22d0a88b770c4c22188d51896a5e412884.zip
Notes
Diffstat (limited to 'mail/enma')
-rw-r--r--mail/enma/Makefile60
-rw-r--r--mail/enma/distinfo4
-rw-r--r--mail/enma/files/patch-enma_etc_enma.conf.sample9
-rw-r--r--mail/enma/files/patch-enma_src_addr_util.c10
-rw-r--r--mail/enma/files/patch-enma_src_enma.c10
5 files changed, 39 insertions, 54 deletions
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 42102e930f4e..37ea71ef5b3f 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -6,63 +6,57 @@
#
PORTNAME= enma
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/ENMA/${PORTVERSION}
MAINTAINER= umq@ueo.co.jp
COMMENT= A sender authentication milter supporting SPF and Sender ID
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/dns/bind97:checksum
-
-.if defined(WITH_POSTFIX_MILTER) || defined(WITH_POSTFIX) || defined(WITH_POSTFIX_CURRENT)
-CONF_SUB= ${REINPLACE_CMD} -e '/milter\.postfix/s/false/true/' ${WRKSRC}/enma/etc/enma.conf.sample
-.if defined(WITH_POSTFIX_CURRENT)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix-current
-.else
-RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
-.endif
-.endif
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
-BIND_PATH_CMD= cd ${PORTSDIR}/dns/bind97 && ${MAKE} -V WRKSRC
-BIND_SRC_DIR= ${BASENAME} $$(${BIND_PATH_CMD})
+OPTIONS= LIBBIND "Link against dns/libbind instead of dns/ldns" Off
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PREFIX}/man \
- --with-libbind=${WRKSRC}/build/tmp_build
+ --with-ssl-incdir=${OPENSSLINC} --with-ssl-libdir=${OPENSSLLIB}
USE_RC_SUBR= milter-enma
USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
USE_PERL5_BUILD=yes
-LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
MANLANG= "" ja_JP.UTF-8
MAN1= enma.1
MANCOMPRESSED= no
-PLIST_FILES= libexec/enma bin/sidfquery etc/enma.conf.sample
-PORTDOCS= ChangeLog INSTALL LICENSE README TODO
+PLIST_FILES= bin/sidfquery etc/enma.conf.sample lib/libsauth.a lib/libsauth.la \
+ lib/libsauth.so lib/libsauth.so.0 libexec/enma
+PORTDOCS= ChangeLog INSTALL LICENSE README
SUB_FILES= milter-enma
+.if defined(WITH_POSTFIX_MILTER) || defined(WITH_POSTFIX) || defined(WITH_POSTFIX_CURRENT)
+CONF_SUB= ${REINPLACE_CMD} -e '/milter\.postfix/s/false/true/' ${WRKSRC}/enma/etc/enma.conf.sample
+. if defined(WITH_POSTFIX_CURRENT)
+RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix-current
+. else
+RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
+. endif
+.endif
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
-USE_OPENSSL= yes
-.if ${OSVERSION} < 700000
-WITH_OPENSSL_PORT= yes
+.if defined(WITH_LIBBIND)
+CONFIGURE_ARGS+= --with-resolver=libbind \
+ --with-libbind-incdir=${LOCALBASE}/include/bind \
+ --with-libbind-libdir=${LOCALBASE}/lib
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libbind.a:${PORTSDIR}/dns/libbind
+.else
+CONFIGURE_ARGS+= --with-resolver=ldns
+LIB_DEPENDS+= ldns.1:${PORTSDIR}/dns/ldns
.endif
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
pre-configure:
- cd ${PORTSDIR}/dns/bind97 && ${MAKE} -DBATCH patch && \
- ${LN} -s $$(${BIND_PATH_CMD}) ${WRKSRC}/build && \
- cd ${WRKSRC}/build/$$(${BIND_SRC_DIR}) && \
- ./configure --prefix=${WRKSRC}/build/tmp_build --enable-threads && \
- cd ${WRKSRC}/build/$$(${BIND_SRC_DIR})/lib/dns && \
- ${MAKE} include/dns/enumtype.h include/dns/enumclass.h && \
- cd ${WRKSRC}/build/$$(${BIND_SRC_DIR})/lib/bind9 && \
- ${MAKE} && ${MAKE} install
- ${REINPLACE_CMD} -e 's/-lbind/-lbind9/' ${WRKSRC}/configure \
- ${WRKSRC}/enma/bin/Makefile.in ${WRKSRC}/enma/src/Makefile.in
$$(${CONF_SUB})
post-install:
diff --git a/mail/enma/distinfo b/mail/enma/distinfo
index 40437d96aac4..df844f05f4b8 100644
--- a/mail/enma/distinfo
+++ b/mail/enma/distinfo
@@ -1,2 +1,2 @@
-SHA256 (enma-1.1.0.tar.gz) = d56cebe60bb7af9560381c7bbf3712375e7e0ebcf0483005800a0e15dd92ef18
-SIZE (enma-1.1.0.tar.gz) = 238176
+SHA256 (enma-1.2.0.tar.gz) = 34a07a8929498c67285a1af550b7e49cd4765f18dbe300edb98772cefe53a308
+SIZE (enma-1.2.0.tar.gz) = 411233
diff --git a/mail/enma/files/patch-enma_etc_enma.conf.sample b/mail/enma/files/patch-enma_etc_enma.conf.sample
index 852edb401945..28b2ca490fbc 100644
--- a/mail/enma/files/patch-enma_etc_enma.conf.sample
+++ b/mail/enma/files/patch-enma_etc_enma.conf.sample
@@ -11,12 +11,3 @@
milter.chdir: /var/tmp
milter.timeout: 7210
milter.loglevel: 0
-@@ -16,7 +16,7 @@
-
- ## Syslog ##
- syslog.ident: enma
--syslog.facility: local4
-+syslog.facility: mail
- syslog.logmask: info
-
-
diff --git a/mail/enma/files/patch-enma_src_addr_util.c b/mail/enma/files/patch-enma_src_addr_util.c
deleted file mode 100644
index e02d6a9c923d..000000000000
--- a/mail/enma/files/patch-enma_src_addr_util.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./enma/src/addr_util.c.orig 2009-03-27 15:06:08.000000000 +0900
-+++ ./enma/src/addr_util.c 2010-10-21 09:28:43.000000000 +0900
-@@ -18,6 +18,7 @@
- #include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
diff --git a/mail/enma/files/patch-enma_src_enma.c b/mail/enma/files/patch-enma_src_enma.c
new file mode 100644
index 000000000000..b6426af79254
--- /dev/null
+++ b/mail/enma/files/patch-enma_src_enma.c
@@ -0,0 +1,10 @@
+--- ./enma/src/enma.c.orig 2011-11-07 12:18:02.000000000 +0900
++++ ./enma/src/enma.c 2012-02-25 14:52:45.000000000 +0900
+@@ -15,6 +15,7 @@
+ #include <stdio.h>
+ #include <assert.h>
+ #include <sysexits.h>
++#include <stdbool.h>
+ #include <stdlib.h>
+ #include <syslog.h>
+