aboutsummaryrefslogtreecommitdiff
path: root/mail/eps
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-21 16:46:22 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-21 16:46:22 +0000
commite204f32c4c00b8500fd129485128a604c0509660 (patch)
treee35b234c261bc28e692c569c360018186c86612e /mail/eps
parentbfce0810988c27b64c45e9af6e5abb060af07089 (diff)
downloadports-e204f32c4c00b8500fd129485128a604c0509660.tar.gz
ports-e204f32c4c00b8500fd129485128a604c0509660.zip
Notes
Diffstat (limited to 'mail/eps')
-rw-r--r--mail/eps/Makefile36
-rw-r--r--mail/eps/distinfo2
-rw-r--r--mail/eps/pkg-descr23
-rw-r--r--mail/eps/pkg-message2
-rw-r--r--mail/eps/pkg-plist19
5 files changed, 82 insertions, 0 deletions
diff --git a/mail/eps/Makefile b/mail/eps/Makefile
new file mode 100644
index 000000000000..c47e1408ca57
--- /dev/null
+++ b/mail/eps/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: eps
+# Date created: 21 Jul 2005
+# Whom: ismail@enderunix.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= eps
+PORTVERSION= 1.5
+CATEGORIES= mail
+MASTER_SITES= http://www.inter7.com/eps/
+
+MAINTAINER= ismail@EnderUNIX.org
+COMMENT= EPS is a Email Parsing System
+
+USE_REINPLACE= yes
+
+PORTDOCS= howto
+
+MAKE_ENV+= DEFS="${CFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CC =|CC \?=|' \
+ -e 's|^DEFS =|DEFS \?=|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libeps.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/eps/distinfo b/mail/eps/distinfo
new file mode 100644
index 000000000000..366b88b79806
--- /dev/null
+++ b/mail/eps/distinfo
@@ -0,0 +1,2 @@
+MD5 (eps-1.5.tar.gz) = 842615f5527eacdf91d5dd375ef2e71d
+SIZE (eps-1.5.tar.gz) = 28346
diff --git a/mail/eps/pkg-descr b/mail/eps/pkg-descr
new file mode 100644
index 000000000000..c14b37141ca0
--- /dev/null
+++ b/mail/eps/pkg-descr
@@ -0,0 +1,23 @@
+EPS (Email Parsing System) is intended to give people the ability
+to write their own email processing tools.
+Whether you want to process incoming and outgoing emails,
+or just analyze a message,
+this package is intended to aid in that endeavor.
+
+Features
+
+ * Written in C
+ * API is documented
+ * Fast and efficient
+
+Usage
+How we use EPS and how others use EPS
+
+ * Tracking incoming and outgoing email messages based on threads
+ * Archiving and searching against threads
+ * Demographics collection via email
+ * Email client
+ * Create custom autoresponders
+ * We even used it to parse simple LDIF files!
+
+WWW: http://www.inter7.com/index.php?page=eps
diff --git a/mail/eps/pkg-message b/mail/eps/pkg-message
new file mode 100644
index 000000000000..b1104ad01529
--- /dev/null
+++ b/mail/eps/pkg-message
@@ -0,0 +1,2 @@
+
+Please read the %%PREFIX%%/share/doc/eps/howto
diff --git a/mail/eps/pkg-plist b/mail/eps/pkg-plist
new file mode 100644
index 000000000000..2cf495bc4f22
--- /dev/null
+++ b/mail/eps/pkg-plist
@@ -0,0 +1,19 @@
+include/address.h
+include/base64.h
+include/boundary.h
+include/buffer.h
+include/content.h
+include/email.h
+include/eps.h
+include/fold.h
+include/header.h
+include/int_buffer.h
+include/int_stream.h
+include/interface.h
+include/line.h
+include/mime.h
+include/misc.h
+include/qp.h
+include/rfc2822.h
+include/unfold.h
+lib/libeps.a