aboutsummaryrefslogtreecommitdiff
path: root/mail/epstools
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-26 09:10:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-26 09:10:36 +0000
commit7a00dab22806c277bc64e29cc6bdc2a7803202e6 (patch)
tree1993956ccf542e0d355b7d78c7d62db715ee945c /mail/epstools
parent0577482d2bb2c74377e6d094b77ff6b90622812f (diff)
downloadports-7a00dab22806c277bc64e29cc6bdc2a7803202e6.tar.gz
ports-7a00dab22806c277bc64e29cc6bdc2a7803202e6.zip
Notes
Diffstat (limited to 'mail/epstools')
-rw-r--r--mail/epstools/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/mail/epstools/Makefile b/mail/epstools/Makefile
index e2ae0d555063..d6e1051731af 100644
--- a/mail/epstools/Makefile
+++ b/mail/epstools/Makefile
@@ -18,31 +18,26 @@ MAKE_ENV+= DEFS="-I${LOCALBASE}/include/eps ${CFLAGS}"
SUB_FILES= pkg-message
EXAMPLE_FILES= addr.1 addr.2 addr.3 addr.4 email.1 email.2 virus.email
-INSTALL_FILES= address b64decode b64encode body fold full headers qpdecode rewrite
+INSTALL_FILES= address b64decode b64encode body fold full headers qpdecode \
+ rewrite
+
+OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|^CC =|CC \?=|' \
- -e 's|^DEFS =|DEFS \?=|' \
- -e 's|^LIBS = -leps|LIBS = ${LOCALBASE}/lib/libeps.a|' \
- ${WRKSRC}/Makefile
+ -e 's|^DEFS =|DEFS \?=|' \
+ -e 's|^LIBS = -leps|LIBS = ${LOCALBASE}/lib/libeps.a|' \
+ ${WRKSRC}/Makefile
do-install:
.for f in ${INSTALL_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/bin/eps-${f}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin/eps-${f}
.endfor
-
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${EXAMPLE_FILES}
- ${INSTALL_DATA} ${WRKSRC}/content/${f} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/content/${f} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>