aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-devel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-01-13 19:25:17 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-01-13 19:25:17 +0000
commit845c05afacd6588be1d69f720b3ef04414530234 (patch)
tree470f4119826f27795172e9480a129d1d6e2c80e3 /mail/evolution-devel
parent0e638f172e26ba471cb70e114f509188323a028a (diff)
downloadports-845c05afacd6588be1d69f720b3ef04414530234.tar.gz
ports-845c05afacd6588be1d69f720b3ef04414530234.zip
Notes
Diffstat (limited to 'mail/evolution-devel')
-rw-r--r--mail/evolution-devel/Makefile5
-rw-r--r--mail/evolution-devel/distinfo2
-rw-r--r--mail/evolution-devel/files/patch-aa21
-rw-r--r--mail/evolution-devel/files/patch-camel::camel-mime-message.c14
-rw-r--r--mail/evolution-devel/files/patch-e-util::e-pilot-util.c23
-rw-r--r--mail/evolution-devel/files/patch-po::Makefile.in.in20
-rw-r--r--mail/evolution-devel/files/patch-shell::Makefile.in14
-rw-r--r--mail/evolution-devel/pkg-plist68
8 files changed, 56 insertions, 111 deletions
diff --git a/mail/evolution-devel/Makefile b/mail/evolution-devel/Makefile
index b42ea72a8dc1..375fc4dc22b1 100644
--- a/mail/evolution-devel/Makefile
+++ b/mail/evolution-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= evolution
-PORTVERSION= 1.0
-PORTREVISION= 8
+PORTVERSION= 1.0.1
CATEGORIES= mail gnome
MASTER_SITES= http://www.sleepycat.com/update/3.1.17/ \
${MASTER_SITE_GNOME}
@@ -54,6 +53,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
PLIST_SUB+= VERSION=${PORTVERSION}
+MAN1= evolution.1
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
diff --git a/mail/evolution-devel/distinfo b/mail/evolution-devel/distinfo
index d3e47446f26a..15f8c4cebec0 100644
--- a/mail/evolution-devel/distinfo
+++ b/mail/evolution-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (evolution-1.0.tar.gz) = 89546c8d15c2aca6ca41caa5b5f14a44
+MD5 (evolution-1.0.1.tar.gz) = 3ff4face716bc43b6cbdfbbeb82d8e40
MD5 (db-3.1.17.tar.gz) = 5baeb94fb934d0bf783ea42117c400be
diff --git a/mail/evolution-devel/files/patch-aa b/mail/evolution-devel/files/patch-aa
index f5499db4ff70..bdde2090fd13 100644
--- a/mail/evolution-devel/files/patch-aa
+++ b/mail/evolution-devel/files/patch-aa
@@ -1,9 +1,9 @@
$FreeBSD$
---- configure.orig Fri Dec 14 19:13:12 2001
-+++ configure Fri Dec 14 19:20:26 2001
-@@ -9253,7 +9253,7 @@
+--- configure.orig Sun Jan 13 19:02:14 2002
++++ configure Sun Jan 13 19:02:40 2002
+@@ -9292,7 +9292,7 @@
CPPFLAGS_save="$CPPFLAGS"
CPPFLAGS="$DB3_CFLAGS $CPPFLAGS"
@@ -12,7 +12,7 @@ $FreeBSD$
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -9327,7 +9327,7 @@
+@@ -9366,7 +9366,7 @@
echo "configure: failed program was:" >&5
cat conftest.$ac_ext >&5
rm -rf conftest*
@@ -21,7 +21,7 @@ $FreeBSD$
fi
rm -f conftest*
-@@ -9438,7 +9438,7 @@
+@@ -9477,7 +9477,7 @@
echo "$ac_t""$ac_cv_db3_lib_version_match" 1>&6
if test "$ac_cv_db3_lib_version_match" = no; then
@@ -30,16 +30,7 @@ $FreeBSD$
fi
CPPFLAGS="$CPPFLAGS_save"
-@@ -11059,7 +11059,7 @@
- size_t utf8_real_len = strlen (utf8);
- char *pstring;
-
-- if (convert_ToPilotChar ("UTF8", utf8, utf8_real_len, &pstring) == -1)
-+ if (convert_ToPilotChar ("UTF-8", utf8, utf8_real_len, &pstring) == -1)
- exit (1);
-
- exit (0);
-@@ -12680,10 +12680,10 @@
+@@ -12707,10 +12707,10 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
diff --git a/mail/evolution-devel/files/patch-camel::camel-mime-message.c b/mail/evolution-devel/files/patch-camel::camel-mime-message.c
deleted file mode 100644
index 2f19696c5b1e..000000000000
--- a/mail/evolution-devel/files/patch-camel::camel-mime-message.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- camel/camel-mime-message.c 2001/12/07 18:58:45 1.1
-+++ camel/camel-mime-message.c 2001/12/07 18:59:18
-@@ -206,7 +206,7 @@
- #if defined(HAVE_TIMEZONE)
- tz = timezone;
- #elif defined(HAVE_TM_GMTOFF)
-- tz = local->tm_gmtoff;
-+ tz = -local->tm_gmtoff;
- #endif
- offset = -(((tz/60/60) * 100) + (tz/60 % 60));
- if (local->tm_isdst>0)
diff --git a/mail/evolution-devel/files/patch-e-util::e-pilot-util.c b/mail/evolution-devel/files/patch-e-util::e-pilot-util.c
deleted file mode 100644
index aea980ec11ae..000000000000
--- a/mail/evolution-devel/files/patch-e-util::e-pilot-util.c
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- e-util/e-pilot-util.c 2001/12/14 12:11:21 1.1
-+++ e-util/e-pilot-util.c 2001/12/14 12:12:08
-@@ -36,7 +36,7 @@
- if (!string)
- return NULL;
-
-- res = convert_ToPilotChar ("UTF8", string, strlen (string), &pstring);
-+ res = convert_ToPilotChar ("UTF-8", string, strlen (string), &pstring);
-
- if (res != 0)
- pstring = strdup (string);
-@@ -53,7 +53,7 @@
- if (!string)
- return NULL;
-
-- res = convert_FromPilotChar ("UTF8", string, strlen (string), &ustring);
-+ res = convert_FromPilotChar ("UTF-8", string, strlen (string), &ustring);
-
- if (res != 0)
- ustring = strdup (string);
diff --git a/mail/evolution-devel/files/patch-po::Makefile.in.in b/mail/evolution-devel/files/patch-po::Makefile.in.in
index 52ce64727053..f6aa43a9d474 100644
--- a/mail/evolution-devel/files/patch-po::Makefile.in.in
+++ b/mail/evolution-devel/files/patch-po::Makefile.in.in
@@ -1,14 +1,14 @@
$FreeBSD$
---- po/Makefile.in.in 2001/11/20 13:17:31 1.1
-+++ po/Makefile.in.in 2001/11/20 13:17:42
-@@ -106,7 +106,7 @@
- @catalogs='$(CATALOGS)'; \
- for cat in $$catalogs; do \
- cat=`basename $$cat`; \
-- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+--- po/Makefile.in.in 2002/01/13 17:11:01 1.1
++++ po/Makefile.in.in 2002/01/13 17:11:38
+@@ -125,7 +125,7 @@
+ *.gmo) destdir=$(DESTDIR)$(gnulocaledir);; \
+ *) destdir=$(DESTDIR)$(localedir);; \
+ esac; \
+- lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
- $(mkinstalldirs) $(DESTDIR)$$dir; \
- if test -r $$cat; then \
+ dir=$$destdir/$$lang/LC_MESSAGES; \
+ if test -r "$(MKINSTALLDIRS)"; then \
+ $(MKINSTALLDIRS) $$dir; \
diff --git a/mail/evolution-devel/files/patch-shell::Makefile.in b/mail/evolution-devel/files/patch-shell::Makefile.in
new file mode 100644
index 000000000000..db4862b22875
--- /dev/null
+++ b/mail/evolution-devel/files/patch-shell::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- shell/Makefile.in 2002/01/13 17:29:15 1.1
++++ shell/Makefile.in 2002/01/13 17:29:32
+@@ -186,7 +186,7 @@
+
+ SUBDIRS = glade importer
+
+-INCLUDES = -O \
++INCLUDES = \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir) \
diff --git a/mail/evolution-devel/pkg-plist b/mail/evolution-devel/pkg-plist
index 49db87dd3586..ae78ad12030b 100644
--- a/mail/evolution-devel/pkg-plist
+++ b/mail/evolution-devel/pkg-plist
@@ -1,3 +1,4 @@
+bin/csv2vcard
bin/evolution
bin/evolution-addressbook
bin/evolution-addressbook-clean
@@ -173,25 +174,25 @@ include/evolution/shell/evolution-storage-set-view-listener.h
include/evolution/shell/evolution-storage.h
include/evolution/shell/evolution-wizard.h
include/evolution/wombat/wombat-client.h
-lib/evolution/camel-providers/%%VERSION%%/libcamelimap.a
-lib/evolution/camel-providers/%%VERSION%%/libcamelimap.so
-lib/evolution/camel-providers/%%VERSION%%/libcamelimap.urls
-lib/evolution/camel-providers/%%VERSION%%/libcamellocal.a
-lib/evolution/camel-providers/%%VERSION%%/libcamellocal.so
-lib/evolution/camel-providers/%%VERSION%%/libcamellocal.so.0
-lib/evolution/camel-providers/%%VERSION%%/libcamellocal.urls
-lib/evolution/camel-providers/%%VERSION%%/libcamelpop3.a
-lib/evolution/camel-providers/%%VERSION%%/libcamelpop3.so
-lib/evolution/camel-providers/%%VERSION%%/libcamelpop3.so.0
-lib/evolution/camel-providers/%%VERSION%%/libcamelpop3.urls
-lib/evolution/camel-providers/%%VERSION%%/libcamelsendmail.a
-lib/evolution/camel-providers/%%VERSION%%/libcamelsendmail.so
-lib/evolution/camel-providers/%%VERSION%%/libcamelsendmail.so.0
-lib/evolution/camel-providers/%%VERSION%%/libcamelsendmail.urls
-lib/evolution/camel-providers/%%VERSION%%/libcamelsmtp.a
-lib/evolution/camel-providers/%%VERSION%%/libcamelsmtp.so
-lib/evolution/camel-providers/%%VERSION%%/libcamelsmtp.so.0
-lib/evolution/camel-providers/%%VERSION%%/libcamelsmtp.urls
+lib/evolution/camel-providers/1.0/libcamelimap.a
+lib/evolution/camel-providers/1.0/libcamelimap.so
+lib/evolution/camel-providers/1.0/libcamelimap.urls
+lib/evolution/camel-providers/1.0/libcamellocal.a
+lib/evolution/camel-providers/1.0/libcamellocal.so
+lib/evolution/camel-providers/1.0/libcamellocal.so.0
+lib/evolution/camel-providers/1.0/libcamellocal.urls
+lib/evolution/camel-providers/1.0/libcamelpop3.a
+lib/evolution/camel-providers/1.0/libcamelpop3.so
+lib/evolution/camel-providers/1.0/libcamelpop3.so.0
+lib/evolution/camel-providers/1.0/libcamelpop3.urls
+lib/evolution/camel-providers/1.0/libcamelsendmail.a
+lib/evolution/camel-providers/1.0/libcamelsendmail.so
+lib/evolution/camel-providers/1.0/libcamelsendmail.so.0
+lib/evolution/camel-providers/1.0/libcamelsendmail.urls
+lib/evolution/camel-providers/1.0/libcamelsmtp.a
+lib/evolution/camel-providers/1.0/libcamelsmtp.so
+lib/evolution/camel-providers/1.0/libcamelsmtp.so.0
+lib/evolution/camel-providers/1.0/libcamelsmtp.urls
lib/evolution/evolution-mail-importers/%%VERSION%%/libmbox.a
lib/evolution/evolution-mail-importers/%%VERSION%%/libmbox.so
lib/evolution/evolution-mail-importers/%%VERSION%%/libmbox.so.0
@@ -336,7 +337,6 @@ share/gnome/help/evolution/C/config.html
share/gnome/help/evolution/C/contact-automation-basic.html
share/gnome/help/evolution/C/contact-search.html
share/gnome/help/evolution/C/customizing-summary.html
-share/gnome/help/evolution/C/docbook.css
share/gnome/help/evolution/C/encryption.html
share/gnome/help/evolution/C/figures/calendar.png
share/gnome/help/evolution/C/figures/config-cal.png
@@ -387,18 +387,6 @@ share/gnome/help/evolution/C/sgml/usage-mail.sgml
share/gnome/help/evolution/C/sgml/usage-mainwindow.sgml
share/gnome/help/evolution/C/sgml/usage-print.sgml
share/gnome/help/evolution/C/sgml/usage-sync.sgml
-share/gnome/help/evolution/C/stylesheet-images/caution.gif
-share/gnome/help/evolution/C/stylesheet-images/home.gif
-share/gnome/help/evolution/C/stylesheet-images/important.gif
-share/gnome/help/evolution/C/stylesheet-images/next.gif
-share/gnome/help/evolution/C/stylesheet-images/note.gif
-share/gnome/help/evolution/C/stylesheet-images/prev.gif
-share/gnome/help/evolution/C/stylesheet-images/tip.gif
-share/gnome/help/evolution/C/stylesheet-images/toc-blank.gif
-share/gnome/help/evolution/C/stylesheet-images/toc-minus.gif
-share/gnome/help/evolution/C/stylesheet-images/toc-plus.gif
-share/gnome/help/evolution/C/stylesheet-images/up.gif
-share/gnome/help/evolution/C/stylesheet-images/warning.gif
share/gnome/help/evolution/C/topic.dat
share/gnome/help/evolution/C/typography.html
share/gnome/help/evolution/C/ui-intro.html
@@ -436,7 +424,6 @@ share/gnome/help/evolution/no/config.html
share/gnome/help/evolution/no/contact-automation-basic.html
share/gnome/help/evolution/no/contact-search.html
share/gnome/help/evolution/no/customizing-summary.html
-share/gnome/help/evolution/no/docbook.css
share/gnome/help/evolution/no/encryption.html
share/gnome/help/evolution/no/figures/calendar.png
share/gnome/help/evolution/no/figures/config-cal.png
@@ -489,18 +476,6 @@ share/gnome/help/evolution/no/sgml/usage-mail.sgml
share/gnome/help/evolution/no/sgml/usage-mainwindow.sgml
share/gnome/help/evolution/no/sgml/usage-print.sgml
share/gnome/help/evolution/no/sgml/usage-sync.sgml
-share/gnome/help/evolution/no/stylesheet-images/caution.gif
-share/gnome/help/evolution/no/stylesheet-images/home.gif
-share/gnome/help/evolution/no/stylesheet-images/important.gif
-share/gnome/help/evolution/no/stylesheet-images/next.gif
-share/gnome/help/evolution/no/stylesheet-images/note.gif
-share/gnome/help/evolution/no/stylesheet-images/prev.gif
-share/gnome/help/evolution/no/stylesheet-images/tip.gif
-share/gnome/help/evolution/no/stylesheet-images/toc-blank.gif
-share/gnome/help/evolution/no/stylesheet-images/toc-minus.gif
-share/gnome/help/evolution/no/stylesheet-images/toc-plus.gif
-share/gnome/help/evolution/no/stylesheet-images/up.gif
-share/gnome/help/evolution/no/stylesheet-images/warning.gif
share/gnome/help/evolution/no/topic.dat
share/gnome/help/evolution/no/typography.html
share/gnome/help/evolution/no/ui-intro.html
@@ -1154,6 +1129,7 @@ share/locale/it/LC_MESSAGES/evolution.mo
share/locale/ja/LC_MESSAGES/evolution.mo
share/locale/ko/LC_MESSAGES/evolution.mo
share/locale/lt/LC_MESSAGES/evolution.mo
+share/locale/lv/LC_MESSAGES/evolution.mo
share/locale/nl/LC_MESSAGES/evolution.mo
share/locale/nn/LC_MESSAGES/evolution.mo
share/locale/no/LC_MESSAGES/evolution.mo
@@ -1223,7 +1199,7 @@ share/locale/zh_TW/LC_MESSAGES/evolution.mo
@dirrm share/gnome/evolution
@dirrm lib/evolution/evolution-mail-importers/%%VERSION%%
@dirrm lib/evolution/evolution-mail-importers
-@dirrm lib/evolution/camel-providers/%%VERSION%%
+@dirrm lib/evolution/camel-providers/1.0
@dirrm lib/evolution/camel-providers
@dirrm lib/evolution
@dirrm include/evolution/wombat