aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-exchange/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-02 01:02:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-02 01:02:27 +0000
commit68338952426e0d4e3b373e7fd926682d66dbc8b0 (patch)
treef6db1812124b28755eee5f9cbb35f0b80adc0747 /mail/evolution-exchange/Makefile
parentf86b91b75666673cabb027a2365747ecde61bd85 (diff)
downloadports-68338952426e0d4e3b373e7fd926682d66dbc8b0.tar.gz
ports-68338952426e0d4e3b373e7fd926682d66dbc8b0.zip
Notes
Diffstat (limited to 'mail/evolution-exchange/Makefile')
-rw-r--r--mail/evolution-exchange/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
new file mode 100644
index 000000000000..25deecad6486
--- /dev/null
+++ b/mail/evolution-exchange/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ximian-connector
+# Date created: 30 May 2004
+# Whom: kiesel
+#
+# $FreeBSD$
+#
+
+PORTNAME= ximian
+PORTVERSION= 1.4.7.1
+CATEGORIES= mail gnome
+MASTER_SITES= http://ftp.ximian.com/pub/source/evolution/
+PKGNAMESUFFIX= -connector
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= kiesel@schlund.de
+COMMENT= Evolution plugin to connect to Microsoft Exchange servers
+
+BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WANT_OPENLDAP_VER= 21
+WANT_OPENLDAP_SASL= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
+ --with-static-ldap=no
+
+EVO_VERSION= 1.4
+PLIST_SUB= VERSION="1.4" EVO_VERSION=${EVO_VERSION}
+
+.include <bsd.port.mk>