aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-exchange
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-07 22:24:32 +0000
commit58406bee8938178fc317574c4236434b0dd11a25 (patch)
treeb4fa34eca69e23769c548b4436cbf65d765e5fe2 /mail/evolution-exchange
parent98eb5c95a29c8dd1a76435744e5316092835f696 (diff)
downloadports-58406bee8938178fc317574c4236434b0dd11a25.tar.gz
ports-58406bee8938178fc317574c4236434b0dd11a25.zip
Notes
Diffstat (limited to 'mail/evolution-exchange')
-rw-r--r--mail/evolution-exchange/Makefile36
-rw-r--r--mail/evolution-exchange/distinfo4
-rw-r--r--mail/evolution-exchange/files/patch-configure31
-rw-r--r--mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c14
-rw-r--r--mail/evolution-exchange/files/patch-ltmain.sh51
-rw-r--r--mail/evolution-exchange/files/patch-po::Makefile.in.in11
-rw-r--r--mail/evolution-exchange/pkg-plist88
7 files changed, 148 insertions, 87 deletions
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index 1756b804bc9d..5ab39285bf6c 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ximian
-PORTVERSION= 1.4.7.1
-PORTREVISION= 1
+PORTVERSION= 2.0.2
CATEGORIES= mail gnome
-MASTER_SITES= http://ftp.ximian.com/pub/source/evolution/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/2.0
PKGNAMESUFFIX= -connector
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
@@ -19,18 +19,36 @@ COMMENT= Evolution plugin to connect to Microsoft Exchange servers
BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+USE_BZIP2= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
-WANT_OPENLDAP_VER= 21
-WANT_OPENLDAP_SASL= yes
+USE_OPENLDAP= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnometarget
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -rpath ${X11BASE}/lib/evolution/${EVO_VERSION}"
CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
--with-static-ldap=no
-EVO_VERSION= 1.4
-PLIST_SUB= VERSION="1.4" EVO_VERSION=${EVO_VERSION}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+EVO_VERSION= 2.0
+PLIST_SUB= VERSION="2.0" EVO_VERSION=${EVO_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000 && defined(MAKE_KERBEROS5) && \
+ exists(/usr/lib/libkrb5.so) && !defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --with-krb5=/usr
+.elif ( ${OSVERSION} < 500000 && !defined(MAKE_KERBEROS5) ) || \
+ defined(PACKAGE_BUILDING)
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
+.elif ${OSVERSION} >= 500000 && !defined(NO_KERBEROS) && \
+ exists(/usr/lib/libkrb5.so)
+CONFIGURE_ARGS+= --with-krb5=/usr
+.else
+LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/evolution-exchange/distinfo b/mail/evolution-exchange/distinfo
index ff3a864f146c..ecaf521ee176 100644
--- a/mail/evolution-exchange/distinfo
+++ b/mail/evolution-exchange/distinfo
@@ -1,2 +1,2 @@
-MD5 (ximian-connector-1.4.7.1.tar.gz) = fad20b3b50161a99f1e36b704590e600
-SIZE (ximian-connector-1.4.7.1.tar.gz) = 898976
+MD5 (ximian-connector-2.0.2.tar.bz2) = 706f53c9c26321c938248264a4456c30
+SIZE (ximian-connector-2.0.2.tar.bz2) = 1185897
diff --git a/mail/evolution-exchange/files/patch-configure b/mail/evolution-exchange/files/patch-configure
index b2b64b88e985..43668716a0d1 100644
--- a/mail/evolution-exchange/files/patch-configure
+++ b/mail/evolution-exchange/files/patch-configure
@@ -1,11 +1,22 @@
---- configure.orig Tue Jun 1 20:52:34 2004
-+++ configure Tue Jun 1 20:52:55 2004
-@@ -22992,7 +22992,7 @@
-
- case $with_static_ldap in
- no|"")
-- if test -f $with_openldap/lib/libldap.la; then
-+ if test -f $with_openldap/lib/libldap.so; then
- with_static_ldap=no
+--- configure.orig Fri Aug 20 15:26:49 2004
++++ configure Fri Aug 20 15:27:21 2004
+@@ -23754,8 +23754,8 @@
+ # libldap might depend on OpenSSL... We need to pull
+ # in the dependency libs explicitly here since we're
+ # not using libtool for the configure test.
+- if test -f $with_openldap/lib/libldap.la; then
+- LDAP_LIBS="`. $with_openldap/lib/libldap.la; echo $dependency_libs` $LDAP_LIBS"
++ if test -f $with_openldap/lib/libldap.so; then
++ LDAP_LIBS="`. $with_openldap/lib/libldap.so; echo $dependency_libs` $LDAP_LIBS"
+ fi
else
- with_static_ldap=yes
+ LDAP_LIBS="-llber $LDAP_LIBS"
+@@ -24006,7 +24006,7 @@
+
+
+ mitlibs="-lkrb5 -lk5crypto -lcom_err -lgssapi_krb5"
+-heimlibs="-lkrb5 -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
++heimlibs="-lkrb5 -lcrypt -lcrypto -lasn1 -lcom_err -lroken -lgssapi"
+ echo "$as_me:$LINENO: checking for Kerberos 5" >&5
+ echo $ECHO_N "checking for Kerberos 5... $ECHO_C" >&6
+ if test "${ac_cv_lib_kerberos5+set}" = set; then
diff --git a/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c b/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c
index d5806c41d0c5..7576f7123449 100644
--- a/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c
+++ b/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c
@@ -1,13 +1,13 @@
---- lib/e2k-autoconfig.c.orig Tue May 11 11:09:03 2004
-+++ lib/e2k-autoconfig.c Tue Jun 1 20:47:50 2004
-@@ -25,6 +25,10 @@
+--- lib/e2k-autoconfig.c.orig Tue May 11 11:15:58 2004
++++ lib/e2k-autoconfig.c Thu Jun 17 14:02:58 2004
+@@ -31,6 +31,10 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
- #include <stdlib.h>
- #include <string.h>
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
- #include <resolv.h>
+ #include <netinet/in.h>
#include <arpa/nameser.h>
-
+ #include <resolv.h>
diff --git a/mail/evolution-exchange/files/patch-ltmain.sh b/mail/evolution-exchange/files/patch-ltmain.sh
deleted file mode 100644
index 263a5ce21d00..000000000000
--- a/mail/evolution-exchange/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Mon Apr 5 19:24:18 2004
-+++ ltmain.sh Tue Jun 1 20:45:09 2004
-@@ -1346,7 +1346,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1361,8 +1361,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3056,6 +3064,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5528,10 +5539,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/evolution-exchange/files/patch-po::Makefile.in.in b/mail/evolution-exchange/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..042bef6eb7fc
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-po::Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Sun Jul 25 18:30:57 2004
++++ po/Makefile.in.in Sun Jul 25 18:31:20 2004
+@@ -32,6 +32,8 @@
+ gnulocaledir = $(datadir)/locale
+ gettextsrcdir = $(datadir)/glib-2.0/gettext/po
+ subdir = po
++mkdir_p = @mkdir_p@
++mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
diff --git a/mail/evolution-exchange/pkg-plist b/mail/evolution-exchange/pkg-plist
index 2041a036ef58..70ec761c760a 100644
--- a/mail/evolution-exchange/pkg-plist
+++ b/mail/evolution-exchange/pkg-plist
@@ -1,21 +1,93 @@
-bin/ximian-connector-setup
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/apps_evolution_exchange.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/apps_evolution_exchange.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/apps_evolution_exchange.schemas > /dev/null || /usr/bin/true
+bin/ximian-connector-setup-%%VERSION%%
lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.so
lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.urls
-libdata/bonobo/servers/GNOME_Evolution_Exchange_Storage.server
+libdata/bonobo/servers/GNOME_Evolution_Exchange_Storage_%%VERSION%%.server
libexec/evolution/%%EVO_VERSION%%/evolution-exchange-storage
-share/gnome/evolution/%%EVO_VERSION%%/images/connector.png
-share/gnome/evolution/%%EVO_VERSION%%/images/exchange-delegates-48.png
-share/gnome/evolution/%%EVO_VERSION%%/images/exchange-oof-48.png
+%%DOCSDIR%%/E2kContext.html
+%%DOCSDIR%%/E2kGlobalCatalog.html
+%%DOCSDIR%%/E2kSecurityDescriptor.html
+%%DOCSDIR%%/E2kSid.html
+%%DOCSDIR%%/E2kUserDialog.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+%%DOCSDIR%%/ximian-connector-e2k-action.html
+%%DOCSDIR%%/ximian-connector-e2k-autoconfig.html
+%%DOCSDIR%%/ximian-connector-e2k-encoding-utils.html
+%%DOCSDIR%%/ximian-connector-e2k-freebusy.html
+%%DOCSDIR%%/ximian-connector-e2k-http-utils.html
+%%DOCSDIR%%/ximian-connector-e2k-properties.html
+%%DOCSDIR%%/ximian-connector-e2k-restriction.html
+%%DOCSDIR%%/ximian-connector-e2k-result.html
+%%DOCSDIR%%/ximian-connector-e2k-rule-xml.html
+%%DOCSDIR%%/ximian-connector-e2k-rule.html
+%%DOCSDIR%%/ximian-connector-e2k-uri.html
+%%DOCSDIR%%/ximian-connector-e2k-utils.html
+%%DOCSDIR%%/ximian-connector-e2k-xml-utils.html
+%%DOCSDIR%%/ximian-connector-test-utils.html
+%%DOCSDIR%%/ximian-connector-xntlm-des.html
+%%DOCSDIR%%/ximian-connector-xntlm-md4.html
+%%DOCSDIR%%/ximian-connector-xntlm.html
+%%DOCSDIR%%/ximian-connector.devhelp
+share/gnome/ximian-connector/%%VERSION%%/etspec/e-storage-set-view.etspec
+share/gnome/ximian-connector/%%VERSION%%/glade/e-folder-creation-dialog.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/e-foreign-folder-dialog.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-autoconfig-wizard.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-change-password.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-delegates.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-oof.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-permissions-dialog.glade
+share/gnome/ximian-connector/%%VERSION%%/images/connector-mini.png
share/gnome/ximian-connector/%%VERSION%%/images/connector.png
+share/gnome/ximian-connector/%%VERSION%%/images/exchange-delegates-48.png
+share/gnome/ximian-connector/%%VERSION%%/images/exchange-oof-48.png
+share/gnome/ximian-connector/%%VERSION%%/ui/ximian-connector.xml
+share/locale/ar/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/az/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/bg/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/bn/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/cs/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/cy/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/da/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/de/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/el/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/en_CA/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/es/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/fi/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/fr/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/gu/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/hu/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/it/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/ja/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/ko/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/ms/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/nb/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/nl/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/nn/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/no/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/pa/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/pl/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/pt/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/pt_BR/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/sq/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/sr/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/sr@Latn/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/sv/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/ta/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/tr/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/uk/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/zh_CN/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/zh_TW/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+@dirrm share/gnome/ximian-connector/%%VERSION%%/ui
@dirrm share/gnome/ximian-connector/%%VERSION%%/images
@dirrm share/gnome/ximian-connector/%%VERSION%%/glade
+@dirrm share/gnome/ximian-connector/%%VERSION%%/etspec
@dirrm share/gnome/ximian-connector/%%VERSION%%
@dirrm share/gnome/ximian-connector
+@dirrm %%DOCSDIR%%