aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-exchange
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /mail/evolution-exchange
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'mail/evolution-exchange')
-rw-r--r--mail/evolution-exchange/Makefile14
-rw-r--r--mail/evolution-exchange/distinfo4
-rw-r--r--mail/evolution-exchange/files/patch-po::Makefile.in.in11
-rw-r--r--mail/evolution-exchange/files/patch-storage_e-folder-exchange.c16
-rw-r--r--mail/evolution-exchange/pkg-plist40
5 files changed, 33 insertions, 52 deletions
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index f8f815e4531a..90ba22ac5525 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ximian
-PORTVERSION= 2.0.4
+PORTVERSION= 2.2.0
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/2.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/2.2
PKGNAMESUFFIX= -connector
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
@@ -26,13 +26,13 @@ USE_GMAKE= yes
USE_OPENLDAP= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnometarget
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -rpath ${X11BASE}/lib/evolution/${EVO_VERSION}"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
--with-static-ldap=no
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
-EVO_VERSION= 2.0
-PLIST_SUB= VERSION="2.0" EVO_VERSION=${EVO_VERSION}
+EVO_VERSION= 2.2
+PLIST_SUB= VERSION="2.2" EVO_VERSION=${EVO_VERSION} EDS_VERSION="1.2"
.include <bsd.port.pre.mk>
@@ -48,4 +48,8 @@ CONFIGURE_ARGS+= --with-krb5=${LOCALBASE}
.endif
.endif
+.if ${ARCH} == "amd64"
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -fPIC"
+.endif
+
.include <bsd.port.post.mk>
diff --git a/mail/evolution-exchange/distinfo b/mail/evolution-exchange/distinfo
index 0bca663c9c31..bf1166cc4bf2 100644
--- a/mail/evolution-exchange/distinfo
+++ b/mail/evolution-exchange/distinfo
@@ -1,2 +1,2 @@
-MD5 (ximian-connector-2.0.4.tar.bz2) = 726499c226b0932882dffe76869e9031
-SIZE (ximian-connector-2.0.4.tar.bz2) = 1202829
+MD5 (ximian-connector-2.2.0.tar.bz2) = 10ee14a8670c36c24f1d13021257c0ce
+SIZE (ximian-connector-2.2.0.tar.bz2) = 1242512
diff --git a/mail/evolution-exchange/files/patch-po::Makefile.in.in b/mail/evolution-exchange/files/patch-po::Makefile.in.in
deleted file mode 100644
index 042bef6eb7fc..000000000000
--- a/mail/evolution-exchange/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Sun Jul 25 18:30:57 2004
-+++ po/Makefile.in.in Sun Jul 25 18:31:20 2004
-@@ -32,6 +32,8 @@
- gnulocaledir = $(datadir)/locale
- gettextsrcdir = $(datadir)/glib-2.0/gettext/po
- subdir = po
-+mkdir_p = @mkdir_p@
-+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
diff --git a/mail/evolution-exchange/files/patch-storage_e-folder-exchange.c b/mail/evolution-exchange/files/patch-storage_e-folder-exchange.c
new file mode 100644
index 000000000000..7436ca9fe8f6
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-storage_e-folder-exchange.c
@@ -0,0 +1,16 @@
+--- storage/e-folder-exchange.c.orig Tue Jan 25 21:31:32 2005
++++ storage/e-folder-exchange.c Tue Jan 25 21:31:52 2005
+@@ -689,11 +689,12 @@
+ void
+ e_folder_exchange_unsubscribe (EFolder *folder)
+ {
++ E2kContext *ctx;
+ g_return_if_fail (E_IS_FOLDER_EXCHANGE (folder));
+
+ /* FIXME : This is a hack as of now. The free_folder in mail-stub
+ gets called when we are in offline and the context is NULL then. */
+- E2kContext *ctx = E_FOLDER_EXCHANGE_CONTEXT (folder);
++ ctx = E_FOLDER_EXCHANGE_CONTEXT (folder);
+ if (ctx) {
+ e2k_context_unsubscribe (E_FOLDER_EXCHANGE_CONTEXT (folder),
+ E_FOLDER_EXCHANGE_URI (folder));
diff --git a/mail/evolution-exchange/pkg-plist b/mail/evolution-exchange/pkg-plist
index ac4581fd4159..c43d25bf769c 100644
--- a/mail/evolution-exchange/pkg-plist
+++ b/mail/evolution-exchange/pkg-plist
@@ -1,45 +1,17 @@
bin/ximian-connector-setup-%%VERSION%%
-lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.so
-lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.urls
+lib/evolution-data-server-%%EDS_VERSION%%/camel-providers/libcamelexchange.so
+lib/evolution-data-server-%%EDS_VERSION%%/camel-providers/libcamelexchange.urls
libdata/bonobo/servers/GNOME_Evolution_Exchange_Storage_%%VERSION%%.server
libexec/evolution/%%EVO_VERSION%%/evolution-exchange-storage
-%%DOCSDIR%%/E2kContext.html
-%%DOCSDIR%%/E2kGlobalCatalog.html
-%%DOCSDIR%%/E2kSecurityDescriptor.html
-%%DOCSDIR%%/E2kSid.html
-%%DOCSDIR%%/E2kUserDialog.html
-%%DOCSDIR%%/ch01.html
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/up.png
-%%DOCSDIR%%/ximian-connector-e2k-action.html
-%%DOCSDIR%%/ximian-connector-e2k-autoconfig.html
-%%DOCSDIR%%/ximian-connector-e2k-encoding-utils.html
-%%DOCSDIR%%/ximian-connector-e2k-freebusy.html
-%%DOCSDIR%%/ximian-connector-e2k-http-utils.html
-%%DOCSDIR%%/ximian-connector-e2k-properties.html
-%%DOCSDIR%%/ximian-connector-e2k-restriction.html
-%%DOCSDIR%%/ximian-connector-e2k-result.html
-%%DOCSDIR%%/ximian-connector-e2k-rule-xml.html
-%%DOCSDIR%%/ximian-connector-e2k-rule.html
-%%DOCSDIR%%/ximian-connector-e2k-uri.html
-%%DOCSDIR%%/ximian-connector-e2k-utils.html
-%%DOCSDIR%%/ximian-connector-e2k-xml-utils.html
-%%DOCSDIR%%/ximian-connector-test-utils.html
-%%DOCSDIR%%/ximian-connector-xntlm-des.html
-%%DOCSDIR%%/ximian-connector-xntlm-md4.html
-%%DOCSDIR%%/ximian-connector-xntlm.html
-%%DOCSDIR%%/ximian-connector.devhelp
share/gnome/ximian-connector/%%VERSION%%/etspec/e-storage-set-view.etspec
share/gnome/ximian-connector/%%VERSION%%/glade/e-folder-creation-dialog.glade
share/gnome/ximian-connector/%%VERSION%%/glade/e-foreign-folder-dialog.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-autoconfig-wizard.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-change-password.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-delegates.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-folder-tree.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-oof.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-passwd-expiry.glade
share/gnome/ximian-connector/%%VERSION%%/glade/exchange-permissions-dialog.glade
share/gnome/ximian-connector/%%VERSION%%/images/connector-mini.png
share/gnome/ximian-connector/%%VERSION%%/images/connector.png
@@ -51,8 +23,6 @@ share/locale/az/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/bg/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/bn/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
-share/locale/cy/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
-share/locale/da/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/de/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/el/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/en_CA/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
@@ -61,10 +31,12 @@ share/locale/es/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/fi/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/fr/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/gu/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/hi/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/it/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/ja/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/ko/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+share/locale/lt/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/ms/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/nb/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/ximian-connector-%%VERSION%%.mo