aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution-exchange
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-09-07 09:30:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-09-07 09:30:43 +0000
commitc207d1820e033004dccd57750bd905b0fe4e7c7d (patch)
tree3ca7403e6cf36965acd90fbc412b62b34da8af58 /mail/evolution-exchange
parent0a169fbd3859665694ffd6c7a05c472cd2d1e26f (diff)
downloadports-c207d1820e033004dccd57750bd905b0fe4e7c7d.tar.gz
ports-c207d1820e033004dccd57750bd905b0fe4e7c7d.zip
Notes
Diffstat (limited to 'mail/evolution-exchange')
-rw-r--r--mail/evolution-exchange/Makefile2
-rw-r--r--mail/evolution-exchange/distinfo4
-rw-r--r--mail/evolution-exchange/files/patch-addressbook_e-book-backend-gal.c20
3 files changed, 23 insertions, 3 deletions
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
index 2cafa1673c05..2dc205c8d428 100644
--- a/mail/evolution-exchange/Makefile
+++ b/mail/evolution-exchange/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ximian
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.3
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}${PKGNAMESUFFIX}/2.2
diff --git a/mail/evolution-exchange/distinfo b/mail/evolution-exchange/distinfo
index e80523bf6ad3..14f454f2f22d 100644
--- a/mail/evolution-exchange/distinfo
+++ b/mail/evolution-exchange/distinfo
@@ -1,2 +1,2 @@
-MD5 (ximian-connector-2.2.2.tar.bz2) = 2cee47bdf6030d30a5ac82e5028b58ed
-SIZE (ximian-connector-2.2.2.tar.bz2) = 1367526
+MD5 (ximian-connector-2.2.3.tar.bz2) = 9545af11852f8ea3794ca39f58a45873
+SIZE (ximian-connector-2.2.3.tar.bz2) = 1188149
diff --git a/mail/evolution-exchange/files/patch-addressbook_e-book-backend-gal.c b/mail/evolution-exchange/files/patch-addressbook_e-book-backend-gal.c
new file mode 100644
index 000000000000..91469b5788a2
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-addressbook_e-book-backend-gal.c
@@ -0,0 +1,20 @@
+--- addressbook/e-book-backend-gal.c.orig Fri Jun 3 09:32:12 2005
++++ addressbook/e-book-backend-gal.c Wed Sep 7 05:24:12 2005
+@@ -413,12 +413,13 @@
+ the op after either */
+ msg_type = ldap_msgtype (res);
+ if (msg_type == LDAP_RES_SEARCH_ENTRY) {
+- g_mutex_lock (bl->priv->ldap_lock);
+- LDAPMessage *e = ldap_first_entry(bl->priv->ldap, res);
+- g_mutex_unlock (bl->priv->ldap_lock);
+-
++ LDAPMessage *e;
+ EContact *contact;
+ char *vcard;
++
++ g_mutex_lock (bl->priv->ldap_lock);
++ e = ldap_first_entry(bl->priv->ldap, res);
++ g_mutex_unlock (bl->priv->ldap_lock);
+
+ if (!e) {
+ g_warning ("uh, this shouldn't happen");