aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-11 06:16:16 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-11 06:16:16 +0000
commit257b51868831cfbd2171e5d0bc6ccbabc057c274 (patch)
tree52e514a07cd0171224a8d69a07e15cf887e121e3 /mail/evolution/Makefile
parent7886bf6d12203ff75202485836810768d4c33bcc (diff)
downloadports-257b51868831cfbd2171e5d0bc6ccbabc057c274.tar.gz
ports-257b51868831cfbd2171e5d0bc6ccbabc057c274.zip
Notes
Diffstat (limited to 'mail/evolution/Makefile')
-rw-r--r--mail/evolution/Makefile40
1 files changed, 14 insertions, 26 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index e57ab6daf1c8..076111c11052 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -6,47 +6,43 @@
#
PORTNAME= evolution
-PORTVERSION= 1.2.4
+PORTVERSION= 1.4.0
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.2 \
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.4 \
sobomax/:local
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
db-3.1.17${EXTRACT_SUFX}:local
-DIST_SUBDIR= gnome
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An integrated mail, calendar and address book distributed suite
-LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf \
- nss3.1:${PORTSDIR}/security/nss \
- soup.6:${PORTSDIR}/devel/soup
+LIB_DEPENDS= soup-2.0.0:${PORTSDIR}/devel/libsoup \
+ gtkhtml-3.0.2:${PORTSDIR}/www/gtkhtml3
.if defined(WITH_LDAP)
LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
.endif
-RUN_DEPENDS= gnome-spell-component-0.5:${PORTSDIR}/textproc/gnomespell \
- gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+RUN_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
.if !defined(WITHOUT_PILOT)
-BUILD_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
-RUN_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
+LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnomepilot2
.endif
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs gal gtkhtml
+USE_GNOME= gnomeprefix gnomehack gnometarget
USE_REINPLACE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-db3-libs=${DB3_WRKSRC} \
--with-db3-includes=${DB3_WRKSRC} \
- --with-nspr-includes=${LOCALBASE}/include/nspr \
- --with-nspr-libs=${LOCALBASE}/lib \
- --with-nss-includes=${LOCALBASE}/include/nss/nss \
- --with-nss-libs=${LOCALBASE}/lib
+ --enable-nss=no \
+ --enable-openssl=yes
+CONFLICTS= evolution-1.2*
.if defined(WITH_LDAP)
CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
@@ -62,14 +58,10 @@ PLIST_SUB= PILOT:="@comment "
CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-PLIST_SUB+= VERSION=${PORTVERSION}
-
-MAN1= evolution.1
+PLIST_SUB+= VERSION="1.4"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l '<db.h>' | \
+ @${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} ${GREP} -l '<db.h>' | \
${XARGS} ${REINPLACE_CMD} -e 's|<db.h>|<db3/db.h>|g'
# DB3 stuff. Ugly, I know, but that's life.
@@ -81,7 +73,7 @@ DB3_CONFIGURE_ARGS= --enable-compat185 \
--disable-dynamic \
--prefix=${PREFIX} \
--includedir=${PREFIX}/include/db3 \
- --build=${ARCH}-unknown-freebsd${OSREL}
+ --target=${ARCH}-unknown-freebsd${OSREL}
pre-configure:
@(cd ${DB3_WRKSRC} && \
@@ -97,8 +89,4 @@ pre-configure:
@${LN} -s . ${DB3_WRKSRC}/db3
# End of the DB3 stuff
-post-install:
- @${FIND} ${PREFIX}/share/gnome/evolution/default_user -type f | \
- ${XARGS} ${CHMOD} 644
-
.include <bsd.port.mk>