aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-09-04 18:53:13 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-09-04 18:53:13 +0000
commit3ef1afa8d7bf0abcf2adcd3e21cc50f733ae7025 (patch)
tree072c1ce305b22310d3f50db4a6605f079770bca4 /mail/evolution/Makefile
parent357cf619c52b9484fe698d02d15a063a77ca4009 (diff)
Notes
Diffstat (limited to 'mail/evolution/Makefile')
-rw-r--r--mail/evolution/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index b12f0cf56dd6..f797e1dc54c1 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -6,18 +6,18 @@
#
PORTNAME= evolution
-PORTVERSION= 0.10
-PORTREVISION= 1
+PORTVERSION= 0.12
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/evolution
MAINTAINER= gnome@FreeBSD.org
-#LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap <- avoid extra dependency until
+LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf
+#ldap.1:${PORTSDIR}/net/openldap <- avoid extra dependency until
# it actually works
-BROKEN= "Out of sync with latest gal"
+#BROKEN= "Out of sync with latest gal"
USE_GMAKE= yes
USE_BISON= yes
@@ -25,7 +25,9 @@ USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure libical/configure
-CONFIGURE_ARGS= # --with-pisock=${LOCALBASE}/pilot --enable-pilot-conduits=yes
+CONFIGURE_ARGS= --with-db3-libs=${LOCALBASE}/lib \
+ --with-html-dir=${PREFIX}/share/gnome/html
+# --with-pisock=${LOCALBASE}/pilot --enable-pilot-conduits=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -37,5 +39,11 @@ pre-patch:
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l '[^g]iconv.h' | \
+ xargs ${PERL} -pi -e 's|([^g])iconv.h|\1giconv.h|g'
+ @find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l '<db.h>' | \
+ xargs ${PERL} -pi -e 's|<db.h>|<db3/db.h>|g'
+ @find ${WRKSRC} -type f -name "*.[ch]" | xargs ${GREP} -l 'wrong DB3' | \
+ xargs ${PERL} -pi -e 's|.*wrong DB3.*||'
.include <bsd.port.mk>