aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-12 09:56:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-12 09:56:39 +0000
commitf9933fb0f88426dd4f5dc11e0a07550529c979f2 (patch)
tree71ad1b208ace91e4ed7d8dbec6a53176c2c09510 /mail/evolution/Makefile
parentb1cdc5bcd7ad657a5b141cbe47a867b51dd176e2 (diff)
downloadports-f9933fb0f88426dd4f5dc11e0a07550529c979f2.tar.gz
ports-f9933fb0f88426dd4f5dc11e0a07550529c979f2.zip
Notes
Diffstat (limited to 'mail/evolution/Makefile')
-rw-r--r--mail/evolution/Makefile40
1 files changed, 21 insertions, 19 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 6be065fbd562..6000317c9bc2 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= evolution
-PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTVERSION= 1.4.6
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
@@ -20,13 +19,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= An integrated mail, calendar and address book distributed suite
-.if defined(WITH_LDAP)
-USE_OPENLDAP= yes
-.endif
RUN_DEPENDS= ${X11BASE}/lib/gnome-spell/libgnome-spell-component-0.3.so:${PORTSDIR}/textproc/gnomespell
-.if !defined(WITHOUT_PILOT)
-LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnomepilot2
-.endif
USE_BZIP2= yes
USE_GMAKE= yes
@@ -41,25 +34,34 @@ CONFIGURE_ARGS= --with-db3-libs=${DB3_WRKSRC} \
--enable-nss=no \
--enable-openssl=yes \
--with-krb5=/usr
+CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
+ LIBS="${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib
EVO_VERSION= 1.4
+PLIST_SUB= VERSION=${EVO_VERSION}
+PKGINSTALL= ${WRKDIR}/pkg-install
-.if defined(WITH_LDAP)
-CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
-.endif
+OPTIONS= PILOT "Enable Palm Pilot sync support" off \
+ LDAP "Enable LDAP support" on
-.if !defined(WITHOUT_PILOT)
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PILOT)
+LIB_DEPENDS+= gpilotdconduit.2:${PORTSDIR}/palm/gnomepilot2
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
--enable-pilot-conduits=yes
-PLIST_SUB= PILOT:=""
+PLIST_SUB+= PILOT:=""
.else
-PLIST_SUB= PILOT:="@comment "
+PLIST_SUB+= PILOT:="@comment "
.endif
-CONFIGURE_ENV= CPPFLAGS="-I${DB3_WRKSRC} -I${LOCALBASE}/include" \
- LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-PLIST_SUB+= VERSION=${EVO_VERSION}
-PKGINSTALL= ${WRKDIR}/pkg-install
+.if !defined(WITHOUT_LDAP)
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-openldap=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--with-openldap=no
+.endif
post-patch:
@${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} ${GREP} -l '<db.h>' | \
@@ -95,4 +97,4 @@ post-install:
@${FIND} ${PREFIX}/share/gnome/evolution/${EVO_VERSION}/default_user \
-type f | ${XARGS} ${CHMOD} u+w
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>