aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-01-25 01:09:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-01-25 01:09:31 +0000
commit1d89811657da07f0c102b7a6dad4abf5e5ddd867 (patch)
tree41d7eb30b3725a858692eaa4f2effbdb37b97286 /mail/evolution
parent32f883223f08e922cec4365c47dc3058dc685240 (diff)
Notes
Diffstat (limited to 'mail/evolution')
-rw-r--r--mail/evolution/Makefile1
-rw-r--r--mail/evolution/files/patch-camel_camel-lock-helper.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index 236d1a92a8da..780dedfa79ef 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 2.0.3
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.0
diff --git a/mail/evolution/files/patch-camel_camel-lock-helper.c b/mail/evolution/files/patch-camel_camel-lock-helper.c
new file mode 100644
index 000000000000..17bae50d1204
--- /dev/null
+++ b/mail/evolution/files/patch-camel_camel-lock-helper.c
@@ -0,0 +1,19 @@
+===================================================================
+RCS file: /cvs/gnome/evolution/camel/Attic/camel-lock-helper.c,v
+retrieving revision 1.5
+retrieving revision 1.5.74.1
+diff -u -r1.5 -r1.5.74.1
+--- camel/camel-lock-helper.c 2001/10/27 16:59:27 1.5
++++ camel/camel-lock-helper.c 2005/01/20 07:28:44 1.5.74.1
+@@ -360,8 +360,9 @@
+ switch(msg.id) {
+ case CAMEL_LOCK_HELPER_LOCK:
+ res = CAMEL_LOCK_HELPER_STATUS_NOMEM;
+- path = malloc(msg.data+1);
+- if (path != NULL) {
++ if (msg.data > 0xffff) {
++ res = CAMEL_LOCK_HELPER_STATUS_PROTOCOL;
++ } else if ((path = malloc(msg.data+1)) != NULL) {
+ res = CAMEL_LOCK_HELPER_STATUS_PROTOCOL;
+ len = read_n(STDIN_FILENO, path, msg.data);
+ if (len == msg.data) {