aboutsummaryrefslogtreecommitdiff
path: root/mail/evolution
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-27 00:30:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-27 00:30:21 +0000
commita22ea7b619ea1a23e54780a4936fa0474097ca0a (patch)
tree427c9b9ec50871367fcfa05b6a9ef5645c678a31 /mail/evolution
parent47695840417950f9e740f87925693b0ee61fd957 (diff)
downloadports-a22ea7b619ea1a23e54780a4936fa0474097ca0a.tar.gz
ports-a22ea7b619ea1a23e54780a4936fa0474097ca0a.zip
Notes
Diffstat (limited to 'mail/evolution')
-rw-r--r--mail/evolution/Makefile2
-rw-r--r--mail/evolution/files/patch-gpg-temp84
-rw-r--r--mail/evolution/pkg-comment1
3 files changed, 86 insertions, 1 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index d41620fc0753..625e8f08abb2 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://people.FreeBSD.org/~sobomax/:local
@@ -17,6 +18,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
+COMMENT= An integrated mail, calendar and address book distributed suite
LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf \
nss3.1:${PORTSDIR}/security/nss \
diff --git a/mail/evolution/files/patch-gpg-temp b/mail/evolution/files/patch-gpg-temp
new file mode 100644
index 000000000000..93871b48be15
--- /dev/null
+++ b/mail/evolution/files/patch-gpg-temp
@@ -0,0 +1,84 @@
+diff -u -r1.2.8.1 camel-mime-filter-canon.c
+--- camel/camel-mime-filter-canon.c 21 Jan 2003 03:07:05 -0000 1.2.8.1
++++ camel/camel-mime-filter-canon.c 26 Feb 2003 23:12:09 -0000
+@@ -26,6 +26,7 @@
+ #include <config.h>
+ #endif
+
++#include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>
+
+@@ -170,7 +171,7 @@
+ if (len)
+ filter(f, in, len, prespace, out, outlen, outprespace);
+
+- /* the data didn't contain an eol or was too short for "From ", we only need to check for "From" and add an eol */
++ /* the data didn't contain an eol or was too short for "From ", we only need to check for "From" */
+ if (f->backlen) {
+ inptr = (unsigned char *)f->backbuf;
+ inend = (unsigned char *)f->backbuf + f->backlen;
+@@ -195,20 +196,7 @@
+ while (o>starto && (o[-1] == ' ' || o[-1] == '\t' || o[-1]=='\r'))
+ o--;
+ }
+- /* check end of line canonicalisation */
+- if (o>starto) {
+- if (flags & CAMEL_MIME_FILTER_CANON_CRLF) {
+- if (o[-1] != '\r')
+- *o++ = '\r';
+- } else {
+- if (o[-1] == '\r')
+- o--;
+- }
+- }
+-
+- /* and always finish with an eol */
+- *o++ = '\n';
+-
++
+ *outlen = o - *out;
+
+ f->backlen = 0;
+diff -u -r1.24 camel-stream-filter.c
+--- camel/camel-stream-filter.c 19 Jul 2002 11:25:02 -0000 1.24
++++ camel/camel-stream-filter.c 26 Feb 2003 23:12:10 -0000
+@@ -19,11 +19,16 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
++
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
++
++#include <stdio.h>
+ #include <string.h>
+ #include "camel-stream-filter.h"
+
+ #define d(x)
+-/*#include <stdio.h>*/
+
+ /* use my malloc debugger? */
+ /*extern void g_check(void *mp);*/
+@@ -368,10 +373,18 @@
+ {
+ CamelStreamFilter *filter = (CamelStreamFilter *)stream;
+ struct _CamelStreamFilterPrivate *p = _PRIVATE(filter);
+-
++ struct _filter *f;
++
+ if (p->filteredlen > 0)
+ return FALSE;
+-
++
++ f = p->filters;
++ while (f) {
++ if (f->filter->backlen > 0)
++ return FALSE;
++ f = f->next;
++ }
++
+ return camel_stream_eos(filter->source);
+ }
+
diff --git a/mail/evolution/pkg-comment b/mail/evolution/pkg-comment
deleted file mode 100644
index 017eaee53071..000000000000
--- a/mail/evolution/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-An integrated mail, calendar and address book distributed suite