aboutsummaryrefslogtreecommitdiff
path: root/mail/exim-monitor/Makefile
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2001-08-27 13:19:14 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2001-08-27 13:19:14 +0000
commit38748d83219cb6916b6f5c4503f2e0d3a5bdd74b (patch)
treea276e92c254bdff6e03e0310ee35845fc60a9169 /mail/exim-monitor/Makefile
parent8188cfcbb16d7708fe00862685c8c4698f6a0947 (diff)
downloadports-38748d83219cb6916b6f5c4503f2e0d3a5bdd74b.tar.gz
ports-38748d83219cb6916b6f5c4503f2e0d3a5bdd74b.zip
Notes
Diffstat (limited to 'mail/exim-monitor/Makefile')
-rw-r--r--mail/exim-monitor/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/mail/exim-monitor/Makefile b/mail/exim-monitor/Makefile
new file mode 100644
index 000000000000..5128ff89dc0f
--- /dev/null
+++ b/mail/exim-monitor/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: exim-minitor
+# Date created: 27 August 2001
+# Whom: sheldonh@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= exim
+PORTVERSION= 3.33
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
+ http://www.exim.org/ftp/ \
+ ftp://ftp.is.co.za/networking/mail/transport/exim/
+
+MAINTAINER= sheldonh@FreeBSD.org
+
+USE_BZIP2= yes
+USE_PERL5= yes
+USE_XLIB= yes
+
+# This dependency is disabled, because it prevents package users from
+# using the exim-monitor package with any of the exim slave packages.
+#
+#RUN_DEPENDS= ${LOCALBASE}/sbin/exim:${PORTSDIR}/mail/exim
+
+MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+
+SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},'
+
+do-configure:
+ ${MKDIR} ${WRKSRC}/Local
+ ${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile
+ ${CP} ${WRKSRC}/exim_monitor/EDITME ${WRKSRC}/Local/eximon.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon.bin \
+ ${PREFIX}/sbin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon \
+ ${PREFIX}/sbin/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>