aboutsummaryrefslogtreecommitdiff
path: root/mail/exim-monitor/Makefile
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-04-28 23:11:10 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-04-28 23:11:10 +0000
commit4aea318324c747310abdbcecb3ec19bfd38af1aa (patch)
tree7ea5b214d64228188955d0ca13d48bacc0232a2a /mail/exim-monitor/Makefile
parent70b88ad66feae36d635e4d81a8b52635d8fa1db9 (diff)
downloadports-4aea318324c747310abdbcecb3ec19bfd38af1aa.tar.gz
ports-4aea318324c747310abdbcecb3ec19bfd38af1aa.zip
Notes
Diffstat (limited to 'mail/exim-monitor/Makefile')
-rw-r--r--mail/exim-monitor/Makefile36
1 files changed, 5 insertions, 31 deletions
diff --git a/mail/exim-monitor/Makefile b/mail/exim-monitor/Makefile
index 07c513e1afd1..b7ffd7ca62d3 100644
--- a/mail/exim-monitor/Makefile
+++ b/mail/exim-monitor/Makefile
@@ -5,44 +5,18 @@
# $FreeBSD$
#
-PORTNAME= exim-monitor
-PORTVERSION= ${EXIM_VERSION}
-CATEGORIES= mail
-MASTER_SITES= ${MASTER_SITE_EXIM}
-MASTER_SITE_SUBDIR= exim4
-DISTNAME= exim-${PORTVERSION}
-DIST_SUBDIR= exim
+PKGNAMESUFFIX= -monitor
-MAINTAINER= sheldonh@FreeBSD.org
COMMENT= The Exim monitor for the Exim MTA
-USE_BZIP2= yes
-USE_PERL5= yes
-USE_XLIB= yes
+MASTERDIR= ${.CURDIR}/../exim
+PKGDIR= ${.CURDIR}
-EXIM_VERSION= 4.20
+EXIMON_ONLY= yes
# This dependency is disabled, because it prevents package users from
# using the exim-monitor package with any of the exim slave packages.
#
#RUN_DEPENDS= ${LOCALBASE}/sbin/exim:${PORTSDIR}/mail/exim
-MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
-
-SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},'
-
-do-configure:
- ${MKDIR} ${WRKSRC}/Local
- ${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile
- ${CP} ${WRKSRC}/exim_monitor/EDITME ${WRKSRC}/Local/eximon.conf
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon.bin \
- ${PREFIX}/sbin/
- ${INSTALL_SCRIPT} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon \
- ${PREFIX}/sbin/
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"