aboutsummaryrefslogtreecommitdiff
path: root/mail/exim-old
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2001-07-10 10:47:29 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2001-07-10 10:47:29 +0000
commite1d536bdb8f678a01c258e811fe417cdbe0cd72e (patch)
tree8bc04d9fecac57fe8fab0b07839782ec3b32489c /mail/exim-old
parent4ac21daf7d498366ce62839ae363dcbdd55993a1 (diff)
downloadports-e1d536bdb8f678a01c258e811fe417cdbe0cd72e.tar.gz
ports-e1d536bdb8f678a01c258e811fe417cdbe0cd72e.zip
Notes
Diffstat (limited to 'mail/exim-old')
-rw-r--r--mail/exim-old/Makefile35
-rw-r--r--mail/exim-old/files/patch-src::daemon.c12
2 files changed, 35 insertions, 12 deletions
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index 647457df0bd3..a00321c119bf 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.31
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
@@ -15,17 +16,15 @@ DISTFILES= exim-3.31.tar.gz exim-texinfo-3.30.tar.gz
MAINTAINER= sheldonh@FreeBSD.org
+USE_PERL5= yes
+
+MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+
# If WITHOUT_X11 is not defined, the eximon monitor, which requires X,
# will be built. If you do not have XFree86 installed and you do not
# want to install it, define WITHOUT_X11 during the build. This will
# disable eximon, the Exim monitor.
-.if !defined(WITHOUT_X11)
-USE_XLIB= yes
-.endif
-
-USE_PERL5= yes
-
-MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+#WITHOUT_X11= yes
# Define WITH_TCP_WRAPPERS, WITH_LDAP, WITH_MYSQL, and WITH_PGSQL to
# link against libwrap, an LDAP library (see below), liblibmysqlclient
@@ -35,9 +34,11 @@ MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
#WITH_MYSQL= yes
#WITH_PGSQL= yes
-# Only define WITH_IPV6 on systems with IPv6 support compiled into the
-# kernel. Exim's IPv6 support is still experimental.
-#WITH_IPV6= yes
+# Define WITHOUT_IPV6 to exclude IPv6 support from the compiled exim
+# binary. Exim compiled with IPv6 support will still operate on
+# systems that do not have IPv6 kernel support, so this should not
+# be necessary.
+#WITHOUT_IPV6= yes
# If WITH_LDAP is defined, LDAP_LIB_TYPE must be either OPENLDAP1 or
# OPENLDAP2. UMICHIGAN is an alias for OPENLDAP1. Exim also supports
@@ -71,6 +72,16 @@ LDAP_LIB_TYPE?=OPENLDAP1
# You should not need to fiddle with anything below this point.
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400014
+WITHOUT_IPV6= yes
+.endif
+
SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},' \
-e 's,XX_BINOWN_XX,${BINOWN},'
.if !defined(USE_XLIB)
@@ -144,7 +155,7 @@ SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${PREFIX}/lib -lpq,' \
SEDLIST+= -e 's,XX_PGSQL_[^ ]*_XX,,'
.endif
-.if defined(WITH_IPV6)
+.if !defined(WITHOUT_IPV6)
SEDLIST+= -e 's,^\# HAVE_IPV6=,HAVE_IPV6=,'
.endif
@@ -189,4 +200,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/exim-old/files/patch-src::daemon.c b/mail/exim-old/files/patch-src::daemon.c
new file mode 100644
index 000000000000..1cfdf2b972ca
--- /dev/null
+++ b/mail/exim-old/files/patch-src::daemon.c
@@ -0,0 +1,12 @@
+--- src/daemon.c.orig Tue Jul 10 11:52:32 2001
++++ src/daemon.c Tue Jul 10 11:53:33 2001
+@@ -841,7 +841,8 @@
+
+ for (i = 9; i >= 0; i--)
+ {
+- if (bind(listen_sockets[sk], (struct sockaddr *)&sin, sizeof(sin)) < 0)
++ if (bind(listen_sockets[sk], (struct sockaddr *)&sin,
++ (ipv6_address) ? sizeof(sin.v6) : sizeof(sin.v4)) < 0)
+ {
+ char *msg = strerror(errno);
+ char *addr = (ipa->address[0] == 0)? "(any)" : ipa->address;