aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2001-11-02 17:11:14 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2001-11-02 17:11:14 +0000
commit34323bd7e010dbd9c534ddfa821dfcc48d54c7fe (patch)
treee8a1783aee2ffd9575a3b786890b2357988802ee /mail/exim
parentcd4c2a4e4b08f1a3a04fed1c6ec646310317fa5c (diff)
downloadports-34323bd7e010dbd9c534ddfa821dfcc48d54c7fe.tar.gz
ports-34323bd7e010dbd9c534ddfa821dfcc48d54c7fe.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src::exim.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index cd425afabe5d..9edb7afae006 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.33
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim/files/patch-src::exim.c b/mail/exim/files/patch-src::exim.c
index e84e06bcff84..c16f4a861e8e 100644
--- a/mail/exim/files/patch-src::exim.c
+++ b/mail/exim/files/patch-src::exim.c
@@ -10,3 +10,11 @@
(list_queue && queue_list_requires_admin) ||
(queue_interval >= 0 && prod_requires_admin))
{
+@@ -3462,6 +3463,7 @@
+ }
+
+ /* The loop will repeat if more is TRUE. */
++ while (waitpid(-1, NULL, WNOHANG) > 0);
+ }
+
+ exim_exit(EXIT_SUCCESS); /* Never returns */