aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2003-08-14 10:25:15 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2003-08-14 10:25:15 +0000
commit944ed68cfa6d823124404e91d68ac8e5729401e6 (patch)
tree7db635de9ccf399a0a08eb2a1cd582f607ef113f /mail/exim
parent832d6b991e4d5a2ec5d4d0e334a29cd29900fd8f (diff)
downloadports-944ed68cfa6d823124404e91d68ac8e5729401e6.tar.gz
ports-944ed68cfa6d823124404e91d68ac8e5729401e6.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile41
-rw-r--r--mail/exim/distinfo5
-rw-r--r--mail/exim/files/patch-OS::Makefile-FreeBSD15
-rw-r--r--mail/exim/files/patch-src::host.c13
-rw-r--r--mail/exim/pkg-plist1
5 files changed, 25 insertions, 50 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 0a87cf7576e8..2ad56537b395 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,37 +7,32 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
-PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_EXIM} \
- http://duncanthrax.net/%SUBDIR%/:exiscan,exiscan_acl
-MASTER_SITE_SUBDIR= exim4 exiscan/:exiscan exiscan-acl/:exiscan_acl
+ http://duncanthrax.net/%SUBDIR%/:exiscan_acl
+MASTER_SITE_SUBDIR= exim4 exiscan-acl/:exiscan_acl
DISTFILES= exim-${EXIM_VERSION}${EXTRACT_SUFX} \
exim-texinfo-${EXIM_DOCVERSION}${EXTRACT_SUFX}
-.if defined(WITH_EXISCAN_ACL)
+.if !defined(WITHOUT_EXISCAN)
DISTFILES+= exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2:exiscan_acl
-.elif !defined(WITHOUT_EXISCAN)
-DISTFILES+= exiscan-${EXISCAN_VERSION}${EXTRACT_SUFX}:exiscan
.endif
DIST_SUBDIR= exim
EXTRACT_ONLY= exim-${EXIM_VERSION}${EXTRACT_SUFX} \
exim-texinfo-${EXIM_DOCVERSION}${EXTRACT_SUFX}
-.if !defined(WITH_EXISCAN_ACL) && !defined(WITHOUT_EXISCAN)
-EXTRACT_ONLY+= exiscan-${EXISCAN_VERSION}${EXTRACT_SUFX}
-.endif
MAINTAINER= sheldonh@FreeBSD.org
COMMENT= High performance MTA for Unix systems on the Internet
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
USE_BZIP2= yes
USE_PERL5= yes
MAN8= exim.8
-EXIM_VERSION= 4.20
+EXIM_VERSION= 4.21
EXIM_DOCVERSION= 4.20
EXISCAN_ACL_VERSION= ${EXIM_VERSION}-10
-EXISCAN_VERSION= ${EXIM_VERSION}-26
PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
@@ -45,7 +40,7 @@ PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
PKGMESSAGE= ${WRKDIR}/POST-INSTALL-NOTES
.endif
-MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
+MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH} LOCALBASE=${LOCALBASE}
POSTGRESQL_PORT?= databases/postgresql7
@@ -54,10 +49,8 @@ POSTGRESQL_PORT?= databases/postgresql7
# XFree86 to be installed if it is not present.
#WITH_EXIMON= yes
-# If WITH_EXISCAN_ACL is defined, exim will be build with the newer
-# exiscan acl support. Otherwise if WITHOUT_EXISCAN is defined,
-# exim will be built without exiscan email content scanner support.
-#WITH_EXISCAN_ACL= yes
+# If WITHOUT_EXISCAN is defined, exim will be built without exiscan
+# email content scanner support.
#WITHOUT_EXISCAN= yes
# Define WITH_TCP_WRAPPERS, WITH_MYSQL, and WITH_PGSQL to link against
@@ -141,17 +134,11 @@ EXTRA_PATCHES+= `${FIND} ${PATCHDIR} -name 'wishlist-*.patch'`
PORTDOC_FILES= Exim3.upgrade Exim4.upgrade OptionLists.txt README \
dbm.discuss.txt filter.txt pcrepattern.txt pcretest.txt \
spec.txt
-.if defined(WITH_EXISCAN_ACL)
+.if !defined(WITHOUT_EXISCAN)
PORTDOC_FILES+= exiscan-acl-examples.txt exiscan-acl-spec.txt
PLIST_SUB+= EXISCAN_ACL=""
-PLIST_SUB+= EXISCAN="@comment "
-.elif !defined(WITHOUT_EXISCAN)
-PORTDOC_FILES+= exiscan-readme.txt
-PLIST_SUB+= EXISCAN_ACL="@comment "
-PLIST_SUB+= EXISCAN=""
.else
PLIST_SUB+= EXISCAN_ACL="@comment "
-PLIST_SUB+= EXISCAN="@comment "
.endif
.if ${OSVERSION} < 400014
@@ -331,17 +318,11 @@ pre-everything::
.endif
post-patch:
-.if defined(WITH_EXISCAN_ACL)
+.if !defined(WITHOUT_EXISCAN)
${BZCAT} ${DISTDIR}/${DIST_SUBDIR}/exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2 \
| ${PATCH} -d ${WRKSRC} -p1 > ${WRKDIR}/patch-exiscan-acl.log 2>&1
@${CAT} ${FILESDIR}/POST-INSTALL-NOTES.exiscan-acl \
${FILESDIR}/POST-INSTALL-NOTES > ${WRKDIR}/POST-INSTALL-NOTES
-.elif !defined(WITHOUT_EXISCAN)
- cd ${WRKSRC} && ${PATCH} -p1 \
- < ../exiscan-${EXISCAN_VERSION}/exiscan-${EXISCAN_VERSION}.patch \
- > ${WRKDIR}/patch-exiscan.log 2>&1
- @${CAT} ${FILESDIR}/POST-INSTALL-NOTES.exiscan \
- ${FILESDIR}/POST-INSTALL-NOTES > ${WRKDIR}/POST-INSTALL-NOTES
.else
@${CAT} ${FILESDIR}/POST-INSTALL-NOTES > ${WRKDIR}/POST-INSTALL-NOTES
.endif
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 32d7ccd63e5c..2bfabcb5044d 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,4 +1,3 @@
-MD5 (exim/exim-4.20.tar.bz2) = 90f9e876b60d00c0a5dd53ece7c85338
+MD5 (exim/exim-4.21.tar.bz2) = 16b1290e4c289c7d70294ca447b0a3bc
MD5 (exim/exim-texinfo-4.20.tar.bz2) = debc6d3fdd88fd6d9c646ca0495fa92d
-MD5 (exim/exiscan-4.20-26.tar.bz2) = a3ad2a486b52cc32990888a00f8fabca
-MD5 (exim/exiscan-acl-4.20-10.patch.bz2) = e0ea3a68600047832ddadac6684242f8
+MD5 (exim/exiscan-acl-4.21-10.patch.bz2) = b22d3ed3e132ea11069b89ae4269f493
diff --git a/mail/exim/files/patch-OS::Makefile-FreeBSD b/mail/exim/files/patch-OS::Makefile-FreeBSD
index 58f6355e13d8..59769cfb40f7 100644
--- a/mail/exim/files/patch-OS::Makefile-FreeBSD
+++ b/mail/exim/files/patch-OS::Makefile-FreeBSD
@@ -1,10 +1,19 @@
---- OS/Makefile-FreeBSD.orig Mon Jun 11 12:04:05 2001
-+++ OS/Makefile-FreeBSD Mon Jun 11 12:04:33 2001
-@@ -5,6 +5,7 @@
+--- OS/Makefile-FreeBSD.orig Tue Aug 12 17:39:51 2003
++++ OS/Makefile-FreeBSD Thu Aug 14 12:10:46 2003
+@@ -5,12 +5,16 @@
PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
CHOWN_COMMAND=/usr/sbin/chown
+STRIP_COMMAND=/usr/bin/strip
+ HAVE_ICONV=yes
HAVE_SA_LEN=YES
+ # crypt() is in a separate library
+ LIBS=-lcrypt
++
++# iconv() is in a separate 4rd party library
++LFLAGS+=-liconv -L${LOCALBASE}/lib
+
+ # FreeBSD always ships with Berkeley DB
+ USE_DB=yes
diff --git a/mail/exim/files/patch-src::host.c b/mail/exim/files/patch-src::host.c
deleted file mode 100644
index b6e1e98e4207..000000000000
--- a/mail/exim/files/patch-src::host.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/host.c.orig Mon May 12 15:39:19 2003
-+++ src/host.c Fri Jun 20 14:54:12 2003
-@@ -817,8 +817,8 @@
- int rc;
- uschar *save = deliver_domain;
- deliver_domain = h->name; /* set $domain */
-- rc = match_isinlist(string_copylc(h->name), &hosts_treat_as_local, 0, NULL,
-- NULL, MCL_DOMAIN, TRUE, NULL);
-+ rc = match_isinlist(string_copylc(h->name), &hosts_treat_as_local, 0,
-+ &domainlist_anchor, NULL, MCL_DOMAIN, TRUE, NULL);
- deliver_domain = save;
- if (rc == OK) goto FOUND_LOCAL;
- }
diff --git a/mail/exim/pkg-plist b/mail/exim/pkg-plist
index e647573cd7fc..f8403431c744 100644
--- a/mail/exim/pkg-plist
+++ b/mail/exim/pkg-plist
@@ -29,7 +29,6 @@ sbin/exiqsumm
%%PORTDOCS%%share/doc/exim/spec.txt
%%PORTDOCS%%%%EXISCAN_ACL%%share/doc/exim/exiscan-acl-examples.txt
%%PORTDOCS%%%%EXISCAN_ACL%%share/doc/exim/exiscan-acl-spec.txt
-%%PORTDOCS%%%%EXISCAN%%share/doc/exim/exiscan-readme.txt
@unexec install-info --delete %D/info/exim.info %D/info/dir
@unexec install-info --delete %D/info/exim_filter.info %D/info/dir
@exec install-info --section="Exim" --entry "* Exim Specification: (exim). Exim manual" %D/info/exim.info %D/info/dir