aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2000-12-21 08:56:52 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2000-12-21 08:56:52 +0000
commita818454de9ab5f1fbfe2a3ff5b9ee3bd93d7625b (patch)
tree841b511c41c433d75ed6de5935140e8ea637a2d8 /mail/exim
parent272b15896ef068d764d2587bc0b8d88044934c00 (diff)
downloadports-a818454de9ab5f1fbfe2a3ff5b9ee3bd93d7625b.tar.gz
ports-a818454de9ab5f1fbfe2a3ff5b9ee3bd93d7625b.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile10
-rw-r--r--mail/exim/files/Makefile56
2 files changed, 58 insertions, 8 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 6ea207a83d49..50c09800ce65 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -33,6 +33,9 @@ MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
#WITH_PAM= yes
#WITH_PGSQL= yes
+# Link against OpenSSL in the base system for STARTTLS support.
+#WITH_TLS= yes
+
# Enable the embedded Perl interpreter, allowing Perl subroutines to be
# called during string expansion.
WITH_PERL= yes
@@ -59,6 +62,13 @@ SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},' \
SEDLIST+= -e 's,^EXIM_MONITOR,\#EXIM_MONITOR,'
.endif
+.if defined(WITH_TLS)
+SEDLIST+= -e 's,XX_TLS_LIBS_XX,-lssl -lcrypto,' \
+ -e 's,^\# SUPPORT_TLS,SUPPORT_TLS,'
+.else
+SEDLIST+= -e 's,^TLS_LIBS,\#TLS_LIBS,'
+.endif
+
.if !defined(WITH_PERL)
SEDLIST+= -e 's,^EXIM_PERL,\#EXIM_PERL,'
.endif
diff --git a/mail/exim/files/Makefile b/mail/exim/files/Makefile
index 63021a5cd58a..4ca6f7eba250 100644
--- a/mail/exim/files/Makefile
+++ b/mail/exim/files/Makefile
@@ -356,19 +356,21 @@ LOOKUP_LIBS=XX_MYSQL_LIBS_XX XX_PGSQL_LIBS_XX XX_LDAP_LIBS_XX
# If you have set LDAP=yes, you should set LDAP_LIB_TYPE to indicate which LDAP
# library you have. Unfortunately, though most of their functions are the
-# same, there is a difference in error handling. Currently Exim knows about
-# three LDAP libraries: the one from the University of Michigan, the Netscape
-# SDK library, and the library that comes with Solaris 7. Uncomment whichever
-# of these you are using.
+# same, there are minor differences. Currently Exim knows about four LDAP
+# libraries: the one from the University of Michigan (also known as OpenLDAP 1),
+# OpenLDAP 2, the Netscape SDK library, and the library that comes with Solaris
+# 7 onwards. Uncomment whichever of these you are using.
# LDAP_LIB_TYPE=UMICHIGAN
+# LDAP_LIB_TYPE=OPENLDAP1
+# LDAP_LIB_TYPE=OPENLDAP2
# LDAP_LIB_TYPE=NETSCAPE
-# LDAP_LIB_TYPE=SOLARIS7
+# LDAP_LIB_TYPE=SOLARIS
LDAP_LIB_TYPE=XX_LDAP_TYPE_XX
-# If you don't set any of these, Exim applies a heuristic to distinguish the
-# University of Michigan library, but it cannot distinguish between the other
-# two.
+# If you don't set any of these, Exim assumes the original University of
+# Michigan (OpenLDAP 1) library.
+
# The TESTDB lookup is for performing tests on the handling of lookup
# results, and is not useful for general running. It should be included
@@ -518,6 +520,39 @@ SUPPORT_PAM=yes
# GNU/Linux -ldl is also needed.
+# Exim can be built to support the SMTP STARTTLS command, which implements
+# Transport Layer Security using SSL (Secure Sockets Layer). To do this, you
+# must install the OpenSSL library package. Exim contains no cryptographic
+# code of its own. Uncomment the following lines if you want to build Exim
+# with TLS support.
+
+# SUPPORT_TLS=yes
+TLS_LIBS=XX_TLS_LIBS_XX
+
+# If you are running Exim as a server, note that just building it with TLS
+# support is not usually all you need to do. You normally need to set up a
+# suitable certificate, and tell Exim about it by means of the tls_certificate
+# and tls_privatekey runtime options. You also need to set tls_advertise_hosts
+# to specify which hosts TLS support is advertised to. On the other hand,
+# if you are running Exim only as a client, building it with TLS support
+# is all you need to do.
+
+# Additional libraries and include files are required for OpenSSL. The TLS_LIBS
+# setting above assumes that the libraries are installed with all your other
+# libraries. If they are in a special directory, you may need something like
+
+# TLS_LIBS=-L/usr/local/openssl/lib -lssl -lcrypto
+
+# TLS_LIBS is included only on the command for linking Exim itself, not on any
+# auxiliary programs. If the include files are not in a standard place, you can
+# set TLS_INCLUDE to specify where they are:
+
+# TLS_INCLUDE=-I/usr/local/openssl/include/
+
+# You don't need to set TLS_INCLUDE if the relevant directories are already
+# specified in INCLUDE.
+
+
# Included transports: These variables determine which individual transport
# drivers are included in the Exim binary. There are no defaults; those that
# are wanted must be defined here by setting the appropriate variables to the
@@ -531,6 +566,11 @@ TRANSPORT_AUTOREPLY=yes
TRANSPORT_PIPE=yes
TRANSPORT_SMTP=yes
+# This one is special-purpose, and commonly not required, so do not include
+# it by default.
+
+# TRANSPORT_LMTP=yes
+
# TCP wrappers: If you want to use tcpwrappers from within Exim, uncomment
# this setting. See the manual section entitled "Use of tcpwrappers" in the