aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-01-13 13:45:51 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-01-13 13:45:51 +0000
commit3e761a50dd32ab30fd5edc6bd8bc863d4b2ad8ea (patch)
tree57ef8ebbc143a5d0c967dc5f928c21296170b0db /mail/exim
parent82572ff65caeab86f19a2b8a41f0f6fb7c4e1601 (diff)
downloadports-3e761a50dd32ab30fd5edc6bd8bc863d4b2ad8ea.tar.gz
ports-3e761a50dd32ab30fd5edc6bd8bc863d4b2ad8ea.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile29
-rw-r--r--mail/exim/distinfo4
-rw-r--r--mail/exim/files/patch-src__mime.c52
-rw-r--r--mail/exim/options9
4 files changed, 27 insertions, 67 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index bd5d7195b845..b05fa9bcb7ab 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION?= 2
+PORTREVISION?= 0
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_EXIM:S/$/:exim/}
MASTER_SITE_SUBDIR= exim4/:exim
@@ -65,16 +65,23 @@ XCLIENT_EXTRA_PATCHES= ${FILESDIR}/extra-patch-xclient
# OCSP is supported for openssl only
.if ${PORT_OPTIONS:MOCSP}
.if ! ${PORT_OPTIONS:MTLS}
-IGNORE= You cannot enable OCSP stapling without TLS support
+IGNORE= you cannot enable OCSP stapling without TLS support
.elif ${PORT_OPTIONS:MGNUTLS}
-IGNORE= You cannot enable OCSP stapling with gnutls
+IGNORE= you cannot enable OCSP stapling with gnutls
.endif
.endif
# DMARC implies SPF
.if ${PORT_OPTIONS:MDMARC}
.if ! ${PORT_OPTIONS:MSPF} || ! ${PORT_OPTIONS:MDKIM}
-IGNORE= You cannot enable DMARC without SPF and DKIM support
+IGNORE= you cannot enable DMARC without SPF and DKIM support
+.endif
+.endif
+
+# DANE implies DNSSEC
+.if ${PORT_OPTIONS:MDANE}
+.if ! ${PORT_OPTIONS:MDNSSEC}
+IGNORE= you cannot enable DANE without DNSSEC support
.endif
.endif
@@ -85,7 +92,7 @@ MASTER_SITE_SUBDIR+= sa-exim/:sa_exim
DISTFILES+= sa-exim-${SA_EXIM_VERSION}.tar.gz:sa_exim
.endif
-EXIM_VERSION= 4.84
+EXIM_VERSION= 4.85
SA_EXIM_VERSION=4.2
EXIM_INSTALL_ARG+= "-no_chown" "-no_symlink"
@@ -201,6 +208,14 @@ SEDLIST+= -e 's,^\# (EXPERIMENTAL_CERTNAMES=),\1,'
SEDLIST+= -e 's,^\# (EXPERIMENTAL_DSN=),\1,'
.endif
+.if ${PORT_OPTIONS:MDANE}
+SEDLIST+= -e 's,^\# (EXPERIMENTAL_DANE=),\1,'
+.endif
+
+.if ${PORT_OPTIONS:MEVENT}
+SEDLIST+= -e 's,^\# (EXPERIMENTAL_EVENT=),\1,'
+.endif
+
.if !${PORT_OPTIONS:MPRDR}
SEDLIST+= -e 's,^\# (DISABLE_PRDR=),\1,'
.endif
@@ -433,10 +448,6 @@ SEDLIST+= -e 's,XX_SPF_FLAGS_XX,,' \
.endif
.if ${PORT_OPTIONS:MSRS}
-LIB_DEPENDS+= libsrs2.so:${PORTSDIR}/mail/libsrs2
-SEDLIST+= -e 's,XX_SRS_FLAGS_XX,-DSRS,' \
- -e 's,XX_SRS_LIBS_XX,-L${LOCALBASE}/lib -lsrs2,'
-.elif ${PORT_OPTIONS:MSRS_ALT}
LIB_DEPENDS+= libsrs_alt.so:${PORTSDIR}/mail/libsrs_alt
SEDLIST+= -e 's,XX_SRS_FLAGS_XX,-DEXPERIMENTAL_SRS,' \
-e 's,XX_SRS_LIBS_XX,-L${LOCALBASE}/lib -lsrs_alt,'
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 90125087e9cc..85b8ed35af52 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,4 +1,4 @@
-SHA256 (exim/exim-4.84.tar.bz2) = 78ea22be87fb6df880e7fd482f3bec9ef6ceca0c9dedd50f8a26cae0b38b9e9c
-SIZE (exim/exim-4.84.tar.bz2) = 1761790
+SHA256 (exim/exim-4.85.tar.bz2) = 13211f2bbc5400d095a9b4be075eb1347e0d98676fdfe4be8a3b4d56281daaa4
+SIZE (exim/exim-4.85.tar.bz2) = 1784150
SHA256 (exim/sa-exim-4.2.tar.gz) = 72e0a735547f18b05785e6c58a71d24623858f0f5234a5dc0e24cb453999e99a
SIZE (exim/sa-exim-4.2.tar.gz) = 66575
diff --git a/mail/exim/files/patch-src__mime.c b/mail/exim/files/patch-src__mime.c
deleted file mode 100644
index 4eb3bc9421f2..000000000000
--- a/mail/exim/files/patch-src__mime.c
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -urN ../exim-4.84.orig/src/mime.c ../exim-4.84/src/mime.c
---- ../exim-4.84.orig/src/mime.c 2014-08-09 15:44:29.000000000 +0300
-+++ ../exim-4.84/src/mime.c 2014-11-12 02:36:21.000000000 +0200
-@@ -620,12 +620,18 @@
- else
- param_value = string_cat(param_value, &size, &ptr, q++, 1);
- }
-- param_value[ptr++] = '\0';
-- param_value_len = ptr;
--
-- param_value = rfc2047_decode(param_value, check_rfc2047_length, NULL, 32, &param_value_len, &q);
-- debug_printf("Found %s MIME parameter in %s header, value is '%s'\n", mp->name, mime_header_list[i].name, param_value);
-- *((uschar **)(mp->value)) = param_value;
-+ if (param_value)
-+ {
-+ param_value[ptr++] = '\0';
-+ param_value_len = ptr;
-+
-+ param_value = rfc2047_decode(param_value,
-+ check_rfc2047_length, NULL, 32, &param_value_len, &q);
-+ debug_printf("Found %s MIME parameter in %s header, "
-+ "value is '%s'\n", mp->name, mime_header_list[i].name,
-+ param_value);
-+ }
-+ *mp->value = param_value;
- p += (mp->namelen + param_value_len + 1);
- goto NEXT_PARAM_SEARCH;
- }
-diff -urN ../exim-4.84.orig/src/mime.h ../exim-4.84/src/mime.h
---- ../exim-4.84.orig/src/mime.h 2014-08-09 15:44:29.000000000 +0300
-+++ ../exim-4.84/src/mime.h 2014-11-12 02:36:13.000000000 +0200
-@@ -40,15 +40,15 @@
-
-
- typedef struct mime_parameter {
-- uschar *name;
-- int namelen;
-- void *value;
-+ uschar * name;
-+ int namelen;
-+ uschar ** value;
- } mime_parameter;
-
- static mime_parameter mime_parameter_list[] = {
-- { US"name=", 5, &mime_filename },
-+ { US"name=", 5, &mime_filename },
- { US"filename=", 9, &mime_filename },
-- { US"charset=", 8, &mime_charset },
-+ { US"charset=", 8, &mime_charset },
- { US"boundary=", 9, &mime_boundary }
- };
-
diff --git a/mail/exim/options b/mail/exim/options
index 41389a16d759..d6053322c37d 100644
--- a/mail/exim/options
+++ b/mail/exim/options
@@ -52,7 +52,7 @@ OPTIONS_RADIO_TLS= TLS GNUTLS
TLS_DESC= TLS support
OPTIONS_RADIO_LS= SA_EXIM
LS_DESC= Local scan patch
-OPTIONS_RADIO_SRSR= SRS SRS_ALT
+OPTIONS_RADIO_SRSR= SRS
SRSR_DESC= Sender Rewriting Scheme
OPTIONS_RADIO= TLS LS SRSR
@@ -62,7 +62,7 @@ OPTIONS_GROUP_LOOKUP= CDB BDB DNSDB DSEARCH LSEARCH MYSQL NIS OPENLDAP PGSQL RED
LOOKUP_DESC= Lookup support
OPTIONS_GROUP_STORAGE= MAILDIR MAILSTORE MBX
STORAGE_DESC= Supported storage formats
-OPTIONS_GROUP_EXPERIMENTAL= CERTNAMES DCC DMARC DSN PROXY SPF
+OPTIONS_GROUP_EXPERIMENTAL= CERTNAMES DANE DCC DMARC DSN EVENT PROXY SPF
EXPERIMENTAL_DESC= Experimental options
OPTIONS_GROUP= AUTH LOOKUP STORAGE EXPERIMENTAL
@@ -74,11 +74,11 @@ AUTH_RADIUS_DESC= Enable radius (RFC 2865) authentication
AUTH_SASL_DESC= Enable use of Cyrus SASL auth library
AUTH_SPA_DESC= Enable Secure Password Authentication
CERTNAMES_DESC= Check certiticates ownership
-DSN_DESC= Enable Delivery Status Notifications
BDB_DESC= Enable Berkeley DB lookups
CDB_DESC= Enable CDB-style lookups
CONTENT_SCAN_DESC= Enable exiscan email content scanner
DAEMON_DESC= Install scripts to run as a daemon
+DANE_DESC= Enable experimental DANE support
DCC_DESC= Enable DCC at ACL support via dccifd
DISABLE_D_OPT_DESC= Disable macros overrides using option -D
DKIM_DESC= Enable support for DKIM
@@ -86,7 +86,9 @@ DMARC_DESC= Enable DMARC support
DNSDB_DESC= Enable DNS-style lookups
DNSSEC_DESC= Enable DNSSEC validation
DSEARCH_DESC= Enable directory-list lookups
+DSN_DESC= Enable Delivery Status Notifications
EMBEDDED_PERL_DESC= Enable embedded Perl interpreter
+EVENT_DESC= Messages events support (TPDA namely)
EXIMON_DESC= Build eximon monitor (requires X libraries)
ICONV_DESC= Enable header charset conversion
LISTMATCH_RHS_DESC= Enable pre-4.77 behaviour for match_*
@@ -112,7 +114,6 @@ SA_EXIM_DESC= Build with Spamassassin local scan
SPF_DESC= Enable Sender Policy Framework checking
SQLITE_DESC= Enable SQLite lookups
SRS_DESC= Enable Sender Rewriting Scheme
-SRS_ALT_DESC= Enable alternative Sender Rewriting Scheme
SUID_DESC= Install the exim binary suid root
TCP_WRAPPERS_DESC= Enable /etc/hosts.allow access control
GNUTLS_DESC= Use GnuTLS instead of OpenSSL for TLS