aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>1999-08-03 17:01:39 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>1999-08-03 17:01:39 +0000
commitd9f7575c6f6a92fe0763b3a29482d2c29c00cb6a (patch)
tree4bf8ae8f9aa39e8bffeffb22d8665669d7b49db2 /mail/exim
parent80f4fcbc06b8056eff5fbac83e04e70baba6b3f5 (diff)
downloadports-d9f7575c6f6a92fe0763b3a29482d2c29c00cb6a.tar.gz
ports-d9f7575c6f6a92fe0763b3a29482d2c29c00cb6a.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile64
-rw-r--r--mail/exim/distinfo2
-rw-r--r--mail/exim/files/Makefile187
-rw-r--r--mail/exim/files/configure.default164
-rw-r--r--mail/exim/files/patch-aa20
5 files changed, 284 insertions, 153 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 030538920d15..2c4c9f2c8a8a 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,43 +3,72 @@
# Date created: 23 June 1996
# Whom: markm@FreeBSD.ORG
#
-# $Id: Makefile,v 1.33 1999/06/17 08:53:10 sheldonh Exp $
+# $Id: Makefile,v 1.34 1999/06/21 11:07:07 sheldonh Exp $
#
-DISTNAME= exim-3.02
+DISTNAME= exim-3.03
CATEGORIES= mail
MASTER_SITES= ftp://ftp.cus.cam.ac.uk/pub/software/programs/exim/ \
ftp://ftp.quite.net/pub/exim/ \
http://www.exim.org/ftp/ \
ftp://ftp.is.co.za/networking/mail/transport/exim/
-DISTFILES= exim-3.02.tar.gz exim-texinfo-3.00.tar.gz
+DISTFILES= exim-3.03.tar.gz exim-texinfo-3.00.tar.gz
MAINTAINER= sheldonh@FreeBSD.org
# If USE_XLIB is defined, the eximon monitor, which requires X, will be
-# built.
+# built. Comment it out unless you have or want XFree86 installed!
USE_XLIB= YES
USE_PERL5= YES
MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
-do-configure:
- ${MKDIR} ${WRKSRC}/Local
-.if defined(USE_XLIB) && ${USE_XLIB} == YES
- ${SED} -e "s#XX_PREFIX_XX#${PREFIX}#" \
- < ${FILESDIR}/Makefile \
- > ${WRKSRC}/Local/Makefile
+# Uncomment the USE_LDAP and USE_MYSQL definitions to link against libldap
+# and libmysqlclient respectively:
+#USE_LDAP= YES
+#USE_MYSQL= YES
+
+# If USE_LDAP==YES then LDAP_LIB_TYPE should be one of UMICHIGAN, NETSCAPE or
+# SOLARIS7:
+LDAP_LIB_TYPE= UMICHIGAN
+
+# You should not need to fiddle with anything below this point.
+
+SEDLIST= -e 's,XX_PREFIX_XX,${PREFIX},' \
+ -e 's,XX_BINOWN_XX,${BINOWN},'
+.if !defined(USE_XLIB) || ${USE_XLIB} != YES
+SEDLIST+= -e 's/^EXIM_MONITOR/\#EXIM_MONITOR/'
+.endif
+
+.if defined(USE_LDAP) && ${USE_LDAP} == YES
+SEDLIST+= -e 's,XX_LDAP_LIBS_XX,-L${PREFIX}/lib -lber -lldap,' \
+ -e 's,XX_LDAP_INCLUDE_XX,-I${PREFIX}/include,' \
+ -e 's,XX_LDAP_TYPE_XX,${LDAP_LIB_TYPE},'
.else
- ${SED} -e "s#XX_PREFIX_XX#${PREFIX}#" \
- -e "s/^EXIM_MONITOR/#EXIM_MONITOR/" \
- < ${FILESDIR}/Makefile \
- > ${WRKSRC}/Local/Makefile
+SEDLIST+= -e 's,XX_LDAP_[^ ]*_XX,,' \
+ -e 's,^LDAP_LIB_TYPE,\#LDAP_LIB_TYPE,'
.endif
+.if defined(USE_MYSQL) && ${USE_MYSQL} == YES
+SEDLIST+= -e 's,XX_MYSQL_LIBS_XX,-L${PREFIX}/lib/mysql -lmysqlclient,' \
+ -e 's,XX_MYSQL_INCLUDE_XX,-I${PREFIX}/include/mysql,'
+.else
+SEDLIST+= -e 's,XX_MYSQL_[^ ]*_XX,,'
+.endif
+
+.if ( !defined(USE_LDAP) || ${USE_LDAP} != YES ) && \
+ ( !defined(USE_MYSQL) || ${USE_MYSQL} != YES )
+SEDLIST+= -e 's/^LOOKUP_LIBS/\#LOOKUP_LIBS/' \
+ -e 's/^LOOKUP_INCLUDE/\#LOOKUP_INCLUDE/'
+.endif
+
+do-configure:
+ ${MKDIR} ${WRKSRC}/Local
+ ${SED} ${SEDLIST} < ${FILESDIR}/Makefile > ${WRKSRC}/Local/Makefile
+ ${SED} ${SEDLIST} < ${FILESDIR}/configure.default \
+ > ${WRKSRC}/src/configure.default
${CP} ${FILESDIR}/eximon.conf ${WRKSRC}/Local
- ${SED} -e "s#XX_BINOWN_XX#${BINOWN}#" \
- < ${FILESDIR}/configure.default > ${WRKSRC}/src/configure.default
cd ${WRKSRC}/doc && \
for i in ../../exim-texinfo-3.00/doc/* ; do \
ln -sf $$i ; \
@@ -51,4 +80,7 @@ post-build:
${TOUCH} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon.bin
${TOUCH} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon
+post-install:
+ @${CAT} ${PKGDIR}/MESSAGE
+
.include <bsd.port.mk>
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 2a06c2e24dd4..785fe37b8a97 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,2 +1,2 @@
-MD5 (exim-3.02.tar.gz) = c02fc43a8999c483a8aab24b6aad42cb
+MD5 (exim-3.03.tar.gz) = 71581c8e7bce2bf6bb859ad4ae21f15f
MD5 (exim-texinfo-3.00.tar.gz) = c0e8bde7adfbbf30de8f9a6889976d87
diff --git a/mail/exim/files/Makefile b/mail/exim/files/Makefile
index 8f112eafdb2c..08234c1c21d8 100644
--- a/mail/exim/files/Makefile
+++ b/mail/exim/files/Makefile
@@ -7,41 +7,53 @@
# be edited and then saved to a file called Local/Makefile before first running
# the make command.
-# Blank lines and lines starting with # are ignored. It is also permitted to
-# use the # character to add a comment to a setting, for example
-#
-# EXIM_GID=42 # the "mail" group
-#
-# Consequently, it is not possible to have the # character present in any
-# setting, but I can't think of any cases where this would be wanted.
-
-# Things that depend on the operating system have default settings in files
-# called OS/Makefile-<osname>. These can be overridden by creating files
-# called Local/Makefile-<osname>. In particular, the location of the X11
-# libraries is something that is quite variable between different versions
-# of the same operation system (and indeed there are different versions of
-# X11 as well, of course). The four settings concerned here are X11, XINCLUDE,
-# XLFLAGS (linking flags) and X11_LD_LIB (dynamic run-time library).
-
-# There are defaults in OS/Makefile-Default which are overridden for some
-# operating systems in the OS/Makefile-<osname> file. If these are not right
-# for you, put appropriate settings into a file called Local/Makefile-<osname>.
-# In all cases "<osname>" stands for the name of your operating system - look
-# at the names in the OS directory to see which names are recognized.
+# Things that depend on the operating system have default settings in
+# OS/Makefile-Default, but these are overridden for some OS by files called
+# called OS/Makefile-<osname>. You can further override these by creating files
+# called Local/Makefile-<osname>, where "<osname>" stands for the name of your
+# operating system - look at the names in the OS directory to see which names
+# are recognized.
+
+# However, if you are building Exim for a single OS only, you can place all the
+# configuration settings in the one file called Local/Makefile; only if you are
+# building for several OS from the same source files do you need to worry
+# about splitting off the OS-dependent settings into separate files.
+
+# One OS-specific thing is the C compiler; the overall default is gcc, but
+# some OS Makefiles specify cc. You can override anything that is set by
+# putting CC=whatever in your Local/Makefile.
+
+# NOTE: You should never need to edit any of the distributed Makefiles; all
+# overriding can be done in your Local/Makefile(s). This will make it easier
+# for you when the next release comes along.
+
+# The location of the X11 libraries is something else that is quite variable
+# even between different versions of the same operation system (and indeed
+# there are different versions of X11 as well, of course). The four settings
+# concerned here are X11, XINCLUDE, XLFLAGS (linking flags) and X11_LD_LIB
+# (dynamic run-time library).
# Another area of variability between systems is the type and location of the
# dbm library package. Exim has support for ndbm, gdbm, and Berkeley db. By
# default it assumes ndbm; this often works with gdbm or db, provided they
# are correctly installed, via their compatibility interfaces. However, Exim
# can also be configured to use the native calls for Berkeley db 1.85, and
-# this is defaulted for some operating systems. There are some locking actions
-# that can be varied by changing the configuration. The defaults are set in
+# this is defaulted for some operating systems. The defaults are set in
# OS/Makefile-Default, and can be changed by putting things into an OS-specific
# Makefile, or indeed into the main Local/Makefile if Exim is being compiled
# for a single OS only.
# See also the file doc/dbm.discuss.txt for discussion about different dbm
# libraries.
+
+# In Local/Makefiles blank lines and lines starting with # are ignored. It is
+# also permitted to use the # character to add a comment to a setting, for
+# example
+#
+# EXIM_GID=42 # the "mail" group
+#
+# Consequently, it is not possible to have the # character present in any
+# setting, but I can't think of any cases where this would be wanted.
###############################################################################
@@ -54,9 +66,10 @@
# The following commands live in different places in some OS. The OS-specific
# files should normally point to the right place, but they can be overridden
-# here if necessary. Perl is not necessary for running Exim, but there are
-# some Perl utilities for processing log files. If you haven't got Perl,
-# Exim will still build and run; you just won't be able to run those utilities.
+# here if necessary. Perl is not necessary for running Exim unless you set
+# EXIM_PERL (see below) to get it embedded, but there are some Perl utilities
+# for processing log files. If you haven't got Perl, Exim will still build and
+# run; you just won't be able to run those utilities.
# CHOWN_COMMAND=/usr/bin/chown
# CHGRP_COMMAND=/usr/bin/chgrp
@@ -78,11 +91,16 @@
# installed in this directory. There is no default for this variable built into
# the source files; it must be set in one of the local configuration files.
-BIN_DIRECTORY=XX_PREFIX_XX/sbin
+BIN_DIRECTORY=XX_PREFIX_XX/bin
-# The info directory: This variable defines where the exim info file will be
-# installed by "make install" or "exim_intall".
+# The default distribution of Exim contains only the plain text form of the
+# documentation. Other forms are available separately. If you want to install
+# the documentation in "info" format, first fetch the Texinfo documentation
+# sources from the ftp directory and unpack them, which should create files
+# with the extension "texinfo" in the doc directory. Then set INFO_DIRECTORY to
+# your info directory; "make install" will then build the info files and
+# install them there.
INFO_DIRECTORY=XX_PREFIX_XX/info
@@ -176,10 +194,11 @@ DIRECTOR_SMARTUSER=yes
EXICYCLOG_MAX=10
-# Running Exim not as root: A uid and gid for Exim can be specified here. These
-# are compiled into the binary, but can be changed by settings in the runtime
-# configuration file. If EXIM_UID is not defined, the default in the code is to
-# run as root unless specified otherwise at run time. Specifying 0 at
+# Running Exim without it being root all the time: A uid and gid for Exim can
+# be specified here. These values are compiled into the binary. It is possible
+# to change them by settings in the runtime configuration file, but setting
+# them here is preferred. If EXIM_UID is not defined, the default in the code
+# is to run as root unless specified otherwise at run time. Specifying 0 at
# run time has the effect of unsetting the values build into the binary.
# The settings here must be numeric; the run time file allows names to
@@ -205,12 +224,30 @@ EXICYCLOG_MAX=10
EXIM_MONITOR=eximon.bin
-# The maximum length of header line that Exim is prepared to process. There
-# is a limit in order to catch rogue mailers out there that might connect to
-# the SMTP port, start off a header line, and then just pump junk for ever
-# at it. The default is 8192.
+# Compiling in support for embedded Perl: If you want to be able to
+# use Perl code in Exim's string manipulation language and you have Perl
+# (version 5.004 or later) installed, set EXIM_PERL to perl.o.
+
+EXIM_PERL=perl.o
+
+
+# There are also three options which are used when compiling the Perl interface
+# and when linking with Perl. The default values for these are placed
+# automatically at the head of the Makefile by the script which builds it.
+# However, if you want to override them, you can do so here.
+
+# PERL_CC=
+# PERL_CCOPTS=
+# PERL_LIBS=
-# HEADER_MAXLENGTH=8192
+
+# This parameter sets the maximum length of the header portion of a message
+# that Exim is prepared to process. The default setting is one megabyte. There
+# is a limit in order to catch rogue mailers that might connect to your SMTP
+# port, start off a header line, and then just pump junk at it for ever. The
+# message_size_limit option would also catch this, but it may not be set.
+
+# HEADER_MAXSIZE=(1024*1024)
# The mode of the input directory: The input directory is where messages are
@@ -271,9 +308,37 @@ LOOKUP_LSEARCH=yes
# LOOKUP_CDB=yes
# LOOKUP_DNSDB=yes
# LOOKUP_LDAP=yes
+# LOOKUP_MYSQL=yes
# LOOKUP_NIS=yes
# LOOKUP_NISPLUS=yes
+# Additional libraries and include directories may be required for some
+# lookup styles, e.g. LDAP or MYSQL. LOOKUP_LIBS is included only on the
+# command for linking Exim itself, not on any auxiliary programs. You
+# don't need to set LOOKUP_INCLUDE if the relevant directories are already
+# specified in INCLUDE.
+
+# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include
+# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient
+LOOKUP_INCLUDE=XX_LDAP_INCLUDE_XX XX_MYSQL_INCLUDE_XX
+LOOKUP_LIBS=XX_LDAP_LIBS_XX XX_MYSQL_LIBS_XX
+
+# If you have set LDAP=yes, you should set LDAP_LIB_TYPE to indicate which LDAP
+# library you have. Unfortunately, though most of their functions are the
+# same, there is a difference in error handling. Currently Exim knows about
+# three LDAP libraries: the one from the University of Michigan, the Netscape
+# SDK library, and the library that comes with Solaris 7. Uncomment whichever
+# of these you are using.
+
+# LDAP_LIB_TYPE=UMICHIGAN
+# LDAP_LIB_TYPE=NETSCAPE
+# LDAP_LIB_TYPE=SOLARIS7
+LDAP_LIB_TYPE=XX_LDAP_TYPE_XX
+
+# If you don't set any of these, Exim applies a heuristic to distinguish the
+# University of Michigan library, but it cannot distinguish between the other
+# two.
+
# The TESTDB lookup is for performing tests on the handling of lookup
# results, and is not useful for general running. It should be included
# only when debugging the code of Exim.
@@ -302,7 +367,7 @@ LOOKUP_LSEARCH=yes
# the file name, allowing sites that run two separate daemons to distinguish
# them. Some installations may want something like this
-# PID_FILE_PATH=/var/lock/exim%s.pid
+# PID_FILE_PATH=/var/run/exim%s.pid
# If PID_FILE_PATH is not defined, Exim writes a file in its spool directory
# (see SPOOL_DIRECTORY below) with the name "exim-daemon.pid" for the standard
@@ -337,19 +402,18 @@ ROUTER_QUERYPROGRAM=yes
# The spool directory: This directory is where all the data for messages in
# transit is kept. There is no default in the source, so its location must be
-# defined in a local configuration file, or in the runtime configuration. It
-# is recommended that you define it here if it is a fixed path, especially if
-# you have not defined LOG_FILE_PATH. Log files are then written in a sub-
-# directory of the spool directory, and it is helpful to have this defined
-# right from the start of execution so that, for example, errors in reading
-# the runtime configuration file can be logged.
-
-# Exim creates the spool directory if it does not exist, using the mode
-# required for the sub-directory that it is trying to create at the time. If a
-# non-root uid and gid have been defined for Exim (either in this configuration
-# file, or by the runtime configuration options), then this directory and all
-# sub-directories and their files will be created with their owners and groups
-# set to Exim's uid and gid.
+# defined in a local compile-time configuration file, or in the runtime
+# configuration. It is recommended (but not mandatory) that you define it here
+# if it is a fixed path, especially if you have not defined LOG_FILE_PATH. Log
+# files are then written in a sub-directory of the spool directory, and it is
+# helpful to have this defined right from the start of execution so that, for
+# example, errors in reading the runtime configuration file can be logged.
+
+# Exim creates the spool directory if it does not exist. If a non-root uid and
+# gid have been defined for Exim (either in this configuration file, or by the
+# runtime configuration options), then this directory and all sub-directories
+# and their files will be created with their owners and groups set to Exim's
+# uid and gid.
# Many installations will want something like this:
SPOOL_DIRECTORY=/var/spool/exim
@@ -381,11 +445,12 @@ SPOOL_DIRECTORY=/var/spool/exim
# The appendfile transport can write messages as individual files in a number
-# of formats. The code for two specialist formats, maildir and mailstore,
-# is included only when requested by the following settings:
+# of formats. The code for three specialist formats, maildir, mailstore, and
+# MBX, is included only when requested by the following settings:
# SUPPORT_MAILDIR=yes
# SUPPORT_MAILSTORE=yes
+# SUPPORT_MBX=yes
# Included transports: These variables determine which individual transport
@@ -401,16 +466,12 @@ TRANSPORT_AUTOREPLY=yes
TRANSPORT_PIPE=yes
TRANSPORT_SMTP=yes
-# The Debug transport is special, and should be included only when low-level
-# debugging is being performed. In conjunction with the "debug_transport"
-# configuration option, it permits the subversion of all mail deliveries to
-# a given file.
-
-# TRANSPORT_DEBUG=
-
-# TCP wrappers:
+# TCP wrappers: If you want to use tcpwrappers from within Exim, uncomment
+# this setting. See the manual section entitled "Use of tcpwrappers" in the
+# chapter on building and installing Exim.
-# USE_TCP_WRAPPERS=yes
+USE_TCP_WRAPPERS=yes
+EXTRALIBS=-lwrap
# End of EDITME
diff --git a/mail/exim/files/configure.default b/mail/exim/files/configure.default
index 18de5f134080..2a3d30528ead 100644
--- a/mail/exim/files/configure.default
+++ b/mail/exim/files/configure.default
@@ -6,7 +6,10 @@
# This is a default configuration file which will operate correctly in
# uncomplicated installations. Please see the manual for a complete list
# of all the runtime configuration options that can be included in a
-# configuration file.
+# configuration file. There are many more than are mentioned here. The
+# manual is in the file doc/spec.txt in the Exim distribution as a plain
+# ASCII file. Other formats (PostScript, Texinfo, HTML, PDF) are available
+# from the Exim ftp sites. The manual is also online via the Exim web sites.
# This file is divided into several parts, all but the last of which are
@@ -20,14 +23,18 @@
# MAIN CONFIGURATION SETTINGS #
######################################################################
-# Specify your host's canonical name here. If this option is not set, the
+# Specify your host's canonical name here. This should normally be the fully
+# qualified "official" name of your host. If this option is not set, the
# uname() function is called to obtain the name.
# primary_hostname =
# Specify the domain you want to be added to all unqualified addresses
-# here. Unqualified addresses are accepted only from local callers by
+# here. An unqualified address is one that does not contain an "@" character
+# followed by a domain. For example, "caesar@rome.ex" is a fully qualified
+# address, but the string "caesar" (i.e. just a login name) is an unqualified
+# email address. Unqualified addresses are accepted only from local callers by
# default. See the receiver_unqualified_{hosts,nets} options if you want
# to permit unqualified addresses from remote sources. If this option is
# not set, the primary_hostname value is used for qualification.
@@ -71,7 +78,28 @@
exim_user = XX_BINOWN_XX
exim_group = mail
-never_users = root
+never_users = root : XX_BINOWN_XX
+
+
+# The use of your host as a mail relay by any host, including the local host
+# calling its own SMTP port, is locked out by default. If you want to permit
+# relaying from the local host, you should set
+#
+# host_accept_relay = localhost
+#
+# If you want to permit relaying through your host from certain hosts or IP
+# networks, you need to set the option appropriately, for example
+#
+# host_accept_relay = my.friends.host : 131.111.0.0/16
+#
+# If you are an MX backup or gateway of some kind for some domains, you must
+# set relay_domains to match those domains. This will allow any host to
+# relay through your host to those domains.
+#
+# See the section of the manual entitled "Control of relaying" for more
+# information.
+
+host_accept_relay = "127.0.0.1/32"
# The setting below causes Exim to do a reverse DNS lookup on all incoming
@@ -82,24 +110,47 @@ never_users = root
host_lookup = 0.0.0.0/0
-# Exim contains support for the Realtime Blocking List (RBL) that is being
-# maintained as part of the DNS. See http://maps.vix.com/rbl/ for background.
-# Uncommenting the following line will make Exim reject mail from any
-# host whose IP address is blacklisted in the RBL at maps.vix.com.
+# By default, Exim expects all envelope addresses to be fully qualified, that
+# is, they must contain both a local part and a domain. If you want to accept
+# unqualified addresses (just a local part) from certain hosts, you can specify
+# these hosts by setting one or both of
+#
+# receiver_unqualified_hosts =
+# sender_unqualified_hosts =
+#
+# to control sender and receiver addresses, respectively. When this is done,
+# unqualified addresses are qualified using the settings of qualify_domain
+# and/or qualify_recipient (see above).
-# rbl_domains = rbl.maps.vix.com
+# By default, Exim does not make any checks, other than syntactic ones, on
+# incoming addresses during the SMTP dialogue. This reduces delays in SMTP
+# transactions, but it does mean that you might accept messages with unknown
+# recipients, and/or bad senders.
-# The setting below locks out the use of your host as a mail relay by any
-# other host. If you want to permit relaying through your host from certain
-# hosts or IP networks, you need to vary this option and/or make use of the
-# other three options in the set sender_{host,net}_{accept,reject}_relay.
-# See the section of the manual entitled "Control of relaying" for more info.
-# Removing this setting altogether is not recommended, because there are many
-# unscrupulous people out there who will make use of open relays to try to
-# disguise the source of unsolicited bulk mail.
+# Uncomment this line if you want incoming recipient addresses to be verified
+# during the SMTP dialogue. Unknown recipients are then rejected at this stage,
+# and the generation of a failure message is the job of the sending host.
-host_accept_relay = "127.0.0.1/32"
+# receiver_verify
+
+# Uncomment this line if you want incoming sender addresses (return-paths) to
+# be verified during the SMTP dialogue. Verification can normally only check
+# that the domain exists.
+
+# sender_verify
+
+
+# Exim contains support for the Realtime Blocking List (RBL) that is being
+# maintained as part of the DNS. See http://maps.vix.com/rbl/ for background.
+# Uncommenting the first line below will make Exim reject mail from any
+# host whose IP address is blacklisted in the RBL at maps.vix.com. Some
+# others have followed the RBL lead and have produced other lists: DUL is
+# a list of dial-up addresses, and ORBS is a list of open relay systems. The
+# second line below checks all three lists.
+
+# rbl_domains = rbl.maps.vix.com
+# rbl_domains = rbl.maps.vix.com:dul.maps.vix.com:relays.orbs.org
# If you want Exim to support the "percent hack" for all your local domains,
@@ -107,7 +158,7 @@ host_accept_relay = "127.0.0.1/32"
# to x%y@z (where z is one of your local domains) is locally rerouted to
# x@y and sent on. Otherwise x%y is treated as an ordinary local part.
-# percent_hack_domains=*
+# percent_hack_domains = *
pid_file_path = /var/run/exim%s.pid
@@ -150,22 +201,20 @@ local_delivery:
mode = 0660
-# This transport is used for handling pipe addresses generated by alias
-# or .forward files. It has a conventional name, since it is not actually
-# mentioned elsewhere in this configuration file. (A different name *can*
-# be specified via the "address_pipe_transport" option if you really want
-# to.) If the pipe generates any standard output, it is returned to the sender
-# of the message as a delivery error. Set return_fail_output instead if you
-# want this to happen only when the pipe fails to complete normally.
+# This transport is used for handling pipe deliveries generated by alias
+# or .forward files. If the pipe generates any standard output, it is returned
+# to the sender of the message as a delivery error. Set return_fail_output
+# instead of return_output if you want this to happen only when the pipe fails
+# to complete normally. You can set different transports for aliases and
+# forwards if you want to - see the references to address_pipe below.
address_pipe:
driver = pipe
return_output
-# This transport is used for handling file addresses generated by alias
-# or .forward files. It has a conventional name, since it is not actually
-# mentioned elsewhere in this configuration file.
+# This transport is used for handling deliveries directly to files that are
+# generated by aliassing or forwarding.
address_file:
driver = appendfile
@@ -174,35 +223,8 @@ address_file:
return_path_add
-# This transport is used for handling file addresses generated by alias
-# or .forward files if the path ends in "/", which causes it to be treated
-# as a directory name rather than a file name. Each message is then delivered
-# to a unique file in the directory. If instead you want all such deliveries to
-# be in the "maildir" format that is used by some other mail software,
-# uncomment the final option below. If this is done, the directory specified
-# in the .forward or alias file is the base maildir directory.
-#
-# Should you want to be able to specify either maildir or non-maildir
-# directory-style deliveries, then you must set up yet another transport,
-# called address_directory2. This is used if the path ends in "//" so should
-# be the one used for maildir, as the double slash suggests another level
-# of directory. In the absence of address_directory2, paths ending in //
-# are passed to address_directory.
-
-address_directory:
- driver = appendfile
- delivery_date_add
- envelope_to_add
- return_path_add
- no_from_hack
- prefix = ""
- suffix = ""
-# maildir_format
-
-
# This transport is used for handling autoreplies generated by the filtering
-# option of the forwardfile director. It has a conventional name, since it
-# is not actually mentioned elsewhere in this configuration file.
+# option of the forwardfile director.
address_reply:
driver = autoreply
@@ -229,35 +251,49 @@ end
# If any of your aliases expand to pipes or files, you will need to set
# up a user and a group for these deliveries to run under. You can do
# this by uncommenting the "user" option below (changing the user name
-# as appropriate) and adding a "group" option if necessary.
+# as appropriate) and adding a "group" option if necessary. Alternatively, you
+# can specify "user" on the transports that are used. Note that those
+# listed below are the same as are used for .forward files; you might want
+# to set up different ones for pipe and file deliveries from aliases.
system_aliases:
driver = aliasfile
- file_transport = address_file
- pipe_transport = address_pipe
file = /etc/aliases
search_type = lsearch
-# user = XX_BINOWN_XX
+ file_transport = address_file
+ pipe_transport = address_pipe
+ user = XX_BINOWN_XX
# This director handles forwarding using traditional .forward files.
# If you want it also to allow mail filtering when a forward file
# starts with the string "# Exim filter", uncomment the "filter" option.
+
+# The no_verify setting means that this director will be skipped when
+# verifying addresses if sender_verify or receiver_verify is set (though
+# they are not set by default). Similarly, no_expn means that this director
+# will be skipped if smtp_expn_hosts is set to allow any hosts to use the
+# EXPN command.
+
# The check_ancestor option means that if the forward file generates an
# address that is an ancestor of the current one, the current one gets
# passed on instead. This covers the case where A is aliased to B and B
# has a .forward file pointing to A.
+# The three transports specified at the end are those that are used when
+# forwarding generates a direct delivery to a file, or to a pipe, or sets
+# up an auto-reply, respectively.
+
userforward:
driver = forwardfile
- file_transport = address_file
- pipe_transport = address_pipe
- reply_transport = address_reply
file = .forward
no_verify
no_expn
check_ancestor
# filter
+ file_transport = address_file
+ pipe_transport = address_pipe
+ reply_transport = address_reply
# This director matches local user mailboxes.
diff --git a/mail/exim/files/patch-aa b/mail/exim/files/patch-aa
index 7d19cace9958..a5edf3c681c3 100644
--- a/mail/exim/files/patch-aa
+++ b/mail/exim/files/patch-aa
@@ -1,6 +1,6 @@
---- scripts/exim_install.orig Tue Dec 8 16:05:07 1998
-+++ scripts/exim_install Tue Dec 8 16:09:49 1998
-@@ -186,25 +186,39 @@
+--- scripts/exim_install.orig Mon Aug 2 17:43:03 1999
++++ scripts/exim_install Tue Aug 3 14:31:20 1999
+@@ -195,25 +195,40 @@
fi
done
@@ -9,11 +9,12 @@
+# ${PREFIX}/etc/exim/configure is in place.
+echo $com ""
-+
+
+-# If there is no configuration file, install the default.
+if [ -f ${PREFIX}/etc/rc.d/exim.sh ]; then
+ echo $com "${PREFIX}/etc/rc.d/exim.sh exists, not overwritten"
+else
-+ echo $com "Installing exim.sh startup script in $PREFIX/etc/rc.d"
++ echo $com "Installing exim.sh startup script in ${PREFIX}/etc/rc.d"
+ ${real} mkdir -p ${PREFIX}/etc/rc.d
+ echo ${CP} -p exim.sh ${PREFIX}/etc/rc.d/
+ ${real} ${CP} -p exim.sh ${PREFIX}/etc/rc.d/
@@ -23,8 +24,9 @@
+ exit 1
+ fi
+fi
-
- # If there is no configuration file, install the default.
++
++# Install only a sample configuration, which encourages the admin to look
++# at it, since Exim won't run without a configure file.
echo $com ""
@@ -39,7 +41,7 @@
+ ${real} ${CP} ../src/configure.default ${CONFIGURE_FILE}.sample
if [ $? -ne 0 ]; then
echo $com ""
- echo $com "**** Exim installation ${ver}failed ****"
+ echo $com "*** Exim installation ${ver}failed ***"
exit 1
fi
-else
@@ -48,7 +50,7 @@
# Install info files if the directory is defined and the Texinfo
# source documentation is present.
-@@ -226,19 +240,21 @@
+@@ -235,19 +250,21 @@
echo $com Info installation directory is ${INFO_DIRECTORY}
echo $com ""