aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-09-18 08:58:46 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-09-18 08:58:46 +0000
commit4272c8683f95cf9cfc83d01085b9f2acc19ae742 (patch)
tree12da742c0ed2b7a5f7328756b1d40787a37711ae /mail/exim
parent03cf2e0916b5eadaaa5d50ad8034f0f648102053 (diff)
downloadports-4272c8683f95cf9cfc83d01085b9f2acc19ae742.tar.gz
ports-4272c8683f95cf9cfc83d01085b9f2acc19ae742.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 9b0f84d5eb07..6f0520889419 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -18,7 +18,7 @@ COMMENT?= High performance MTA for Unix systems on the Internet
LICENSE= GPLv2
-USES= cpe tar:bzip2 perl5
+USES= compiler cpe tar:bzip2 perl5
USE_PERL5= run
# Exim build system is job unsafe atm
@@ -151,9 +151,6 @@ CONFIG_FILE_PATH?= ${PREFIX}/etc/exim/configure
ALT_CONFIG_PREFIX?= ${PREFIX}/etc/exim/
EXIM_DYNAMIC_LDFLAGS= -fPIC -rdynamic -export-dynamic
-# Avoid too many warnings due to Exim code style
-EXIM_WARN_FLAGS?= -Wno-logical-op-parentheses -Wno-macro-redefined -Wno-parentheses -Wno-dangling-else
-CFLAGS+= ${EXIM_WARN_FLAGS}
SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DOCSDIR%%,${DOCSDIR},g' \
@@ -625,4 +622,12 @@ post-install:
.endif # ! defined(EXIMON_ONLY)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# If using clang, avoid too many warnings due to Exim code style
+.if ${CHOSEN_COMPILER_TYPE} == "clang"
+EXIM_WARN_FLAGS?= -Wno-logical-op-parentheses -Wno-macro-redefined -Wno-parentheses -Wno-dangling-else
+.endif
+CFLAGS+= ${EXIM_WARN_FLAGS}
+
+.include <bsd.port.post.mk>