aboutsummaryrefslogtreecommitdiff
path: root/mail/exim
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-16 17:03:19 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2018-04-16 17:03:19 +0000
commite34d2b1619d04f4ac6187b9c5fa5b48b699801c5 (patch)
tree68d02c7ec5104a9c69d38b3cb26c9a66d5838459 /mail/exim
parentdae51b46eb2705342121364bff10c8f71a94594b (diff)
downloadports-e34d2b1619d04f4ac6187b9c5fa5b48b699801c5.tar.gz
ports-e34d2b1619d04f4ac6187b9c5fa5b48b699801c5.zip
Notes
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile15
-rw-r--r--mail/exim/options4
2 files changed, 16 insertions, 3 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 592de52d1d29..0fb0287c4a63 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -3,6 +3,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= EXIM:exim
MASTER_SITE_SUBDIR= /exim4/:exim \
@@ -71,13 +72,19 @@ IGNORE= you cannot enable OCSP stapling with gnutls
.endif
.endif
-# DMARC implies SPF
+# DMARC implies SPF and DKIM
.if ${PORT_OPTIONS:MDMARC}
.if ! ${PORT_OPTIONS:MSPF} || ! ${PORT_OPTIONS:MDKIM}
IGNORE= you cannot enable DMARC without SPF and DKIM support
.endif
.endif
+# ARC implies SPF and DKIM
+.if ${PORT_OPTIONS:MARC}
+.if ! ${PORT_OPTIONS:MSPF} || ! ${PORT_OPTIONS:MDKIM}
+IGNORE= you cannot enable ARC without SPF and DKIM support
+.endif
+.endif
# DANE implies DNSSEC
.if ${PORT_OPTIONS:MDANE}
.if ! ${PORT_OPTIONS:MDNSSEC} || ! ${PORT_OPTIONS:MTLS}
@@ -210,6 +217,10 @@ SEDLIST+= -e 's,^\# (EXPERIMENTAL_DSN=),\1,'
SEDLIST+= -e 's,^\# (EXPERIMENTAL_DANE=),\1,'
.endif
+.if ${PORT_OPTIONS:MARC}
+SEDLIST+= -e 's,^\# (EXPERIMENTAL_ARC=),\1,'
+.endif
+
.if !${PORT_OPTIONS:MEVENT}
SEDLIST+= -e 's,^\# (DISABLE_EVENT=),\1,'
.endif
@@ -460,7 +471,7 @@ SEDLIST+= -e 's,^(ALT_CONFIG_PREFIX=),\# \1,'
.if ${PORT_OPTIONS:MSPF}
SEDLIST+= -e 's,XX_SPF_FLAGS_XX,-DSPF,' \
-e 's,XX_SPF_LIBS_XX,-L${LOCALBASE}/lib -lspf2 -lpthread,' \
- -e 's,^\# (EXPERIMENTAL_SPF=),\1,'
+ -e 's,^\# (SUPPORT_SPF=),\1,'
.else
SEDLIST+= -e 's,XX_SPF_FLAGS_XX,,' \
-e 's,XX_SPF_LIBS_XX,,'
diff --git a/mail/exim/options b/mail/exim/options
index 38452b4db72b..cb6c0c267dc4 100644
--- a/mail/exim/options
+++ b/mail/exim/options
@@ -4,6 +4,7 @@ OPTIONS_DEFINE+= ALT_CONFIG_PREFIX \
DEBUG \
DISABLE_D_OPT \
DKIM \
+ SPF \
DNSSEC \
DOCS \
EMBEDDED_PERL \
@@ -65,11 +66,12 @@ OPTIONS_GROUP_LOOKUP= CDB BDB DNSDB DSEARCH LSEARCH MYSQL NIS OPENLDAP PGSQL RED
LOOKUP_DESC= Lookup support
OPTIONS_GROUP_STORAGE= MAILDIR MAILSTORE MBX
STORAGE_DESC= Supported storage formats
-OPTIONS_GROUP_EXPERIMENTAL= CERTNAMES DANE DCC DMARC DSN SPF LMDB QUEUEFILE
+OPTIONS_GROUP_EXPERIMENTAL= CERTNAMES DANE DCC DMARC DSN ARC LMDB QUEUEFILE
EXPERIMENTAL_DESC= Experimental options
OPTIONS_GROUP= AUTH LOOKUP STORAGE EXPERIMENTAL
ALT_CONFIG_PREFIX_DESC= Restrict the set of configuration files
+ARC_DESC= Enable experimental ARC support
AUTH_CRAM_MD5_DESC= Enable CRAM-MD5 authentication mechanisms
AUTH_DOVECOT_DESC= Enable Dovecot authentication mechanisms
AUTH_PLAINTEXT_DESC= Enable plaintext authentication