aboutsummaryrefslogtreecommitdiff
path: root/mail/extmail/Makefile
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-24 16:00:16 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-24 16:00:16 +0000
commit20974c9bbfeb57050f419baa9268b5b7ce01aac4 (patch)
tree203246c28b3c82f60d573dc265237b23b4f14b28 /mail/extmail/Makefile
parent15cb85e984c9447f16ae65a772cfc08204419d5e (diff)
- Update to 1.1.1
PR: ports/140624 Submitted by: Chifeng Qu <chifeng AT gmail.com> (maintainer) Approved by: lwhsu/rafan (mentors, implicit)
Notes
Notes: svn path=/head/; revision=244720
Diffstat (limited to 'mail/extmail/Makefile')
-rw-r--r--mail/extmail/Makefile38
1 files changed, 31 insertions, 7 deletions
diff --git a/mail/extmail/Makefile b/mail/extmail/Makefile
index f924891af662..b3d2e35ab459 100644
--- a/mail/extmail/Makefile
+++ b/mail/extmail/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= extmail
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.1
CATEGORIES= mail
MASTER_SITES= http://www.chifeng.name/dist/extmail/ \
http://mirror3.extmail.net/dist/
-MAINTAINER?= chifeng@gmail.com
+MAINTAINER= chifeng@gmail.com
COMMENT= A high performance webmail system
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
@@ -23,8 +23,6 @@ NO_BUILD= yes
OPTIONS= MYSQL "Use MySQL support" On \
LDAP "Use LDAP support" Off
-SUB_FILES= pkg-message
-
.include <bsd.port.pre.mk>
.if defined(WITH_MYSQL)
@@ -35,8 +33,34 @@ RUN_DEPENDS+= ${SITE_PERL}/DBD/LDAP.pm:${PORTSDIR}/databases/p5-DBD-LDAP
.endif
do-install:
- @${MKDIR} ${WWWDIR}
- @cd ${WRKSRC} && ${CP} -Rfp * ${WWWDIR}
- @${CAT} ${PKGMESSAGE}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR:S,^${PREFIX}/,%D/,}' >> ${TMPPLIST}
+
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR:S,^${PREFIX}/,%D/,} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+
+ @${FIND} \
+ ${WWWDIR}/cgi \
+ ${WWWDIR}/tools \
+ ${WWWDIR}/dispatch-init \
+ ${WWWDIR}/dispatch.fcgi \
+ ${WWWDIR}/dispatch_lig.sh \
+ -type f -print0 | ${XARGS} -0 ${CHMOD} +x
+ @${ECHO_CMD} '@exec ${FIND} \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/cgi \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/tools \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/dispatch-init \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/dispatch.fcgi \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/dispatch_lig.sh \
+ -type f -print0 | ${XARGS} -0 ${CHMOD} +x' >> ${TMPPLIST}
+
+post-install:
+ @if [ ! -f ${WWWDIR}/webmail.cf ]; then \
+ ${CP} -p ${WWWDIR}/webmail.cf.default ${WWWDIR}/webmail.cf ; \
+ ${CHMOD} +w ${WWWDIR}/webmail.cf ; \
+ fi
.include <bsd.port.post.mk>