aboutsummaryrefslogtreecommitdiff
path: root/mail/extman/Makefile
diff options
context:
space:
mode:
authorYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-23 16:09:21 +0000
committerYi-Jheng Lin <yzlin@FreeBSD.org>2009-11-23 16:09:21 +0000
commit12e697d002d495a5463dfe1403c837e6663b346d (patch)
treeb4dcd32ea470587a5f72d13ff715bab6980970c6 /mail/extman/Makefile
parent8e2c6eeca10100647dab8eef88b46c40951a4a34 (diff)
Notes
Diffstat (limited to 'mail/extman/Makefile')
-rw-r--r--mail/extman/Makefile33
1 files changed, 31 insertions, 2 deletions
diff --git a/mail/extman/Makefile b/mail/extman/Makefile
index be9b43ff8b64..39a3e59cdf5f 100644
--- a/mail/extman/Makefile
+++ b/mail/extman/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= extman
-PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= mail
MASTER_SITES= http://www.chifeng.name/dist/extman/%SUBDIR%/ \
http://mirror3.extmail.net/dist/%SUBDIR%/
@@ -29,12 +28,42 @@ OPTIONS= MySQL "Use MySQL support" On \
.if defined(WITH_MySQL)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
+
.if defined(WITH_LDAP)
RUN_DEPENDS+= ${SITE_PERL}/DBD/LDAP.pm:${PORTSDIR}/databases/p5-DBD-LDAP
.endif
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR:S,^${PREFIX}/,%D/,}' >> ${TMPPLIST}
+
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${WWWDIR:S,^${PREFIX}/,%D/,} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+
+ @${FIND} \
+ ${WWWDIR}/cgi \
+ ${WWWDIR}/contrib \
+ ${WWWDIR}/tools \
+ ${WWWDIR}/addon/mailgraph_ext/mailgraph-init \
+ ${WWWDIR}/addon/mailgraph_ext/mailgraph_ext.pl \
+ ${WWWDIR}/addon/mailgraph_ext/qmonitor.pl \
+ -type f -print0 | ${XARGS} -0 ${CHMOD} +x
+ @${ECHO_CMD} '@exec ${FIND} \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/cgi \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/contrib \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/tools \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/addon/mailgraph_ext/mailgraph-init \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/addon/mailgraph_ext/mailgraph_ext.pl \
+ ${WWWDIR:S,^${PREFIX}/,%D/,}/addon/mailgraph_ext/qmonitor.pl \
+ -type f -print0 | ${XARGS} -0 ${CHMOD} +x' >> ${TMPPLIST}
+
+post-install:
+ @if [ ! -f ${WWWDIR}/webman.cf ]; then \
+ ${CP} -p ${WWWDIR}/webman.cf.default ${WWWDIR}/webman.cf ; \
+ ${CHMOD} +w ${WWWDIR}/webman.cf ; \
+ fi
.include <bsd.port.post.mk>